Results 1 to 7 of 7

Thread: openSuse does not boot after installing on double boot with Windows10

  1. #1

    Default openSuse does not boot after installing on double boot with Windows10

    Hi

    I have Windows 10 running on first 500GB of my laptop and wanted to install openSuse 13.2 using double boot on second 500GB of same disk. I assume that openSuse 13.2 supports UEFI but I had forgotten to disable secure boot. So the boot manager only lists Windows 10 and I can't boot Linux. I now have disabled secure boot and tried booting from the installation-DVD in update mode but I do not know how to proceed from the shell prompt of the temporaty RAM-installation. Can any one please tell me in detail what I have to do?

    Many thanks in advance.

    Regards
    golpecito

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 9
    Posts
    14,582

    Default Re: openSuse does not boot after installing on double boot with Windows10

    First off 13.2 is no longer supported.

    Second Did you perhaps install in legacy mode? ie MBR boot rather the EFI boot. OSs can not chain if they do not use the same boot method. In Yast-boot loader it should show grub2-efi if in EFI mode else it will be just grub2 for legacy

    Also be sure you turned off Fast boot in Windows. This option leaves the Windows partition in unknown condition and Linux will not be able to read it or boot to it or mount it

  3. #3

    Default Re: openSuse does not boot after installing on double boot with Windows10

    Quote Originally Posted by gogalthorp View Post
    First off 13.2 is no longer supported.

    Second Did you perhaps install in legacy mode? ie MBR boot rather the EFI boot. OSs can not chain if they do not use the same boot method. In Yast-boot loader it should show grub2-efi if in EFI mode else it will be just grub2 for legacy

    Also be sure you turned off Fast boot in Windows. This option leaves the Windows partition in unknown condition and Linux will not be able to read it or boot to it or mount it
    Hi

    you are not replying to my question. You haven't read my problem.

    Thanks

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    9,161
    Blog Entries
    3

    Default Re: openSuse does not boot after installing on double boot with Windows10

    Quote Originally Posted by golpecito View Post
    I assume that openSuse 13.2 supports UEFI but I had forgotten to disable secure boot.
    Yes, openSUSE 13.2 supports UEFI. And it also supports secure-boot.

    If you had secure-boot enabled on your computer, then you would not have been able to boot the installer if it did not supports secure-boot.

    Most likely you have run into a limitation in your UEFI firmware (or BIOS). Some systems will boot any UEFI system as long as it is Windows. Most are less restrictive.

    You should tell us something about the manufacturer or brand name of your computer, and other information such as model number. Maybe someone will recognize it and be familiar with the limitations of its UEFI support.

    So the boot manager only lists Windows 10 and I can't boot Linux.
    Which boot manager is that?

    On my UEFI boxes, I can hit F12 during boot, and the firmware (or BIOS) provides a boot menu. Is that what you are calling a boot manager?
    I now have disabled secure boot and tried booting from the installation-DVD in update mode but I do not know how to proceed from the shell prompt of the temporaty RAM-installation. Can any one please tell me in detail what I have to do?
    After booting the install DVD, get to a command prompt. If you are in the graphic installer interface, then CTRL-ALT-F2 will get you a command prompt.

    Then run the command:
    Code:
    efibootmgr -v
    and post the output here. Either write it down to post later, or redirect the output of the command to a file on a USB flash drive so that you can copy it at a later time for posting. That output will give us some idea about the status of your 13.2 installation.

    You would be better off trying opensuse Leap 42.3, which is still currently supported. However, you might run into the same problems, particularly if they are due to BIOS limitations.
    opensuse Leap 42.3; KDE Plasma 5;
    opensuse tumbleweed; KDE Plasma 5 (test system);

  5. #5

    Default Re: openSuse does not boot after installing on double boot with Windows10

    Quote Originally Posted by nrickert View Post
    Yes, openSUSE 13.2 supports UEFI. And it also supports secure-boot.

    If you had secure-boot enabled on your computer, then you would not have been able to boot the installer if it did not supports secure-boot.

    Most likely you have run into a limitation in your UEFI firmware (or BIOS). Some systems will boot any UEFI system as long as it is Windows. Most are less restrictive.

    You should tell us something about the manufacturer or brand name of your computer, and other information such as model number. Maybe someone will recognize it and be familiar with the limitations of its UEFI support.


    Which boot manager is that?

    On my UEFI boxes, I can hit F12 during boot, and the firmware (or BIOS) provides a boot menu. Is that what you are calling a boot manager?

    After booting the install DVD, get to a command prompt. If you are in the graphic installer interface, then CTRL-ALT-F2 will get you a command prompt.

    Then run the command:
    Code:
    efibootmgr -v
    and post the output here. Either write it down to post later, or redirect the output of the command to a file on a USB flash drive so that you can copy it at a later time for posting. That output will give us some idea about the status of your 13.2 installation.

    You would be better off trying opensuse Leap 42.3, which is still currently supported. However, you might run into the same problems, particularly if they are due to BIOS limitations.
    I tried booting in legacy mode from the DVD selecting 'Recovery' and entered text mode and logged-in as root w/o password. Typing
    Code:
    efibootmgr -v
    the system replied:
    Code:
    Fatal: Couldn't open eithersysfs or procfs directory
    Code:
    Try 'modprobe efivars'
    which also failed.

    I will now try opensuse 42.3 but I want first to get rid of the broken installation. What tool can I use (and where can I get it from) to delete the partitions of the broken opensuse installation?

    I am using an ACER Model E5-574G-74LJ "Aspire E5-574G" with 8GB RAM, 1TB Disk and Windows 10.

    Many thanks for your help.

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    9,161
    Blog Entries
    3

    Default Re: openSuse does not boot after installing on double boot with Windows10

    Quote Originally Posted by golpecito View Post
    Typing
    Code:
    efibootmgr -v
    the system replied:
    Code:
    Fatal: Couldn't open eithersysfs or procfs directory
    Sorry, I didn't explain well enough. You do have to boot in UEFI mode to be able to use that command.

    I will now try opensuse 42.3 but I want first to get rid of the broken installation. What tool can I use (and where can I get it from) to delete the partitions of the broken opensuse installation?
    You can actually delete those in the installer (either 13.2 or 42.3 installer). Maybe boot to the rescue system, and use the "fdisk" command to delete partitions. Or boot the live Tumbleweed rescue CD, and run Yast partitioner to delete unwanted partitions.

    I am using an ACER Model E5-574G-74LJ "Aspire E5-574G" with 8GB RAM, 1TB Disk and Windows 10.
    I don't have an personal experience with ACER. But there have been some earlier threads. Possibly, there is someone reading this who does have experience and can offer help.
    opensuse Leap 42.3; KDE Plasma 5;
    opensuse tumbleweed; KDE Plasma 5 (test system);

  7. #7

    Default Re: openSuse does not boot after installing on double boot with Windows10

    If you need to recover for now the Windows Boot then you will need to do it from a Windows recovery media.

    An advice to install in dual boot with UEFI:

    Use /dev/sda2 where is EFI installed.

    On BIOS if you have disabled Secure Boot, enable it and disable legacy mode.

    Try to follow this guide:


    For your case:
    To check the partitions, let openSUSE installation detects all and after go to create partition setup -> custom partitions, you will find the current partitions and you can edit them. Edit only Linux partitions to format/resize them and optionally configure a mount point for your windows partition.

    On installation settings, edit system. Use Grub2 for UEFI as bootloader and enable support for secure boot. On bootloader options, check scan for foreign operating system.

    After that you can customize the software and etc. After that yo can proceed to install. Once finished you can login on openSUSE and if you reboot you can see the Grub2 and boot from Windows or SUSE.

    The dual boot should work on any PC (HP, Toshiba, Lenovo...)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •