Results 1 to 2 of 2

Thread: Installation of Arduino fails due to "nothing provides jna > 4.2.1"

  1. #1

    Question Installation of Arduino fails due to "nothing provides jna > 4.2.1"

    When I try to install the Arduino package from CrossToolchain:avr, it fails with "Problem: nothing provides jna > 4.2.1 needed by Arduino-1.8.5-1.1.x86_64." The highest jna version I find available for Leap 42.2 is 4.1.0:
    Code:
    linux-pvlm:~> zypper se -s jna
    Loading repository data...
    Reading installed packages...
    
    S | Name        | Type    | Version   | Arch   | Repository           
    --+-------------+---------+-----------+--------+----------------------
      | jna         | package | 4.1.0-7.2 | noarch | Main Repository (OSS)
      | jna-javadoc | package | 4.1.0-7.2 | noarch | Main Repository (OSS)
    However, the Open Build Service (OBS) page for that package, https://build.opensuse.org/package/s...%3Aavr/Arduino, indicates that the build for Leap 42.2 succeeded.

    I don't understand how an OBS build for a Leap 42.2 package requiring jna > 4.2.1 can succeed when that particular jna version is not available.

    And, because of that lack of understanding, I don't know what I might do, if anything, to get the Arduino package installed.

    Any ideas?


    P.S.
    Code:
    zypper lr
    Repository priorities in effect:                                               (See 'zypper lr -P' for details)
          98 (raised priority)  :  1 repository  
          99 (default priority) :  6 repositories
    
    #  | Alias                           | Name                                    | Enabled | GPG Check | Refresh
    ---+---------------------------------+-----------------------------------------+---------+-----------+--------
     1 | CrossToolchain:avr              | CrossToolchain:avr                      | Yes     | (r ) Yes  | Yes    
     2 | KDE:Extra                       | KDE:Extra                               | Yes     | (r ) Yes  | Yes    
     3 | download.opensuse.org-non-oss   | Main Repository (NON-OSS)               | Yes     | (r ) Yes  | Yes    
     4 | download.opensuse.org-non-oss_1 | Update Repository (Non-Oss)             | Yes     | (r ) Yes  | Yes    
     5 | download.opensuse.org-oss       | Main Repository (OSS)                   | Yes     | (r ) Yes  | Yes    
     6 | download.opensuse.org-oss_1     | Main Update Repository                  | Yes     | (r ) Yes  | Yes    
     7 | openSUSE-42.2-0                 | openSUSE-42.2-0                         | No      | ----      | ----   
     8 | packman.inode.at-suse           | Packman Repository                      | Yes     | (r ) Yes  | Yes    
     9 | repo-debug                      | openSUSE-Leap-42.2-Debug                | No      | ----      | ----   
    10 | repo-debug-non-oss              | openSUSE-Leap-42.2-Debug-Non-Oss        | No      | ----      | ----   
    11 | repo-debug-update               | openSUSE-Leap-42.2-Update-Debug         | No      | ----      | ----   
    12 | repo-debug-update-non-oss       | openSUSE-Leap-42.2-Update-Debug-Non-Oss | No      | ----      | ----   
    13 | repo-source                     | openSUSE-Leap-42.2-Source               | No      | ----      | ----   
    14 | repo-source-non-oss             | openSUSE-Leap-42.2-Source-Non-Oss       | No      | ----      | ----
    (Packman repo is Priority 98)

    Lee

  2. #2

    Default Re: Installation of Arduino fails due to "nothing provides jna > 4.2.1"

    Update:

    I just found jna 4.2.2 listed in the unstable packages section at https://software.opensuse.org/package/jna

    Don't know why I didn't find it before, but...

    Arduino is now installed.

    Lee

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •