Results 1 to 3 of 3

Thread: problem with apache under openSUSE leap 42.3

  1. #1

    Default problem with apache under openSUSE leap 42.3

    I can not start the installation process of version 9.2 of the glpi application under openSUSE leap 42.3.

    I receive the following message after the replacement in the folder /srv/www/htdocs of files of version 0.9 of glpi by those of version 9.2 :

    Access forbidden!

    You do not have the right to access the requested directory. Either there is no index document or the directory is protected.

    If you think this is a server error, please contact the webmaster.
    Error 403


    at the apache log file, I have the following error:

    AH01276: Can not serve directory / srv / www / htdocs /: No matching DirectoryIndex (index.html, index.html.var) found, and server-generated directory index forbidden by Options directive


    I tried several solutions found on the net for other linux distributions of the kind, checking the rights and the owner of the htdocs folder, the AllowOverride directive and other changes to the apache configuration files, the modification of the files. htaccess but none of them worked for the openSUSE leap 42.3 distribution,

    there.

    if anyone has ever encountered this problem, I am a taker,

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,188

    Default Re: problem with apache under openSUSE leap 42.3

    A few ideas that come to mind;
    - It's a PHP application and you don't have PHP (apache module in this particular case) installed.
    - You are browsing to the wrong directory and the glpi is located in a subdirectory, what does your directory structure in /srv/www/htdocs/ look like?

    Possibly:
    - You may have installed PHP but not the apache2-mod_php5 module
    - You installed it after installing everything else but it doesn't get activated, in that case; sudo a2enmod php5 ; systemctl restart apache2
    .: miuku @ #opensuse @ irc.libera.chat

  3. #3

    Default Re : Re: problem with apache under openSUSE leap 42.3

    effectively,

    I installed php7 instead of php5 because glpi version 9.2 required it but I forgot to activate php7.

    the problem is solved by executing the commands:
    sudo a2enmod php5
    systemctl restart apache2

    Thank you very much for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •