Results 1 to 2 of 2

Thread: Unable to change the charmap and locale after update

  1. #1

    Unhappy Unable to change the charmap and locale after update

    So I've updated from 42.1 to 42.3 and something is definitely broken in the locales department. Basically the system runs with ASCII 7-bit character map now (so obviously everything else just becomes "?") and denies all attempts to change it.

    Code:
    nikita@linux-w0r5:~> locale 
    LANG=C 
    LC_CTYPE="C" 
    LC_NUMERIC="C" 
    LC_TIME="C" 
    LC_COLLATE="C" 
    LC_MONETARY="C" 
    LC_MESSAGES="C" 
    LC_PAPER="C" 
    LC_NAME="C" 
    LC_ADDRESS="C" 
    LC_TELEPHONE="C" 
    LC_MEASUREMENT="C" 
    LC_IDENTIFICATION="C" 
    LC_ALL=
    nikita@linux-w0r5:~> locale charmap 
    ANSI_X3.4-1968
    /ets/sysconfig/ has en_GB.UTF8 set for everything, but the OS doesn't seem to care about that. Trying to set the variables through console (both with "export" and the localectl thing) resulted in effectively zero effect. It appears to change the settings (at least locale and locale charmap give what I told them to) but it doesn't fix anything and once I restart the terminal the ASCII is back. I've tried just about everything I managed to find on the Net, nothing seems to work. Any suggestions would be very helpful. AFAIK this isn't caused by the update specifically on this notebook, since it seems to have the same problem on the other notebook I updated recently. Could it be some sort of an issue with the live USB I used?

  2. #2

    Default Re: Unable to change the charmap and locale after update

    Okay, it's kinda stupid. KDE was set to "Default(C)" for some reason, never seen that in previous versions. Also never thought KDE could overwright YaST.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •