Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Unable to set Monitor Resolution size

  1. #1
    Join Date
    May 2016
    Location
    Chennai, TN, India
    Posts
    76

    Default Unable to set Monitor Resolution size

    After upgrading to Leap 42.3, I'm facing issues with setting the monitor resolution. I'm using HDMI to connect CPU and monitor, whose resolution is 1360x768_60.00 Please find the output of command
    Code:
    oo@linux-xahq:~> xrandr -q
    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
    default connected primary 1024x768+0+0 0mm x 0mm
       1024x768      76.00*
    I tried to set the monitor resolution in /etc/X11/xorg.conf.d/50-monitor.conf as
    Code:
    #Section "Monitor"
    #  Identifier "Default Monitor"
    #
    #  ## If your monitor doesn't support DDC you may override the
    #  ## defaults here
    #  #  HorizSync 28-85
    #  #  VertRefresh 50-100
    #  ## Add your mode lines here, use e.g the cvt tool
    #  ##  Modeline "1360x768"x60.4   86.00  1360 1424 1536 1792  768 771 777 795 +hsync +vsync (48.0 kHz eP)
    #  #  xrandr --newmode "1360x768_60.00"  84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync 
    #  #  xrandr --addmode HDMI-0 1360x768_60.00
    #  #  xrandr --output HDMI-0 --mode 1360x768_60.00  
    #
    #EndSection
    I'm missing something, because of which unable to set monitor resolution. Do you need any other info to fix this?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Unable to set Monitor Resolution size

    Quote Originally Posted by linlen View Post
    After upgrading to Leap 42.3, I'm facing issues with setting the monitor resolution. I'm using HDMI to connect CPU and monitor, whose resolution is 1360x768_60.00 Please find the output of command
    Code:
    oo@linux-xahq:~> xrandr -q
    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
    default connected primary 1024x768+0+0 0mm x 0mm
       1024x768      76.00*
    I tried to set the monitor resolution in /etc/X11/xorg.conf.d/50-monitor.conf as [CODE]#Section "Monitor"
    We really need to figure out why xrandr does not get the correct display modes from the monitor before trying to configure manually. My advice is to examine /var/log/Xorg.0.log first. That will show EDID related discovery.

    I'm missing something, because of which unable to set monitor resolution. Do you need any other info to fix this?
    You can't put xrandr commands in an Xorg config file like that. You can add such commands to a script file and have it execute at login if desired, but a good idea to try them from a terminal (as user) first before trying to make them permanent.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Unable to set Monitor Resolution size

    Quote Originally Posted by deano_ferrari View Post
    We really need to figure out why xrandr does not get the correct display modes from the monitor before trying to configure manually. My advice is to examine /var/log/Xorg.0.log first. That will show EDID related discovery.
    Further to this you may well have a driver-related issue here. For example, a basic framebuffer driver may be in use. Examination of the Xorg log will be helpful. If you want to share this lengthy output, I recommend uploading to https://paste.opensuse.org/, change the 'Delete After' value to something sensible, and share the link to it here for others to review.

  4. #4
    Join Date
    May 2016
    Location
    Chennai, TN, India
    Posts
    76

    Default Re: Unable to set Monitor Resolution size

    Please find Xorg.O.log file at https://paste.opensuse.org/29985859 . Many Thanks!!!

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Unable to set Monitor Resolution size

    Quote Originally Posted by linlen View Post
    Please find Xorg.O.log file at https://paste.opensuse.org/29985859 . Many Thanks!!!
    Okay, so you have AMD graphics hardware. If you examine the 'LoadModule' and 'UnloadModule' entries, you'll note that the radeon driver is loaded and unloaded again, and that the framebuffer (FBDEV) driver is used instead.

    Code:
    1. [ 24.095] (--) FBDEV(0): Virtual size is 1024x768 (pitch 1024)
    2. [ 24.095] (**) FBDEV(0): Built-in mode "current": 78.7 MHz, 59.9 kHz, 75.7 Hz
    3. [ 24.095] (II) FBDEV(0): Modeline "current"x0.0 78.65 1024 1056 1184 1312 768 772 776 792 -hsync -vsync -csync (59.9 kHz b)
    You have the 'nomodeset' kernel boot option loaded, which is preventing the KMS radeon driver from loading....
    Code:
    [    23.947] Kernel command line:  BOOT_IMAGE=/boot/vmlinuz-4.4.92-31-default  root=UUID=86b32f39-ade7-4b6d-b946-72adcf205c25 ro resume=/dev/sda2  splash=silent nomodeset quiet showopts
    You should try removing this via YaST > System > Bootloader and reboot when done.

  6. #6
    Join Date
    May 2016
    Location
    Chennai, TN, India
    Posts
    76

    Default Re: Unable to set Monitor Resolution size

    I'm unable to open Yast Bootloader. The error I'm getting is
    Code:
    Details : Augeas parsing/serializing error: Get did not match entire input at /usr/share/augeas/lenses/dist/sysconfig.aug:63.12-.71:
    
    Caller: /usr/lib64/ruby/gems/2.1.0/gems/cfa-0.3.1/lib/cfa/augeaus_parser.rb:236:in 'report_error'
    I couldn't figure out the issue. Also facing issue with the below command:
    Code:
    grub2-mkconfig -o /boot/grub2/grub.cfg   
    insmod: ERROR: could not load module part_gpt: No such file or directory

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Unable to set Monitor Resolution size

    Quote Originally Posted by linlen View Post
    I'm unable to open Yast Bootloader. The error I'm getting is
    Code:
    Details : Augeas parsing/serializing error: Get did not match entire input at /usr/share/augeas/lenses/dist/sysconfig.aug:63.12-.71:
    
    Caller: /usr/lib64/ruby/gems/2.1.0/gems/cfa-0.3.1/lib/cfa/augeaus_parser.rb:236:in 'report_error'
    Gecko Linux installed? Seems similar to this thread...
    https://forums.opensuse.org/showthre...ader-quot-menu

    You might need to start another thread with descriptive title for this particular issue to get the required advice.
    Last edited by deano_ferrari; 18-Nov-2017 at 01:31.

  8. #8
    Join Date
    May 2016
    Location
    Chennai, TN, India
    Posts
    76

    Default Re: Unable to set Monitor Resolution size

    No,I didn't install Gecko Linux. I've been using 42.2 and upgraded to 42.3 using zypper dup. Only opensuse and no other OS.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,339
    Blog Entries
    15

    Default Re: Unable to set Monitor Resolution size

    Hi
    What about the ncurses version.... open a terminal and switch to root user (su - [not su or sudo]) then run the command;
    Code:
    yast bootloader
    Use the tab and arrow keys for navigation.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10
    Join Date
    May 2016
    Location
    Chennai, TN, India
    Posts
    76

    Default Re: Unable to set Monitor Resolution size

    No, it's not working. Getting the same error. Learned something new about ncurses.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •