Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: How to enable palm rejection for Touchpad in Leap 42.3?

  1. #1

    Default How to enable palm rejection for Touchpad in Leap 42.3?

    Can someone tell me how to enable Touchpad Palm Rejection in OpenSUSE Leap 42.3, using Gnome desktop? Its very annoying while typing.

    Here is my device:

    "
    I: Bus=0011 Vendor=0002 Product=0007 Version=01b1N: Name="SynPS/2 Synaptics TouchPad"
    P: Phys=isa0060/serio1/input0
    S: Sysfs=/devices/platform/i8042/serio1/input/input2
    U: Uniq=
    H: Handlers=mouse0 event1
    B: PROP=5
    B: EV=b
    B: KEY=e520 10000 0 0 0 0 B: ABS=660800011000003
    "

    The touchpad settings in OpenSUSE are very limited. Here is what options I have.
    https://ibb.co/kMJuk6

    In KDE I also tried and the palm rejection (detection) was not working at all. (Currently I am using Gnome)

    I found some synaptic applications in the OpenSUSE repositories.

    I tried installing "xf86-input-synaptics" (which failed)

    Then tried installing "gsynaptics" (which gives error "GSynaptics couldn't initialize. You have to set 'SHMConfig' 'true' in xorg.conf or XF86Config to use GSynaptics").

    Can someone provide some guidance into how to enable palm-rejection?

    Thanks!


  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: How to enable palm rejection for Touchpad in Leap 42.3?

    I haven't configured what I think you're trying to describe for many years,
    But "back then" I found that sometimes the desired setting would be in the Desktop mouse settings like what your screenshot probably is, and other times in synaptic settings (IIRC there was something called "synaptic toolbox") which were sometimes integrated and other times not integrated into Desktop mouse settings.

    Also, you might be looking for something called "sensitivity" which is different than, but close enough to the "palm setting" you want but may not exist.

    If no configuration can be found, the <best> solution by far (and many people I've known share my opinion) is to just use tape as a hinge for an index card that can flap over the touchpad. It's the only solution I know that works 100% with no grey area accidentally activating the touchpad.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    2,238

    Default Re: How to enable palm rejection for Touchpad in Leap 42.3?

    When LEAP abandoned the synaptics driver for libinput we lost some of the finer settings that we were used to... including palm rejection.
    So no hope for gsynaptics and related tools to work; SLED 12 kept the synaptics driver with mixed results, but are abandoning it in SLE15 AFAIK.
    In my laptop I can still disable the touchpad with Fn+F9, but that is vendor dependent and your mileage might vary.
    Tumbleweed Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.3

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: How to enable palm rejection for Touchpad in Leap 42.3?

    The Xorg libinput driver handles most input devices now, and palm detection is enabled by default.

    https://www.freedesktop.org/wiki/Sof...alm-detection/

    There is always the possibility that your touchpad device isn't being handled correctly and a bug report may be required.

  5. #5
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    2,238

    Default Re: How to enable palm rejection for Touchpad in Leap 42.3?

    Quote Originally Posted by deano_ferrari View Post
    The Xorg libinput driver handles most input devices now, and palm detection is enabled by default.

    https://www.freedesktop.org/wiki/Sof...alm-detection/

    There is always the possibility that your touchpad device isn't being handled correctly and a bug report may be required.
    Nice to know, but... what I see here on Leap 42.2 is:
    Code:
    LT_B:~ # libinput-list-devices
    ...
    Device:           ETPS/2 Elantech Touchpad
    Kernel:           /dev/input/event1
    Group:            7
    Seat:             seat0, default
    Size:             99.90x66.22mm
    Capabilities:     pointer 
    Tap-to-click:     disabled
    Tap-and-drag:     enabled
    Tap drag lock:    disabled
    Left-handed:      disabled
    Nat.scrolling:    disabled
    Middle emulation: disabled
    Calibration:      n/a
    Scroll methods:   *two-finger edge 
    Click methods:    *button-areas clickfinger 
    Disable-w-typing: enabled
    Accel profiles:   none
    Rotation:         n/a
    
    LT_B:~ #
    I don't know if "Palm Rejection" translates to "Disable-w-typing", but that doesn't seem to work here nor I see any way to change any parameter about that setting...
    Tumbleweed Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.3

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: How to enable palm rejection for Touchpad in Leap 42.3?

    Yes, libinput has fewer customizable options than the evdev and synaptics drivers did, but there is supposedly more built-in code to process/filter muti-touch events, with palm detection being one of them. It is possible to configure a particular device to be handled by the deprecated input drivers if required, but the best way forward is to submit a bug report if you believe the behaviour could be better.


    https://bugs.freedesktop.org/

  7. #7

    Default Re: How to enable palm rejection for Touchpad in Leap 42.3?

    Quote Originally Posted by deano_ferrari View Post
    Yes, libinput has fewer customizable options than the evdev and synaptics drivers did, but there is supposedly more built-in code to process/filter muti-touch events, with palm detection being one of them. It is possible to configure a particular device to be handled by the deprecated input drivers if required, but the best way forward is to submit a bug report if you believe the behaviour could be better.


    https://bugs.freedesktop.org/

    Thanks Deano, according to the link you provided for libinput Palm Detection the way it works is simple. By simply ignoring touches that start on the sides of a touchpad (I never thought of 'how' it worked before).

    I tested this with my palm while typing or just by touching and the perimeter and moving in. It is definitely not working. I dual boot with Windows and palm rejection is working just fine with windows, but not OpenSUSE. Strangely I don't remember Ubuntu 16.04 being a problem.

    I will submit a bug report as you suggested.

    I was searching online and noticed several posts with users complaining (some with other distros) of palm rejection working just fine for years, then now its a problem again.


    It makes sense when 'OrsoBruno' explained they did things like abandoned synaptics driver. I wonder what the purpose of that was?...

    Also since this is an issue with libinput under X.org is it even going to be an issue when they switch to Wayland (eventually)? Or will any of these drivers remain the same under that new Window Manager?

    I am not sure how that works.

  8. #8
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    2,238

    Default Re: How to enable palm rejection for Touchpad in Leap 42.3?

    Just for the sake of discussion, this is what we were used to with the synaptics driver (got from a test SLED 12SP3):
    Code:
    sletest@linux:~> synclient
    Parameter settings:
    ...
        PalmDetect              = 1
        PalmMinWidth            = 10
        PalmMinZ                = 200
    ...
    sletest@linux:~>
    This is what I call "palm detection": if you touch with a large enough portion of skin the touch is ignored. I can just lay my hand on the touchpad and my answer to the Forum doesn't get garbled by erratic pointer movements.
    The "Disable while typing" feature in libinput is another thing, technically it works as described (if enabled, of course) but it is of very little if any use, at least with my very large touchpad (or click pad?).
    Maybe Thinkpad's owners using the joystick are happy with that, but it is definitely not "palm detection", rather "side touch detection" at best.
    By the way, this is not openSUSE specific, Ubuntu 1610 behaves the same way (and I don't think that newer versions changed that, but I might be mistaken).

    So, if "side touch" doesn't work, a bug report might help fixing things; but I doubt that it will bring back "palm detection" the way we knew it.
    Anyway, I will be glad to join in testing if I can provide useful info.
    Tumbleweed Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.3

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: How to enable palm rejection for Touchpad in Leap 42.3?

    Quote Originally Posted by lance321 View Post
    Thanks Deano, according to the link you provided for libinput Palm Detection the way it works is simple. By simply ignoring touches that start on the sides of a touchpad (I never thought of 'how' it worked before).

    I tested this with my palm while typing or just by touching and the perimeter and moving in. It is definitely not working. I dual boot with Windows and palm rejection is working just fine with windows, but not OpenSUSE. Strangely I don't remember Ubuntu 16.04 being a problem.

    I will submit a bug report as you suggested.


    I was searching online and noticed several posts with users complaining (some with other distros) of palm rejection working just fine for years, then now its a problem again.


    It makes sense when 'OrsoBruno' explained they did things like abandoned synaptics driver. I wonder what the purpose of that was?...
    This presentation by Hans de Goede is worth watching. It explains why the input stack is being reworked (along with many other Xorg components), and how it unifies a lot of input handling code. It has better support for the multi-touch input devices which are now in common use.

    https://www.youtube.com/watch?v=uIEoFKhzxI8

    Also since this is an issue with libinput under X.org is it even going to be an issue when they switch to Wayland (eventually)? Or will any of these drivers remain the same under that new Window Manager?

    I am not sure how that works.
    With Xorg, a wrapper is needed so that libinput code can be used, and this allows testing/development to be done in non-Wayland environments. I would expect the behaviour to be the same in either environment.

  10. #10

    Default Re: How to enable palm rejection for Touchpad in Leap 42.3?

    Quote Originally Posted by OrsoBruno View Post
    Just for the sake of discussion, this is what we were used to with the synaptics driver (got from a test SLED 12SP3):
    Code:
    sletest@linux:~> synclient
    Parameter settings:
    ...
        PalmDetect              = 1
        PalmMinWidth            = 10
        PalmMinZ                = 200
    ...
    sletest@linux:~>
    This is what I call "palm detection": if you touch with a large enough portion of skin the touch is ignored. I can just lay my hand on the touchpad and my answer to the Forum doesn't get garbled by erratic pointer movements.
    The "Disable while typing" feature in libinput is another thing, technically it works as described (if enabled, of course) but it is of very little if any use, at least with my very large touchpad (or click pad?).
    Maybe Thinkpad's owners using the joystick are happy with that, but it is definitely not "palm detection", rather "side touch detection" at best.
    By the way, this is not openSUSE specific, Ubuntu 1610 behaves the same way (and I don't think that newer versions changed that, but I might be mistaken).

    So, if "side touch" doesn't work, a bug report might help fixing things; but I doubt that it will bring back "palm detection" the way we knew it.
    Anyway, I will be glad to join in testing if I can provide useful info.

    Thanks for the info on Palm detection! I agree with those settings. However I got a little tired of all the fixing I had to do with OpenSUSE (I mean no offense). Its just after using Linux off and on for about 15 years on the desktop now, I really just want things to work. And I have little patience for long time releases where even the basics are broken. It still astounds me so much doesn't work in Ubuntu's standard releases. I still can't install Steam without a hitch in that distro either.

    With my testing in OpenSUSE this week I have had to perform work arounds to install packages, get Steam install and my games to work, and get touchpad palm recognition working...well that does work actually.

    I did submit the bug to Xorg, but I think I will cancel it because I don't think its their problem.

    The issue is definitely specific to OpenSUSE and may be other distros. But Ubuntu was fine.

    I am switching to POP-OS from System76 for now. OMG this things amazing! Its Ubuntu 17.04 underneath, but uses their custom repositories or you can add Ubuntu's etc.

    And everything in this thing (as of this time) just works! Steam installs seamlessly. Palm detection (rejection) when typing is a dream. All software and updates run without issue. Installing Chrome took just seconds.

    Heck I even put in a bigger hard drive, and then booted into the OS, and actively changed my partition size with GPARTED without even having to reboot. It was easy as using disk manager in windows!

    Glad I found this thing. I just want to use my system without all the work right now.

    By the way this POP-OS (as of now) is XORG + Gnome. Just like OpenSUSE, on Ubuntu 17.04. And palm detection is no issue.
    https://system76.com/pop

    Thanks again for all your assistance. Greatly appreciate it!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •