Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: [SLES 12 SP1] unable to ping using NIC with static IP

  1. #1

    Default [SLES 12 SP1] unable to ping using NIC with static IP

    So here is the setup that I have:

    I have two systems, and each has dual GbE NICs (eth0, eth1).

    Both are configured as follows (both hardware and software):

    eth0 is connected to a switch that is connected to a router with a gateway IPv4 address.

    eth1 is connected to a switch that is not connected to a router and as such, does not have a gateway IPv4 address.

    eth0 is on a public network, with a static IPv4 address. (IPv6 is disabled in both cases.)

    eth1 is on a private network, with a static IPv4 address.

    I configured the static IP address (originally) with this: https://forums.opensuse.org/showthre...30#post2109330

    And it works for eth0.

    eth0 on server A is able to ping eth0 on server B.

    However, server A is unable to ping eth1 on server B (and vice versa).

    Is it because I don't have a gateway? How do I make eth1 on server A ping eth1 on server B?

    The switch is just a dummy Netgear 8-port gigabit switch (GS208).

    Is the inability for me to ping eth1 on server B from server A because it is trying to ping eth1 on server B using the "incorrect" network interface? (e.g. eth0 on server A is trying to ping eth1 on server B whereas what I really want is eth1 on server A to be able to ping eth1 on server B)

    Any help would be greatly appreciated.

    Thank you.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: [SLES 12 SP1] unable to ping using NIC with static IP

    Hi alpha754293. Welcome to openSUSE Forums. We have dedicated forums for SLES (same login credentials):

    https://forums.suse.com/forum.php

  3. #3

    Default Re: [SLES 12 SP1] unable to ping using NIC with static IP

    Let's get some information from each machine:

    Code:
    ip a
    ip r
    ip neigh
    Also, you may want to run tcpdump on both sides and see what you can see
    when you try pinging.

    Code:
    sudo /usr/sbin/tcpdump -n -s 0 -i any icmp
    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below.

    If you want to send me a private message, please let me know in the
    forum as I do not use the web interface often.

  4. #4

    Default Re: [SLES 12 SP1] unable to ping using NIC with static IP

    Quote Originally Posted by deano_ferrari View Post
    Hi alpha754293. Welcome to openSUSE Forums. We have dedicated forums for SLES (same login credentials):

    https://forums.suse.com/forum.php
    Yeah, I didn't realise that it was a different forum until after the fact because it looks almost identical, if not EXACTLY identical to the SLES forum.

    Quote Originally Posted by ab View Post
    Let's get some information from each machine:

    Code:
    ip a
    ip r
    ip neigh
    Also, you may want to run tcpdump on both sides and see what you can see
    when you try pinging.

    Code:
    sudo /usr/sbin/tcpdump -n -s 0 -i any icmp
    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below.

    If you want to send me a private message, please let me know in the
    forum as I do not use the web interface often.
    Code:
    on server A
    ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether 00:25:90:78:06:0a brd ff:ff:ff:ff:ff:ff
        inet 192.168.1.100/24 brd 192.168.1.255 scope global eth0
           valid_lft forever preferred_lft forever
    3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether 00:25:90:78:06:0b brd ff:ff:ff:ff:ff:ff
        inet 10.0.1.0/24 brd 10.0.1.255 scope global eth1
           valid_lft forever preferred_lft forever
    
    ip r
    default via 192.168.1.254 dev eth0
    10.0.1.0/24 dev eth1  proto kernel  scope link  src 10.0.1.0
    192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.100
    
    ip neigh
    192.168.1.101 dev eth0 lladdr 00:25:90:78:07:68 REACHABLE
    10.0.1.1 dev eth1  FAILED
    192.168.1.154 dev eth0 lladdr bc:ee:7b:9b:35:d3 REACHABLE
    192.168.1.254 dev eth0 lladdr 04:a1:51:16:3c:62 STALE
    192.168.1.1 dev eth0 lladdr f8:32:e4:bd:d9:84 STALE
    
    
    on server B:
    ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether 00:25:90:78:07:68 brd ff:ff:ff:ff:ff:ff
        inet 192.168.1.101/24 brd 192.168.1.255 scope global eth0
           valid_lft forever preferred_lft forever
    3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether 00:25:90:78:07:69 brd ff:ff:ff:ff:ff:ff
        inet 10.0.1.1/24 brd 10.0.1.255 scope global eth1
           valid_lft forever preferred_lft forever
    
    ip r
    default via 192.168.1.254 dev eth0
    10.0.1.0/24 dev eth1  proto kernel  scope link  src 10.0.1.1
    192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.101
    
    
    ip neigh
    192.168.1.154 dev eth0 lladdr bc:ee:7b:9b:35:d3 REACHABLE
    192.168.1.100 dev eth0 lladdr 00:25:90:78:06:0a REACHABLE
    192.168.1.254 dev eth0 lladdr 04:a1:51:16:3c:62 REACHABLE
    Not sure how to use the tcpdump command (I'm a grossly underqualified sysadmin n00b as far as this stuff is concerned - I only learn it enough to facilitate what I really want/need my systems to do and that's about it).

    Tried pinging 10.0.1.1 (server B) from server A and it says "Destination Host Unreachable".

    Server B which was running the tcpdump says:

    Code:
    0 packets captured
    1 packet received by filter
    0 packets dropped by kernel
    when I exited out of it.

    Hope this helps?

    Thanks.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: [SLES 12 SP1] unable to ping using NIC with static IP

    We can simplify the topology as only eth1 on both servers relevant here:
    Server A (eth1, 10.0.1.0)--------Switch--------Server B(eth1, 10.0.1.1)

    No gateway is needed as both hosts are within the same subnet (and ARP is used to discover the machine's MAC address associated with a given IP address).

    You need to investigate why this result...
    Code:
    10.0.1.1 dev eth1  FAILED
    For example, checked cabling?

    Can you ping server A from server B?

  6. #6
    Join Date
    Sep 2012
    Posts
    7,106

    Default Re: [SLES 12 SP1] unable to ping using NIC with static IP

    Quote Originally Posted by alpha754293 View Post
    Code:
    3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
        link/ether 00:25:90:78:06:0b brd ff:ff:ff:ff:ff:ff
        inet 10.0.1.0/24 brd 10.0.1.255 scope global eth1
           valid_lft forever preferred_lft forever
    IP address with all zeroes or all ones host part is invalid.

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: [SLES 12 SP1] unable to ping using NIC with static IP

    Quote Originally Posted by arvidjaar View Post
    IP address with all zeroes or all ones host part is invalid.
    Good catch! I didn't notice that in my haste... ....trying to do real work at the same time....

    @alpha754293: You need to assign a valid IP address on server A eg 10.0.1.2
    Last edited by deano_ferrari; 14-Nov-2017 at 20:53.

  8. #8

    Default Re: [SLES 12 SP1] unable to ping using NIC with static IP

    On 11/14/2017 07:36 PM, alpha754293 wrote:
    >
    > Code:
    > --------------------
    >
    > on server A
    > ip a
    > 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    > link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    > inet 127.0.0.1/8 scope host lo
    > valid_lft forever preferred_lft forever
    > 2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    > link/ether 00:25:90:78:06:0a brd ff:ff:ff:ff:ff:ff
    > inet 192.168.1.100/24 brd 192.168.1.255 scope global eth0
    > valid_lft forever preferred_lft forever
    > 3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    > link/ether 00:25:90:78:06:0b brd ff:ff:ff:ff:ff:ff
    > inet 10.0.1.0/24 brd 10.0.1.255 scope global eth1
    > valid_lft forever preferred_lft forever


    Ah, here we are. Notice that your IP address is the network address,
    specifically 10.0.1.0. You need to try 10.0.1.1 and 10.0.1.2 for the
    hosts, and leave both the network address (10.0.1.0) and broadcast address
    (10.0.1.255) free as they are special.

    > ip r
    > default via 192.168.1.254 dev eth0
    > 10.0.1.0/24 dev eth1 proto kernel scope link src 10.0.1.0
    > 192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.100


    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below.

    If you want to send me a private message, please let me know in the
    forum as I do not use the web interface often.

  9. #9

    Default Re: [SLES 12 SP1] unable to ping using NIC with static IP

    Thank you everybody!!!

    I didn't know/realise that 10.0.1.0 is a special, reserved address.

    So the second question is once I have that setup, how can I check/test to make sure that the 10.B.C.D network is communicating privately?

    i.e. that when I am trying to ping server B from server A, that it ISN'T using the 192.B.C.D (public) network to execute that ping?

    (background: I'm doing CAE and the private network is going to be the system interconnect. Right now, both for the private and public network on the system, it has the same hostname for both so my concern is that when the distributed parallel processing software tries to look for the compute nodes by hostname, it's going to find it using the public network rather than the private network which is what I don't want. Do I have to use separate hostnames (for the same server/"pizza box") to distinguish the two or can I still stay with a single hostname, and then do something else differently so it know when/how to communicate to the other node (by hostname), but using the private network instead of the public network?)

    Your help in helping me understand this is greatly appreciated!!!

    Thank you.

  10. #10

    Default Re: [SLES 12 SP1] unable to ping using NIC with static IP

    On 11/15/2017 04:46 AM, alpha754293 wrote:
    >
    > Thank you everybody!!!
    >
    > I didn't know/realise that 10.0.1.0 is a special, reserved address.
    >
    > So the second question is once I have that setup, how can I check/test
    > to make sure that the 10.B.C.D network is communicating privately?


    Since this seems related to your original question, I'll answer it, but I
    advise you to ask the rest in anew thread if this does not suffice, as it
    opens another can of worms.

    > i.e. that when I am trying to ping server B from server A, that it ISN'T
    > using the 192.B.C.D (public) network to execute that ping?


    There are two easy ways: first, pull the plug on the wire that should NOT
    be used, and see if data still flow. Maybe to avoid the computer
    detecting this and somehow working around it on its own (because computers
    can be clever like that), try plugging the two systems into different
    switches, so at least the links seem to be up, but the traffic cannot
    route properly.

    Another option is to watch via tcpdump to see which NICs are doing what.

    Also, I would recommend two other things: first, different hostnames for
    different IPs; hostnames only matter on a per-host bsais, but having them
    be ambiguous is just a terrible idea if you plan to use them. How could
    any system possibly know which one to use? Also, hostnames are (in my
    opinion) not great to use for configurations anyway; DNS is fine, but
    simple hostnames are per-server, and in many environments may be
    meaningless. I would probably just use an IP address directly if you are
    going to be using host-based hostnames, as they are unambiguous, actually
    tied to something, and not confused with DNS records (another form of
    unambiguity).

    > (background: I'm doing CAE and the private network is going to be the
    > system interconnect. Right now, both for the private and public network
    > on the system, it has the same hostname for both so my concern is that
    > when the distributed parallel processing software tries to look for the
    > compute nodes by hostname, it's going to find it using the public
    > network rather than the private network which is what I don't want. Do I
    > have to use separate hostnames (for the same server/"pizza box") to
    > distinguish the two or can I still stay with a single hostname, and then
    > do something else differently so it know when/how to communicate to the
    > other node (by hostname), but using the private network instead of the
    > public network?)


    On this topic, which I think deserves its own thread if you really get
    into it much, I recommend a document on rp_filter sysctl settings found here:

    https://www.suse.com/support/kb/doc/?id=7007649

    This is starting to get into nitty gritty of networking stuff, so test well.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below.

    If you want to send me a private message, please let me know in the
    forum as I do not use the web interface often.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •