Results 1 to 4 of 4

Thread: system policy change for networking

  1. #1

    Default system policy change for networking

    When logging into my desktop (KDE, TW) I keep getting prompted for the
    root password. The pop-up states "System policy prevents changes to the
    network". Since I run a system only accessible by me where can I change
    this setting or turn it off all together?

    --
    Ken
    linux since 1984
    S.u.S.E./openSUSE since 1996

  2. #2
    Join Date
    Aug 2008
    Location
    Confoederatio helvetica
    Posts
    22

    Default Re: system policy change for networking

    Hello Kensch,

    I'm not sure that it's the same but i had something similar on my SSD.
    To get rid OFF i had to delete the second user and re-appropriate my home:

    cd ~
    sudo chown -R (username) *

    after that i could re-create the second user (in yast)

    Another thing is the networkmanager, i changed from wicked to networkmanager...

    i hoppe it will help

    cheers

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,663
    Blog Entries
    3

    Default Re: system policy change for networking

    No problem here.

    Did you recently change something on your network?

    I'm normally connected with ethernet. But I unplugged that before booting to Tumbleweed. Then, after login, I clicked "Connect" for the home wifi network (and don't have it set for automatic connect). And it connected without a problem.

    If you configure your connection to be shared by all users, what you describe is known to happen. But you can still avoid the problem by moving the network key out of "kdewallet".

    Right click on network tray applet, and select "Configure Network Connections".

    Then, for your WiFi connection, go to the security tab. Then look for the setting on where to store the password. I recommend "Store password for all users (not encrypted)". You might then need the root password to save those changes.

    After you make that change, you should not again be prompted for root. And note that the password is actually saved in a file readable only by root. So the "(not encrypted)" sounds more scary than it is.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  4. #4

    Default Re: system policy change for networking

    On 11/14/2017 12:46 PM, nrickert wrote:
    >
    > No problem here.
    >
    > Did you recently change something on your network?


    Not really. Still using NetworkManager but different AP while waiting
    for DSL to be re-connected at my winter residence at which time I'll be
    back on ethernet.

    >
    > I'm normally connected with ethernet. But I unplugged that before
    > booting to Tumbleweed. Then, after login, I clicked "Connect" for the
    > home wifi network (and don't have it set for automatic connect). And it
    > connected without a problem.
    >
    > If you configure your connection to be shared by all users, what you
    > describe is known to happen. But you can still avoid the problem by
    > moving the network key out of "kdewallet".


    Never have user KWallet so that's not the problem.

    >
    > Right click on network tray applet, and select "Configure Network
    > Connections".
    >
    > Then, for your WiFi connection, go to the security tab. Then look for
    > the setting on where to store the password. I recommend "Store password
    > for all users (not encrypted)". You might then need the root password
    > to save those changes.
    >
    > After you make that change, you should not again be prompted for root.
    > And note that the password is actually saved in a file readable only by
    > root. So the "(not encrypted)" sounds more scary than it is.
    >


    It's just a minor annoyance that will go away when my DSL is connected
    next week.
    Thanks for the pointers though.


    --
    Ken
    *nux since 1984
    S.u.S.E./openSUSE since 1996

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •