Results 1 to 4 of 4

Thread: virtualbox not working

  1. #1
    Join Date
    Aug 2011
    Location
    Monnickendam, The Netherlands
    Posts
    129

    Question virtualbox not working

    Hello,

    Virtualbox won't work with the newest kernel 4.13.12-1
    Can not /sbin/vboxconfig the kernel.
    Back to kernel 4.13.11-1, all is fine.

    Gerrit Jan

  2. #2
    Join Date
    Aug 2011
    Location
    Monnickendam, The Netherlands
    Posts
    129

    Red face Re: virtualbox not working (solved)

    some info
    Code:
    Het is niet gelukt een sessie te openen voor virtuele machine Kubuntu.
    The virtual machine 'Kubuntu' has terminated unexpectedly during startup with exit code 1 (0x1).
    Resultaatcode:NS_ERROR_FAILURE (0x80004005)
    Component:MachineWrap
    Interface:IMachine {b2547866-a0a1-4391-8b86-6952d82efaa0}
    Code:
    === Building 'vboxdrv' module ===
    make[1]: Entering directory '/usr/src/kernel-modules/virtualbox/src/vboxdrv'
    make KBUILD_VERBOSE= SUBDIRS=/usr/src/kernel-modules/virtualbox/src/vboxdrv SRCROOT=/usr/src/kernel-modules/virtualbox/src/vboxdrv CONFIG_MODULE_SIG= -C /lib/modules/4.13.12-1-default/build -j4 modules
    make[2]: Entering directory '/usr/src/linux-4.13.12-1-obj/x86_64/default'
    /usr/src/linux-4.13.12-1/Makefile:942: *** "Cannot generate ORC metadata for CONFIG_ORC_UNWINDER=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel".  Stop.
    make[3]: *** [Makefile:145: sub-make] Error 2
    make[2]: *** [Makefile:24: __sub-make] Error 2
    make[2]: Leaving directory '/usr/src/linux-4.13.12-1-obj/x86_64/default'
    make[1]: *** [Makefile:305: vboxdrv] Error 2
    make[1]: Leaving directory '/usr/src/kernel-modules/virtualbox/src/vboxdrv'
    make: *** [Makefile:41: all] Error 2
    And solved : this is the problem after the last Tumbleweed update: please install libelf-dev, libelf-devel or elfutils-libelf-devel

  3. #3
    Join Date
    May 2015
    Location
    Italy
    Posts
    442

    Default Re: virtualbox not working

    Thank you Jan! It solved the problem for me too.
    BTW, I had to install the virtualbox-host-source package too.

    Cris


    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD Ryzen 5 3600 Six-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD, 500Gb WD BLACK SN750 NVMe SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  4. #4

    Default Re: virtualbox not working

    Quote Originally Posted by Cris70 View Post
    BTW, I had to install the virtualbox-host-source package too.
    Aha! Thanks for this -- that was the critical bit of information I just needed. :¬)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •