Results 1 to 9 of 9

Thread: Zypper dup indicates problems with Cinnamon

  1. #1

    Default Zypper dup indicates problems with Cinnamon

    ... or 'unmet dependencies,' if that would be a better phrase.

    The problem:

    I booted to console, ran zypper dup, and was unpleasantly surprised to see:

    Code:
    Problem: nothing provides cinnamon-settings-daemon >= 3.6.0 needed by cinnamon-settings-daemon-lang-3.6.1-1.1.noarch
    Problem: nemo-3.4.7-1.3.x86_64 requires cinnamon-translations, but this requirement cannot be provided
    Problem: nemo-3.4.7-1.3.x86_64 requires cinnamon-translations, but this requirement cannot be provided
    Problem: nemo-3.4.7-1.3.x86_64 requires cinnamon-translations, but this requirement cannot be provided
    For the first problem, zypper dup offered three solutions:

    Code:
    Solution 1:  deinstallation of cinnamon-settings-daemon-lang-3.4.4-1.3.noarch
    Solution 2:  keep obsolete cinnamon-settings-daemon-lang-3.4.4-1.3.noarch
    Solution 3:  break cinnamon-settings-daemon-lang-3.6.1-1.1.noarch by ignoring some of its dependencies
    ... and that was as far as I got.

    In similar situations in the past, I have accepted zypper dup's first suggested option, crossed fingers and hoped for the best. This time, I hesitate. I don't think that many others here use the Cinnamon desktop, and worry that an essential component has been omitted.

    Suggestions, anyone?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Zypper dup indicates problems with Cinnamon

    Probably a good starting point is to describe how you installed Cinnamon.

    IIRC,
    When I tinkered with Cinnamon on a 42.3, there were packages in the online (not DVD) OSS but no Pattern which is one way that only <mostly> worked. I seem to remember generally but without detail that some things were working, others not completely.

    It might also be possible to install Cinnamon from source.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: Zypper dup indicates problems with Cinnamon

    I wrote up the installation steps in a mini-FAQ (and thanked you and Miuku for the help provided this summer!):

    https://forums.opensuse.org/showthre...op-and-lightDM

    The installation has been pretty stable for the last several months (and I'd like to keep it stable, which is why I thought I should post my question before proceeding with the dup.)

  4. #4
    Join Date
    Sep 2012
    Posts
    7,847

    Default Re: Zypper dup indicates problems with Cinnamon

    Just wait. Cinnamon packages are being updated to new version; development repository already has cinnamon-settings-daemon 3.6.1, it just did not yet make its way into Factroy/Tumbleweed.

  5. #5

    Default Re: Zypper dup indicates problems with Cinnamon

    Yeah, zypper asked endless questions about what to do with Cinnamon today. Usually I check back in a week, and it's mostly sorted out. (I use Cinnamon for the VNC session, as it seems like I can't get KDE on the desktop and KDE in the VNC session, for the same user.)

    I didn't do anything special for installation, I just selected the Cinnamon packages with the gui tool. Install from source? C'mon I'm not running arch or gentoo or whatever.

  6. #6

    Default Re: Zypper dup indicates problems with Cinnamon

    Ah ha! Thank you, arvidjaar (and to you as well, xorbe). I may be far less knowledgeable than other Tumbleweed users, but even I know how to wait awhile!

  7. #7

    Default Re: Zypper dup indicates problems with Cinnamon

    The solver is broken, and not usable:

    Problem: nemo-3.4.7-1.3.x86_64 requires cinnamon-translations, but this requirement cannot be provided
    Solution 1: Following actions will be done:
    deinstallation of nemo-3.4.7-1.2.x86_64
    deinstallation of cinnamon-metatheme-numix-2.6-1.4.noarch
    Solution 2: keep obsolete cinnamon-translations-3.4.3-1.2.noarch
    Solution 3: break nemo-3.4.7-1.3.x86_64 by ignoring some of its dependencies
    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c): 1


    Okay. Next question.

    Problem: nemo-3.4.7-1.2.x86_64 requires cinnamon-translations, but this requirement cannot be provided
    Solution 1: ...


    Look, I already opted to deinstall that nemo package. Why is it still considering its dependencies? I think the problem is that cinnamon-translations is missing from the repo?

  8. #8

    Default Re: Zypper dup indicates problems with Cinnamon

    I did a successful dup by just keeping "obsolete" packages for now, until cinnamon-translations is resolved.

  9. #9

    Default Re: Zypper dup indicates problems with Cinnamon

    The new cinnamon-settings-daemon must be in; I just zypper dup'd without a problem message.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •