Results 1 to 5 of 5

Thread: which can cause btrfs-transaction 100% cpu consuming?

  1. #1
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default which can cause btrfs-transaction 100% cpu consuming?

    Hi,

    today the btrfs-transaction was consuming 100% of my cpu. Which can cause that?

    Thanks
    --
    Biostatistics and Data Science
    https://bio-data.github.io/

  2. #2

    Default Re: which can cause btrfs-transaction 100% cpu consuming?

    By default snapshot operations may cause that, openSUSE automatically
    cleans up old snapshots eventually, and also automatically creates new
    snapshots, so some of that may do it. I think there is also automatic
    balancing of the Btrfs filesystem, and I suspect that could cause some
    utilization too.

    It would help if we knew more about your system with regard to Btrfs, e.g.
    where you use the filesystem, what snapshots you have, how full your
    filesystem is, if you have run any 'yast' or 'zypper' commands lately, etc.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below.

    If you want to send me a private message, please let me know in the
    forum as I do not use the web interface often.

  3. #3
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: which can cause btrfs-transaction 100% cpu consuming?

    Hi, thanks.

    And how can I access these informations?
    --
    Biostatistics and Data Science
    https://bio-data.github.io/

  4. #4

    Default Re: which can cause btrfs-transaction 100% cpu consuming?

    there are some brtfs issues,
    but everything shall become better
    https://bugzilla.suse.com/show_bug.cgi?id=1017461

    and I will believe it when I experience the imporvments

  5. #5

    Default Re: which can cause btrfs-transaction 100% cpu consuming?

    This issue is bugging me for quite a while now too.
    Reading the comments of the referenced bugreport hasn't made me any wiser. It's marked as resolved but with an up do date system (newest kernel etc) I still experience this problem from time to time.
    So I'd like to disable the quotas but haven't worked out how to do so, until now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •