Results 1 to 6 of 6

Thread: Media Player plays nothing !

  1. #1

    Default Media Player plays nothing !

    on opensuse Leap 42.3
    when i try to run a .mp4 file with Media Player i get the following
    Code:
    mpv ./high.mp4
    Playing: ./high.mp4
     (+) Video --vid=1 (*) (h264 720x480 29.970fps)
     (+) Audio --aid=1 --alang=eng (*) (aac 2ch 48000Hz)
    Failed to initialize a video decoder for codec 'h264'.
    Video: no video
    Failed to initialize an audio decoder for codec 'aac'.
    Audio: no audio
    very similar wit a .avi file
    Code:
    mpv ./file.avi
    Playing: ./Jfile.avi
     (+) Video --vid=1 (mpeg4 720x480 29.970fps)
     (+) Audio --aid=1 (mp3 2ch 44100Hz)
    Failed to initialize a video decoder for codec 'mpeg4'.
    Video: no video
    what is wrong ??

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    1,950

    Default Re: Media Player plays nothing !

    Default mpv from the OSS repo will not play patented formats (such as H264 etc).

    You will need to install the version from Packman.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3

    Default Re: Media Player plays nothing !

    from your post I'm assuming you don't have the packman repo just copy/paste the bellow in a terminal windo
    Code:
    sudo zypper ar -f ftp://packman.inode.at/suse/openSUSE_Leap_42.3/ packman
    sudo zypper dup --from packman
    sudo zypper in vlc-codecs libxine2-codecs

  4. #4

    Default Re: Media Player plays nothing !

    many thanks to both Miuku and I_A
    it works now

    i still have to understand what is packman
    can you explain that ?
    and why working stuff is not directly included in the regular opensuse repository ?

  5. #5
    Join Date
    May 2012
    Location
    Finland
    Posts
    1,950

    Default Re: Media Player plays nothing !

    Packman is a 3rd party repository that holds files that cannot be included with the openSUSE distribution because of patent restrictions (read: they are non-free software).

    The base openSUSE install has no patent restricted codecs and is completely 'libre' software (more or less you are free to do whatever you like with it)
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  6. #6

    Default Re: Media Player plays nothing !

    that puts some light on
    thanks Miuku

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •