Results 1 to 4 of 4

Thread: Steam installation error

  1. #1

    Unhappy Steam installation error

    I am new to OpenSUSE switching from Ubuntu. Trying to install Steam, running into a couple issues.

    Is there some reason why you can't install packages via YAST using the web links in your software package sites in CHROME?

    It appears to only work in Firefox? Nothing on the site says to use Firefox, but Chrome gives me this error when installing STEAM.



    Using the links provided here.
    https://software.opensuse.org/package/steam



    I get this page in Chrome:


    "
    <metapackage xmlnss="http://opensuse.org/Standards/One_Click_Install" xmlns="http://opensuse.org/Standards/One_Click_Install">
    <group>
    <repositories>
    <repository recommended="true">
    <name>openSUSE:Leap:42.3:NonFree</name>
    <summary>Non Free parts of openSUSE Leap 42.3 distribution.</summary>
    <description>Non free or non open source parts of openSUSE Leap 42.3.</description>
    <url>http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/</url>
    </repository>
    <repository recommended="false">
    <name>openSUSE:Leap:42.3</name>
    <summary>openSUSE Leap 42.3</summary>
    <description></description>
    <url>http://download.opensuse.org/distribution/leap/42.3/repo/oss/</url>
    </repository>
    </repositories>
    <software>
    <item>
    <name>steam</name>
    <summary>Installer for Valve's digital software distribution service</summary>
    <description>Steam is a software distribution service with an online store, automated
    installation, automatic updates, achievements, SteamCloud synchronized
    savegame and screenshot functionality, and many social features.

    This package will fetch and install the Steam bootstrap. Start Steam to
    complete the installation of the client for the current user.</description>
    </item>
    </software>
    </group> </metapackage>
    "




    If I open this link in Firefox, I am prompted to download or open the file "steam.ymp".However when installing in YAST2, I get this wonderful error. Which tells me to submit a bug report, but coming from another distro I don't have the foggiest idea how to run sae_y2logs.

    I wish the error message script would take care of this for you, like other programs that report their errors to their own developers...

    "
    Error
    Internal error. Please report a bug report with logs.
    Run save_y2logs to get complete logs.
    Details: undefined method 'reduce' for nil:NilClass
    Caller: /usr/share/YaST2/modules/PachageSlideShow.rb:135:in 'ListSum'
    "

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    23,192
    Blog Entries
    15

    Default Re: Steam installation error

    Hi and welcome to the Forum
    The ymp file needs to be opened with YaST Software on downloading (not sure if that works in chrome?).

    If you have the non-oss repository enabled then use the command line as root user;
    Code:
    zypper in steam
    Or use YaST Software Management and search on steam and install from there...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2 (x86_64) GNOME 3.20.2
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Steam installation error

    Thanks malcolmlewis,

    Your suggestion to run the command worked! (but you have to run as admin with sudo of course)

    Code:
    sudo zypper in steam
    I originally turned to the documentation on OpenSUSE page to install Steam, but the links don't work. I was surprised they don't list the CLI command to install in case their GUI fails. If I hadn't posted here I would never have known to install with zypper since its limited to SUSE.

    https://en.opensuse.org/Steam

    Yes Chrome isn't able to download the YMP file, you just get that page I posted. I am sure its because of how the page is coded. But it prompted to download the file in Firefox.

    I did make sure non-oss repository was enabled, and I had opened the file with YaST Software and started the installation with the admin password, but received errors. However the CLI method you suggested worked fine. Not sure why LEAP version wasn't able to install it using the GUI.

  4. #4

    Unhappy Re: Steam installation error

    I used this command and YaST but didn't work for me

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •