Results 1 to 9 of 9

Thread: Krusader 2.6 does anoying panel update every second, howto stop this auto reload ?

  1. #1
    Join Date
    Aug 2008
    Location
    Confoederatio helvetica
    Posts
    22

    Default Krusader 2.6 does anoying panel update every second, howto stop this auto reload ?

    Hello,

    I' did change from opensuse13.1 to leap 42.3 and so i migrated the very useful krusader from version 2.4 to 2.6.
    All my settings were gone because of the configuration files have been migrated from ~/.kde/share/local and config to ~/.local and ~/.config

    After six month of problems (with plasma and other software), i'm still unable to find how to disable the very annoying auto-refresh of the panel(s).
    It's refreshing the icon's and the status bar about every second (depending how much cache settings and data is on the active panel)
    The CTRL-R (reload, refresh panel) is still working (but not useful with this time interval of autorefresh)

    I tried a lot of custom settings in krusader and krusaderrc but nothing is working...
    I didn't find something in the systemsetting nor kde.org or on the web ...

    So i need some help from you because i think it's maybe a suse parameter.


    Thanks in advance

  2. #2
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,257

    Default Re: Krusader 2.6 does anoying panel update every second, howto stop this auto reload ?

    Quote Originally Posted by ursh15 View Post
    I tried a lot of custom settings in krusader and krusaderrc but nothing is working...
    I didn't find something in the systemsetting nor kde.org or on the web
    I regularly use krusader 2.6.0 on both 42.3 and Tumbleweed and I've never seen the behaviour you describe.

    With krusader closed if you temporarily rename "~/.config/krusaderrc" and then start krusader (with a new default profile) does it still happen?

    Does it happen if you create a new user profile?
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191011) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  3. #3
    Join Date
    Aug 2008
    Location
    Confoederatio helvetica
    Posts
    22

    Default Re: Krusader 2.6 does anoying panel update every second, howto stop this auto reload ?

    Quote Originally Posted by tannington View Post
    I regularly use krusader 2.6.0 on both 42.3 and Tumbleweed and I've never seen the behaviour you describe.

    With krusader closed if you temporarily rename "~/.config/krusaderrc" and then start krusader (with a new default profile) does it still happen?

    Does it happen if you create a new user profile?
    Hello tannington,

    Yes, the autoreload is always on, no matter watt i did to get rid off, but only with version 2.6 .... i have to say that maybe most user do not have a problem with this autoreload of the panel.
    ~/.config/krusaderrc newly created (fresh start) has "AutoResizeColumns=true" but that's unfortunately not the problem

    Cheers.

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,257

    Default Re: Krusader 2.6 does anoying panel update every second, howto stop this auto reload ?

    Did you also try with a new user, just in case it's something in your existing profile?

    Sorry, I'm very much at a loss to offer any suggestions as to the cause (or possible cure).

    Perhaps ask on the krusader users mailing list: https://krusader.org/get-involved/mailing-lists/

    Or consider creating a bug report: https://bugs.kde.org/enter_bug.cgi?p...ponent=general (but probably better to ask on the list first).
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191011) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  5. #5
    Join Date
    Aug 2008
    Location
    Confoederatio helvetica
    Posts
    22

    Default Re: Krusader 2.6 does anoying panel update every second, howto stop this auto reload ?

    Hello again,

    I spend a lot of time (night's) to do some comparison with another OS under gnome and krusader 2.5
    The auto reload, seems to me is executed each time an access to the directory from the active panel is done, not necessarily a writing.
    So i have to add that i use leap 42.3 with plasma5 on an SSD and that my home directory was not formatted at the new installation of Leap 42.3 !

    i tested with: Krusader has "Show the icones for the filenames and folders" on
    I wiped every entrance in the fstab for the ssd.
    I reactivated ".xsession-errors-:0". (before all logs were send to /dev/null)

    I find out that baloo does a lot of the file accessing.
    I stopped baloo with "balooctl disable"

    After that, i had a lot of "KConfigIni" writing in ".xsession-errors-:0", this file was now grooving very fast
    I deleted all the files that made this errors (mainly "desktop files" from previous kde).
    Then i had "libkomparediff" errors every seconds ...

    After killing some process, i found out that my SIP application is creating a lot of entries in the ".xsession-errors-:0"

    Woaw now the auto reload in the krusader panel is activated after every access in the directory but not every seconds any-more...

    Is this not really crazy especially that baloo has blocked some logs ?

    My preferred sip application is not plasma5 clean/compatible, very sad !
    I think it's a Plasma5 problem in relation with kde4/3 and or gnome applications that make a lot of file-system accessing (gnome desktop hasn't this behaviour) anyway, the access are only in the cache (RAM) not on the SSD.

    So my question is still not answered but has nothing to do with Suse.

    Is the auto reload in 2.6 dbus triggered or systemd5 related ? is there anyway to change this behaviour for example in a plasma5 parameter's ? maybe I shall take some time to look at the source code...

    In the interval i may live with auto refresh enabled !

    Special thanks to tannington

    cheers

  6. #6
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: Krusader 2.6 does anoying panel update every second, howto stop this auto reload ?

    Quote Originally Posted by ursh15 View Post
    Woaw now the auto reload in the krusader panel is activated after every access in the directory but not every seconds any-more...
    Could this be related to atime and diratime filesystem settings? In my /home partition I usually include the options noatime and nodiratime.

    Just guessing, mind you.

  7. #7
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: Krusader 2.6 does anoying panel update every second, howto stop this auto reload ?

    And, is this just with krusader or do you have this issue with other FMs, like dolphin or konqueror?

  8. #8
    Join Date
    Aug 2008
    Location
    Confoederatio helvetica
    Posts
    22

    Default Re: Krusader 2.6 does anoying panel update every second, howto stop this auto reload ?

    Quote Originally Posted by brunomcl View Post
    And, is this just with krusader or do you have this issue with other FMs, like dolphin or konqueror?
    Hello,

    No in dolphin a don't see some refreshing !

    Cheers

  9. #9
    Join Date
    Aug 2008
    Location
    Confoederatio helvetica
    Posts
    22

    Default Re: Krusader 2.6 does anoying panel update every second, howto stop this auto reload ?

    Quote Originally Posted by brunomcl View Post
    Could this be related to atime and diratime filesystem settings? In my /home partition I usually include the options noatime and nodiratime.

    Just guessing, mind you.
    Hello, well it could bee but no, if a change my fstab it doesn't change de behaviour if a file is writen.
    if a file is accessed, the refresh is not done with noatime.
    So i found out that my SIP programme is updating every second the config file (very stupid).

    Thanks anyway, i will change the SIP program and live with auto refresh on.

    Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •