Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: Hostname via DHCP configuration

  1. #1

    Default Hostname via DHCP configuration

    Good Day,

    I wasn't sure what i am missing on my machine or what may the solution be on checking a box on
    [] Change Hostname via DHCP No interface with dhcp
    i have seen a previous thread regarding the issue that was posted last 2009 and it seems vague to me about enabling the feature.
    Hope someone can enlighten me. Thanks in Advance

    Cheers!

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    16,789
    Blog Entries
    1

    Default Re: Hostname via DHCP configuration

    Don't forget to state the openSUSE version here.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    16,789
    Blog Entries
    1

    Default Re: Hostname via DHCP configuration

    Are you using a static IP address configuration perhaps? That might explain why you can't enable that function. Post your network interface config as defined in /etc/sysconfig/network/ifcfg-...

    For example, if the interface is eth0, then do
    Code:
    sudo cat /etc/sysconfig/network/ifcfg-eth0
    Last edited by deano_ferrari; 06-Nov-2017 at 14:48.

  4. #4

    Default Re: Hostname via DHCP configuration

    Quote Originally Posted by xlyreb View Post
    Good Day,

    I wasn't sure what i am missing on my machine or what may the solution be on checking a box on

    i have seen a previous thread regarding the issue that was posted last 2009 and it seems vague to me about enabling the feature.
    Hope someone can enlighten me. Thanks in Advance

    Cheers!
    Apologies, Just for heads up i am using openSUSE 42.1

  5. #5

    Default Re: Hostname via DHCP configuration

    Quote Originally Posted by deano_ferrari View Post
    Are you using a static IP address configuration perhaps? That might explain why you can't enable that function. Post your network interface config as defined in /etc/sysconfig/network/ifcfg-...

    For example, if the interface is eh0, then do
    Code:
    sudo cat /etc/sysconfig/network/ifcfg-eth0
    Will do a follow-up report sir! thanks!
    Yes sir, Im using Static IP address / IP reservation

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    16,789
    Blog Entries
    1

    Default Re: Hostname via DHCP configuration

    Quote Originally Posted by xlyreb View Post
    Will do a follow-up report sir! thanks!
    Yes sir, Im using Static IP address / IP reservation
    They're not the same thing. The latter does use DHCP to acquire an IP address, gateway and DNS.

  7. #7

    Default Re: Hostname via DHCP configuration

    Here is what i got sir,

    Bootproto=static
    broadcast="
    ethtool_option="
    Ipaddr=192.168.0.101/255.255.255.0
    MTU=0
    network=0
    remote_ipaddr="
    startmode=Auto
    Name=netlink BCM5778 gigabit ethernet

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    16,789
    Blog Entries
    1

    Default Re: Hostname via DHCP configuration

    Quote Originally Posted by xlyreb View Post
    Here is what i got sir,


    Bootproto=static
    broadcast="
    ethtool_option="
    Ipaddr=192.168.0.101/255.255.255.0
    MTU=0
    network=0
    remote_ipaddr="
    startmode=Auto
    Name=netlink BCM5778 gigabit ethernet
    So that explains it. You're not using a DHCP-acquired address, so you can't enable that feature.

  9. #9

    Default Re: Hostname via DHCP configuration

    is it possible to enable it while inputting a static IP set-up?

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    16,789
    Blog Entries
    1

    Default Re: Hostname via DHCP configuration

    Quote Originally Posted by xlyreb View Post
    is it possible to enable it while inputting a static IP set-up?
    The function is used to push the hostname to the DHCP server (your router in this case), but you're not using DHCP so it's not applicable. You could just configure your openSUSE host to use DHCP instead, and reserve the desired address for this host in the router.

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •