Results 1 to 9 of 9

Thread: Where is typelib-1_0-WebKit-3_0 for Tumbleweed

  1. #1

    Default Where is typelib-1_0-WebKit-3_0 for Tumbleweed

    Hi All,

    I want to run a python+php application, but it depends on typelib-1_0-WebKit-3_0

    typelib-1_0-WebKit-3_0 is available for openSUSE 42.3 (I'm running the application on another machine with openSUSE 42.3), but I cannot find this package for Tumbleweed. Is it named differently? Is it not available at all?

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,067

    Default AW: Where is typelib-1_0-WebKit-3_0 for Tumbleweed


  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,067

    Default AW: Where is typelib-1_0-WebKit-3_0 for Tumbleweed

    Its not there, I have searched for it.

    Maybe you can build it by yourselve?

  4. #4

    Default Re: AW: Where is typelib-1_0-WebKit-3_0 for Tumbleweed

    It does show it on the website, but zypper does not find it and can not install it (even after adding and refreshing GNOME:Next repo). Going to repositories does not show the package either.

  5. #5

    Default Re: AW: Where is typelib-1_0-WebKit-3_0 for Tumbleweed

    Quote Originally Posted by Sauerland View Post
    Maybe you can build it by yourselve?
    I doubt it. I have close to no experience with compiling software. Also, If I remember correctly, installing typelib-1_0-WebKit-3_0 on openSUSE 42.3 pulls in another 2 or 3 related/dependent packages.

  6. #6

    Default Re: AW: Where is typelib-1_0-WebKit-3_0 for Tumbleweed

    Quote Originally Posted by Sauerland View Post
    Its not there, I have searched for it.
    what is webkit2gtk3 package? Description seems to be almost identical to typelib-1_0-WebKit-3_0.

    And if there is no typelib-1_0-WebKit-3_0 for Tumbleweed, is there some channel to request for the package to be built (for those, like myself, who are not knowledgeable enough to do it on their own)?

  7. #7

    Exclamation Re: Where is typelib-1_0-WebKit-3_0 for Tumbleweed

    typelib-1_0-WebKit-3_0 was the gobject inrtospection binding for WebKit1/GTK3 variant. WebKit1 is no longer maintained by upstream for a couple years already and security issues are not being addressed

    typelib-1_0-WebKit2-4_0 is the replacment(WebKit2/GTK3 based) but your application needs to be ported to WK2 (it's not a drop in replacement); I strongly recommend you to contact the author of this application to get it ported to the maintained version of WebKit

  8. #8

    Default Re: Where is typelib-1_0-WebKit-3_0 for Tumbleweed

    Quote Originally Posted by dimstar View Post
    typelib-1_0-WebKit-3_0 was the gobject inrtospection binding for WebKit1/GTK3 variant. WebKit1 is no longer maintained by upstream for a couple years already and security issues are not being addressed
    I see. Do you know when WebKit1 stopped being supported from top of your head? From a quick search it seems it happened some time in late 2014.

  9. #9

    Default Re: Where is typelib-1_0-WebKit-3_0 for Tumbleweed

    Quote Originally Posted by RaveNBlack View Post
    I see. Do you know when WebKit1 stopped being supported from top of your head? From a quick search it seems it happened some time in late 2014.
    2014 sounds about right - so 3 years without security fixes on a web-engine. Not something you really want to have on your system

    WK1/GTK2 is the next target to be removed (removal from TW happens when we don't have internal consumers anymore)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •