Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Kmail - start akonadi

  1. #1
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Kmail - start akonadi

    I've recently switched back to using Kmail in Plasma / 42.3
    However, whenever I start Kmail after a boot I get a screen announcing "The Akonadi Perosnal information Management System is not Running. This application cannot be used without it".
    Just under that is a start button. Once entered Kmail works as it should.
    Previously when I used Kmail Akonadi would start automatically.
    When I stopped using Kmail I uninstalled it. Now I have reinstalled it on the same system and there was no need to reconfigure as all the original config files were still in place... but something seems to have gone wrong with akonadi.
    How can I set this up so that akonadi starts on boot / when kmail starts?
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  2. #2
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,217

    Default Re: Kmail - start akonadi

    As nobody has yet replied, FWIW I never use akonadi and always used to disable the server from starting by setting "StartServer=false" in "akonadiserverrc".

    Maybe see what that's set to?
    Regards, Paul

    Tumbleweed (Snapshot: 20190918) KDE Plasma 5
    Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected
    2x Leap 15.1 KDE Plasma 5

  3. #3
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    966

    Default Re: Kmail - start akonadi

    Quote Originally Posted by farcusnz View Post
    I've recently switched back to using Kmail in Plasma / 42.3
    However, whenever I start Kmail after a boot I get a screen announcing "The Akonadi Perosnal information Management System is not Running. This application cannot be used without it".
    Just under that is a start button. Once entered Kmail works as it should.
    Previously when I used Kmail Akonadi would start automatically.
    When I stopped using Kmail I uninstalled it. Now I have reinstalled it on the same system and there was no need to reconfigure as all the original config files were still in place... but something seems to have gone wrong with akonadi.
    How can I set this up so that akonadi starts on boot / when kmail starts?
    Code:
    karl@erlangen:~> cat .config/akonadi/akonadiserverrc
    [Debug]
    Tracer=null
    
    [%General]
    Driver=QMYSQL
    
    [QMYSQL]
    Host=
    Name=akonadi
    Options="UNIX_SOCKET=/tmp/akonadi-karl.nZUOMG/mysql.socket"
    ServerPath=/usr/sbin/mysqld
    StartServer=true
    karl@erlangen:~>
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  4. #4
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: Kmail - start akonadi

    this is my akonadiserverrc
    startserver is set to "true"

    Code:
    [Debug]
    Tracer=null
    
    
    [%General]
    Driver=QMYSQL
    
    
    [QMYSQL]
    Host=
    Name=akonadi
    Options="UNIX_SOCKET=/tmp/akonadi-farcus.xgYLl6/mysql.socket"
    ServerPath=/usr/sbin/mysqld
    StartServer=true
    from what I understand it is supposed to start when an application needs it . . . but kmail doesn't seem to be starting it
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  5. #5
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,217

    Default Re: Kmail - start akonadi

    Quote Originally Posted by farcusnz View Post
    this is my akonadiserverrc
    startserver is set to "true"
    Checking that was just a passing thought from when I used to disable the server from starting... seemed a little too easy to be the solution.

    Sorry, my knowledge of kmail/akonadi is virtually non-existent.

    Hopefully you'll receive a more useful reply.
    Regards, Paul

    Tumbleweed (Snapshot: 20190918) KDE Plasma 5
    Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected
    2x Leap 15.1 KDE Plasma 5

  6. #6
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    966

    Default Re: Kmail - start akonadi

    Quote Originally Posted by farcusnz View Post
    this is my akonadiserverrc
    startserver is set to "true"

    Code:
    [Debug]
    Tracer=null
    
    
    [%General]
    Driver=QMYSQL
    
    
    [QMYSQL]
    Host=
    Name=akonadi
    Options="UNIX_SOCKET=/tmp/akonadi-farcus.xgYLl6/mysql.socket"
    ServerPath=/usr/sbin/mysqld
    StartServer=true
    from what I understand it is supposed to start when an application needs it . . . but kmail doesn't seem to be starting it
    Upgraded to TW 20171104 a few minutes ago and tested kmail2 5.6.2. With akonadi stopped invoking kmail did start akonadi too. You may want to try: https://wiki.archlinux.org/index.php...n_to_fix_KMail
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  7. #7
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: Kmail - start akonadi

    Quote Originally Posted by karlmistelberger View Post
    Upgraded to TW 20171104 a few minutes ago and tested kmail2 5.6.2. With akonadi stopped invoking kmail did start akonadi too. You may want to try: https://wiki.archlinux.org/index.php...n_to_fix_KMail
    Not having much luck here.
    Followed the instructions to delete all akonadi config files.
    Added my mail accounts back in but still having to manually start akonadi on each fresh boot.
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,804
    Blog Entries
    14

    Default Re: Kmail - start akonadi

    Have a look at the akonadi logfiles in ~/.local/share/akonadi. You may have to rebuild the databas, but that's done by removing / renaming mentioned folder whilst akonadi has not started.
    To make sure you start with a really clean config, remove all akonadi traces in ~/.config and ~/.local/share/akondi, and ~/.config/kmail* and ~/.local/share/kmail* and ~/.local/share/kontact/*kmail* before logging in on the desktop.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    966

    Default Re: Kmail - start akonadi

    Quote Originally Posted by farcusnz View Post
    Not having much luck here.
    Followed the instructions to delete all akonadi config files.
    Added my mail accounts back in but still having to manually start akonadi on each fresh boot.
    With some versions of TW I had to start akonadi manually after booting, but not after graphical login. With TW 20171121 akonadi again starts automatically after booting.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  10. #10

    Default Re: Kmail - start akonadi

    Have you tried simply running
    Code:
    akonadictl start
    from the terminal? I don't use any akonadi applications, but I think that should enable auto start on log in. If not, you can always place the above command in a shell script and save the file in /home/(your user)/.config/autostart-scripts/ which will start the service.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •