Results 1 to 5 of 5

Thread: 20171101 to 20171102 AppStream Query.

  1. #1
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default 20171101 to 20171102 AppStream Query.

    Hi

    Prior to creating this post i looked at the Mailing List, & though i saw mentions of AppStream, i still don't know what to do here. I'm currently on TW [KDE] 20171101, & when i tried dup'ing this morning to 20171102, i was presented with this choice:

    Code:
    sudo zypper -vvv dup
    [sudo] password for root: 
    Verbosity: 3
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Initialising Target
    Checking whether to refresh metadata for My_openSUSE_Repo
    Checking whether to refresh metadata for Vivaldi
    Retrieving: http://repo.vivaldi.com/snapshot/rpm/x86_64/repodata/repomd.xml .................................................................................................................................................................[done]
    Checking whether to refresh metadata for Main Repository (NON-OSS)
    Retrieving: http://download.opensuse.org/tumbleweed/repo/non-oss/content ....................................................................................................................................................................[done]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/non-oss/media.1/media ..............................................................................................................................................................[done]
    Checking whether to refresh metadata for Main Repository (OSS)
    Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/content ........................................................................................................................................................................[done]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/media.1/media ..................................................................................................................................................................[done]
    Checking whether to refresh metadata for Main Update Repository
    Retrieving: http://download.opensuse.org/update/tumbleweed/repodata/repomd.xml ....................................................................................................................................................[done (371 B/s)]
    Checking whether to refresh metadata for Packman Repository
    Retrieving: http://packman.inode.at/suse/openSUSE_Tumbleweed/repodata/repomd.xml ................................................................................................................................................[done (1.0 KiB/s)]
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    Force resolution: No
    Computing upgrade...
    
    
    Problem: bundle-lang-gnome-en-13.2-57.2.noarch obsoletes appstream-glib-lang < 0.7.3 provided by appstream-glib-lang-0.7.2-6.1.noarch
     Solution 1: Following actions will be done:
      keep obsolete appstream-glib-lang-0.7.3-1.1.noarch
      keep obsolete appstream-glib-0.7.3-1.1.x86_64
     Solution 2: deinstallation of appstream-glib-lang-0.7.3-1.1.noarch
     Solution 3: deinstallation of bundle-lang-gnome-en-13.2-57.1.noarch
     Solution 4: keep obsolete bundle-lang-gnome-en-13.2-57.1.noarch
    
    
    Choose from above solutions by number or cancel [1/2/3/4/c] (c): c
    Which option should i choose pls?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,673
    Blog Entries
    3

    Default Re: 20171101 to 20171102 AppStream Query.

    I went with option 2.

    I did that on the principle that I can do without ".lang" packages. And better to drop the "appstream" one than the "gnome" one.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: 20171101 to 20171102 AppStream Query.

    Thanks for such a fast reply

    Aha, i like your logic. Now that you explained it, yes it does seem like the least-worst choice. albeit from my naive perspective, they all seemed intimidating. To ask another naive question of you... after your choice, & the completion of the dup & [presumed] reboot, is your TW all hunky-dory, no known breakages that this choice created?

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,673
    Blog Entries
    3

    Default Re: 20171101 to 20171102 AppStream Query.

    I have not noticed any problems.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: 20171101 to 20171102 AppStream Query.

    Quote Originally Posted by nrickert View Post
    I have not noticed any problems.
    Many thanks, i did it the same way here, & all seems good

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •