Results 1 to 2 of 2

Thread: YaST authetication server (LDAP) crash

  1. #1
    Join Date
    Aug 2008
    Location
    Belgium
    Posts
    184

    Angry YaST authetication server (LDAP) crash

    Hello,

    I start the authentication server in YaST and receive the first screen but when I select any option in global setting , schema files or databases it doesn't react (the right side of the screen is not refreshed)
    Doing a tail of /var/log/YaST/y2log i see a lot of lines and errors coming after each selection
    Code:
    017-11-03 17:34:10 <1> hpprol2(8126) [Ruby] auth-server/dialogs.rb:803 TreeDialog: seeing return value `wizardTree
    2017-11-03 17:34:10 <1> hpprol2(8126) [Ruby] auth-server/dialogs.rb:816 wizard-->current item is daemon
    2017-11-03 17:34:10 <1> hpprol2(8126) [Ruby] auth-server/dialogs.rb:171 callhandler cb_check for item daemon
    2017-11-03 17:34:10 <1> hpprol2(8126) [Ruby] auth-server/dialogs.rb:171 callhandler cb_write for item daemon
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 Cannot convert Array from 'any' to 'boolean'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 ------------- Backtrace begin -------------
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 (eval):2:in `to_boolean'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/include/auth-server/dialogs.rb:175:in `callHandler'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/include/auth-server/dialogs.rb:826:in `TreeDialog'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/include/auth-server/wizards.rb:28:in `block in MainSequence'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/lib64/ruby/vendor_ruby/2.4.0/yast/builtins.rb:546:in `eval'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/modules/Sequencer.rb:261:in `WS_run'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/modules/Sequencer.rb:333:in `block in Run'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/modules/Sequencer.rb:325:in `loop'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/modules/Sequencer.rb:325:in `Run'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/include/auth-server/wizards.rb:46:in `MainSequence'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/include/auth-server/wizards.rb:255:in `block in LdapServerSequence'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/lib64/ruby/vendor_ruby/2.4.0/yast/builtins.rb:546:in `eval'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/modules/Sequencer.rb:261:in `WS_run'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/modules/Sequencer.rb:333:in `block in Run'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/modules/Sequencer.rb:325:in `loop'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/modules/Sequencer.rb:325:in `Run'                                                              
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/include/auth-server/wizards.rb:287:in `LdapServerSequence'                                     
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/lib64/ruby/vendor_ruby/2.4.0/yast/fun_ref.rb:33:in `call'                                                  
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/lib64/ruby/vendor_ruby/2.4.0/yast/fun_ref.rb:33:in `call'                                                  
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/modules/CommandLine.rb:1517:in `Run'                                                           
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/clients/auth-server.rb:133:in `main'                                                           
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/share/YaST2/clients/auth-server.rb:278:in `<top (required)>'                                               
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/lib64/ruby/vendor_ruby/2.4.0/yast/wfm.rb:300:in `eval'                                                     
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/lib64/ruby/vendor_ruby/2.4.0/yast/wfm.rb:300:in `run_client'                                               
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/lib64/ruby/vendor_ruby/2.4.0/yast/wfm.rb:206:in `call_builtin'                                             
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/lib64/ruby/vendor_ruby/2.4.0/yast/wfm.rb:206:in `call_builtin_wrapper'                                     
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/lib64/ruby/vendor_ruby/2.4.0/yast/wfm.rb:195:in `CallFunction'                                             
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 /usr/lib/YaST2/bin/y2start:56:in `<main>'
    2017-11-03 17:34:10 <2> hpprol2(8126) [Ruby] (eval):2 ------------- Backtrace end ---------------
    Somebody can confirm this?

    Many thanks in advance
    Philippe
    Tumbleweed (x86_64) Kernel 4.18.5 with KDE plasma

  2. #2
    Join Date
    Jan 2012
    Location
    Compiegne / France
    Posts
    3

    Default Re: YaST authetication server (LDAP) crash

    Hello,

    First, it's not an anwser to your problem, sorry...

    I just want to share a problem on LDAP very closed of your. We use tumbleweed for our virtual workstation.
    We try to configure the workstation as client of our LDAP Server. From yast, we set the LDAP's server IP and clic "Test Connection", it's ok.
    After validation of the settings, YaST add some package for LDAP client. All seems to be ok.
    But after reboot, we get an error for 3 process that can't not start and stop the boot process, the first one is:
    failed to start Name Service cache daemon

    The main problem is that we can't access to console (Ctrl+Alt+F2...) and the recovery mode is not accessible too.
    So as it's a new installation, we restart from our last snapshot.
    In every case, for the moment we can not use LDAP with Tumbleweed, and after each test we get the same problem: the station is not usable...

    Every feedback on this kind of problem are welcome, thank you for your help.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •