Results 1 to 6 of 6

Thread: Raspberry PI 3 with touchscreen only - cannot complete setup

  1. #1
    Join Date
    Jun 2008
    Location
    Cleveland USA
    Posts
    138

    Default Raspberry PI 3 with touchscreen only - cannot complete setup

    Hi all,

    I'm running into a wall trying to set up tumbleweed (or even leap) on a pi 3 with only a touchscreen. After the initial setup, a login screen appears. With autologin disabled, no onscreen keyboard, and broken wifi out of the box, I can't get past this screen.
    I know I can complete the setup with a keyboard/mouse or an ethernet cable+ssh, but would prefer not to connect anything else to the pi.

    My questions are:

    How can I enable autologin on the pi?
    Editing /etc/sysconfig/displaymanager and setting DISPLAYMANAGER_AUTOLOGIN="yes" has no effect (possibly because the default pi user is root?)

    Failing autologin, (how) can I enable an onscreen keyboard for the login screen?

    Is there a way to get wifi working on firstboot?
    I can make the suggested changes for wifi to /etc/dracut.conf.d/raspberrypi_modules.conf while the microsd card is mounted on my computer, but can't run mkinitrd for obvious reasons.

    If I can somehow get wifi on firstboot, how can I configure wicd to connect to my wifi?
    Not sure where the wicd config file in located (does it accept network settings in wpa_supplicant.conf?)
    Unintentionally left blank...

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,333
    Blog Entries
    15

    Default Re: Raspberry PI 3 with touchscreen only - cannot complete setup

    Quote Originally Posted by coomac View Post
    Hi all,

    I'm running into a wall trying to set up tumbleweed (or even leap) on a pi 3 with only a touchscreen. After the initial setup, a login screen appears. With autologin disabled, no onscreen keyboard, and broken wifi out of the box, I can't get past this screen.
    I know I can complete the setup with a keyboard/mouse or an ethernet cable+ssh, but would prefer not to connect anything else to the pi.

    My questions are:

    How can I enable autologin on the pi?
    Editing /etc/sysconfig/displaymanager and setting DISPLAYMANAGER_AUTOLOGIN="yes" has no effect (possibly because the default pi user is root?)
    You put in your username not yes

    Quote Originally Posted by coomac View Post
    Is there a way to get wifi working on firstboot?
    I can make the suggested changes for wifi to /etc/dracut.conf.d/raspberrypi_modules.conf while the microsd card is mounted on my computer, but can't run modprobe for obvious reasons.

    If I can somehow get wifi on firstboot, how can I configure wicd to connect to my wifi?
    Not sure where the wicd config file in located (does it accept network settings in wpa_supplicant.conf?)
    Wireless still doesn't work on Tumbleweed AFAIK... Look through the archives;
    https://lists.opensuse.org/opensuse-arm/
    Last edited by malcolmlewis; 02-Nov-2017 at 10:37.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    Cleveland USA
    Posts
    138

    Default Re: Raspberry PI 3 with touchscreen only - cannot complete setup

    Quote Originally Posted by malcolmlewis View Post
    You put in your username not yes
    LOL! Wow do I feel ridiculous. I kid you not, I first tried root as the username, but probably didn't save the file or something equally silly and subsequently convinced myself root didn't work.

    Thanks for pointing out the solution!
    Unintentionally left blank...

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,333
    Blog Entries
    15

    Default Re: Raspberry PI 3 with touchscreen only - cannot complete setup

    Quote Originally Posted by coomac View Post
    LOL! Wow do I feel ridiculous. I kid you not, I first tried root as the username, but probably didn't save the file or something equally silly and subsequently convinced myself root didn't work.

    Thanks for pointing out the solution!
    Hi
    No question is ridiculous, else it wouldn't be a help forum

    What I normally do (is with a keyboard) press ctrl+alt+F1 and login as root and quickly create a non root user via;
    Code:
    useradd -m <my_user_name>
    passwd <my_user_name>
    exit
    The -m creates the home directory, then press ctrl+alt+F7 and then login as <my_user_name>.

    The other place to ask about the wifi is on IRC Freenode #opensuse-arm and post a query there.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Jun 2008
    Location
    Cleveland USA
    Posts
    138

    Default Re: Raspberry PI 3 with touchscreen only - cannot complete setup

    Ah I've been using opensuse for 15 years and still make dumb mistakes like that. Always good to have a second pair of eyes - much appreciation for the assistance.

    I did get the wifi working on tumbleweed once autologin was correctly enabled.
    For anyone else in the same situation, removing sdhci_iproc from /etc/dracut.conf.d/raspberrypi_modules.conf, then opening the boot manager in yast and hitting OK runs mkinitrd. Wifi should be up after a reboot.
    Unintentionally left blank...

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,333
    Blog Entries
    15

    Default Re: Raspberry PI 3 with touchscreen only - cannot complete setup

    Quote Originally Posted by coomac View Post
    Ah I've been using opensuse for 15 years and still make dumb mistakes like that. Always good to have a second pair of eyes - much appreciation for the assistance.

    I did get the wifi working on tumbleweed once autologin was correctly enabled.
    For anyone else in the same situation, removing sdhci_iproc from /etc/dracut.conf.d/raspberrypi_modules.conf, then opening the boot manager in yast and hitting OK runs mkinitrd. Wifi should be up after a reboot.
    Hi
    I see;
    Code:
    ip addr
    
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
        inet 192.168.10.103/24 brd 192.168.10.255 scope global eth0
           valid_lft forever preferred_lft forever
    3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
        link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
    
    cat /etc/dracut.conf.d/raspberrypi_modules.conf
    
    add_drivers+=" sdhci-iproc bcm2835-sdhost bcm2835_dma mmc_block dwc2 "
    # Workaround for Wifi
    #omit_drivers+=" sdhci-iproc"
    So it does work... must be bluetooth I was thinking about.. (see we always miss stuff )
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •