Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Raspi 2 XFCE image - Error when starting VNC server in YaST

  1. #1

    Default Raspi 2 XFCE image - Error when starting VNC server in YaST

    Hi!

    Burned todays image of TW raspi 2 XFCE and after first boot updated (some problems with QT5 not available, chose the "keep old version" for all 12 problems). Set up the firewall and wanted to start VNC with Yast, but always get

    "Error Enabling service vncmanager has failed"

    when trying to finish setup.

    I could start the vncserver manually from console/ssh, but would like to have the VNC running on boot automagically...

    Any idea how to resolve this?
    Kind regards

    raspu

  2. #2

    Default Re: Raspi 2 XFCE image - Error when starting VNC server in YaST

    ...are these raspi 2 images meant to be functional at all? Does somebody care? I tried to open PCManFM, nothing happens at all...
    Kind regards

    raspu

  3. #3

    Default Re: Raspi 2 XFCE image - Error when starting VNC server in YaST

    I took the JeOS image for Raspi 2 and added the pattern for LXQT, this is functional at first glance :-)

    Will have a further look...
    Kind regards

    raspu

  4. #4

    Default Re: Raspi 2 XFCE image - Error when starting VNC server in YaST

    Activated VNC Server in Yast, edited config, reboot. When entering vncviewer <IP> :1
    I get on a TW machine:

    Code:
    TigerVNC Viewer 64-bit v1.8.0
    Built on: ??-??-?? ??:??
    Copyright (C) 1999-2017 TigerVNC Team and many others (see README.txt)
    See http://www.tigervnc.org for information on TigerVNC.
    
    Wed Nov  1 15:02:14 2017
     DecodeManager: Detected 12 CPU core(s)
     DecodeManager: Creating 4 decoder thread(s)
     CConn:       connected to host 10.0.0.4 port 5901
    
    Wed Nov  1 15:02:15 2017
     CConnection: Server supports RFB protocol version 3.8
     CConnection: Using RFB protocol version 3.8
     CConnection: Choosing security type VeNCrypt(19)
     CVeNCrypt:   Choosing security type TLSNone (257)
    
    Wed Nov  1 15:02:30 2017
     CConn:       Using pixel format depth 24 (32bpp) little-endian rgb888
     CConn:       Using Tight encoding
    
    Wed Nov  1 15:02:35 2017
     CConn:       End of stream
    Window with login-screen opens, but when I try to enter User/Password, the window colapses and the connection is broke ("End of stream in" in log above). What's going on here?


    PS: Tried to login with monitor and keyboard, same effect, so the whole desktop is unstable. Apparently. sigh...
    Kind regards

    raspu

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Raspi 2 XFCE image - Error when starting VNC server in YaST

    Although I haven't tested the same image,
    Generally speaking,

    How are you installing VNC?
    Are you simply installing the VNC packages
    or
    Are you using YaST to install "Remote Administration?"

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #6

    Default Re: Raspi 2 XFCE image - Error when starting VNC server in YaST

    Hy!

    I went to YaST and enabled

    "Allow Remote Administration With Session Management".

    Did you read the PS? Apparently the desktop is unstable, as even the local login fails and the screen turns black....

    And btw: It's now TW JeOS for raspi 2 with LXQT pattern installed...
    Kind regards

    raspu

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Raspi 2 XFCE image - Error when starting VNC server in YaST

    Quote Originally Posted by suse_rasputin View Post
    Hy!

    I went to YaST and enabled

    "Allow Remote Administration With Session Management".

    Did you read the PS? Apparently the desktop is unstable, as even the local login fails and the screen turns black....

    And btw: It's now TW JeOS for raspi 2 with LXQT pattern installed...
    I don't recommend adding a Desktop to JeOS (I personally haven't checked that, and generally on x86 machines it doesn't work without problems).
    Instead, download the LXQt image and burn it to your SDcard.

    And, configure YaST > Remote Administration <without> session management at first because it's simpler, you can enable session management connections later.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Raspi 2 XFCE image - Error when starting VNC server in YaST

    Also,
    Verifying that you're getting your images from links on this page

    https://en.opensuse.org/HCL:Raspberry_Pi2

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  9. #9

    Default Re: Raspi 2 XFCE image - Error when starting VNC server in YaST

    Quote Originally Posted by tsu2 View Post
    Also,
    Verifying that you're getting your images from links on this page

    https://en.opensuse.org/HCL:Raspberry_Pi2

    TSU
    ...yepp. In the past the only functional images (for me) came from the repo of Stefan Bruens, but he discontinued the releases...
    Kind regards

    raspu

  10. #10

    Default Re: Raspi 2 XFCE image - Error when starting VNC server in YaST

    ...something is wrong with sudo in current TW 64bit KDE (not Raspi...):

    Code:
    sudo xzcat openSUSE-Tumbleweed-ARM-XFCE-raspberrypi2.armv7l-2016.08.20-Build2.2.raw.xz | dd bs=4M of=/dev/sdd iflag=fullblock oflag=direct; sync
    
    dd: failed to open '/dev/sdd': Permission denied
    ...but after su the same comand works just fine.
    Kind regards

    raspu

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •