Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Cannot install virtualbox - nothing provides libcrypto.so.1.0.0(OPENSSL_1.0.0)(64bit)

  1. #1
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    915

    Default Cannot install virtualbox - nothing provides libcrypto.so.1.0.0(OPENSSL_1.0.0)(64bit)

    When i try to install virtualbox 5.1.30 on a laptop running openSUSE 42.3 with Kernel 4.13.10-2.g951f578-default Yast always gives the error message

    nothing provides libcrypto.so.1.0.0(OPENSSL_1.0.0)(64bit) needed by virtualbox-5.1.30-2.7.x86_64

    Searching with Yast which package will provide libcrypto.so.1.0.0 yields that it is provided by package libopenssl1_0_0 Version 1.0.2j-10.1 which is already installed on my system.

    So why does Yast complain?

    My repository-setup is:

    Code:
    #  | Alias                                 | Name                                  | Enabled | GPG Check | Refresh | Priority | URI                                                                                                  
    ---+---------------------------------------+---------------------------------------+---------+-----------+---------+----------+------------------------------------------------------------------------------------------------------
     1 | openSUSE_Kernel_stable                | openSUSE Kernel stable                | Yes     | (r ) Yes  | Yes     |   93     | http://download.opensuse.org/repositories/Kernel:/stable/standard/                                   
     2 | openSUSE_VM_für_Kernel_stable         | openSUSE VM für Kernel stable         | Yes     | (r ) Yes  | Yes     |   94     | http://download.opensuse.org/repositories/Kernel:/stable:/KMP/standard/                              
     3 | Bumblebee-Projekt_Bumblebee3_für_42.3 | Bumblebee-Projekt Bumblebee3 für 42.3 | Yes     | (r ) Yes  | Yes     |   95     | http://download.opensuse.org/repositories/home:/Bumblebee-Project:/Bumblebee3/openSUSE_Leap_42.3/    
     4 | openSUSE_42.3_X11_Bumblebee           | openSUSE 42.3 X11 Bumblebee           | Yes     | (r ) Yes  | Yes     |   96     | http://download.opensuse.org/repositories/X11:/Bumblebee/openSUSE_Leap_42.3/                         
     5 | Packman_openSUSE_42.3_(TH_Aachen)     | Packman openSUSE 42.3 (TH Aachen)     | Yes     | (r ) Yes  | Yes     |   97     | http://ftp.halifax.rwth-aachen.de/packman/suse/openSUSE_Leap_42.3/                                   
     6 | repo-update                           | openSUSE-Leap-42.3-Update             | Yes     | (r ) Yes  | Yes     |   98     | http://download.opensuse.org/update/leap/42.3/oss/                                                   
     7 | repo-update-non-oss                   | openSUSE-Leap-42.3-Update-Non-Oss     | Yes     | (r ) Yes  | Yes     |   98     | http://download.opensuse.org/update/leap/42.3/non-oss/                                               
     8 | repo-non-oss                          | openSUSE-Leap-42.3-Non-Oss            | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/                                    
     9 | repo-oss                              | openSUSE-Leap-42.3-Oss                | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/distribution/leap/42.3/repo/oss/

  2. #2
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: Cannot install virtualbox - nothing provides=?us-ascii?Q?libcrypto=2Eso=2E1=2E0=2E0=28OPENSSL=5F1=2E0=2E0=29=2864bi?==?us-ascii?Q?t=29?=

    On Tue, 31 Oct 2017 11:36:01 +0000, susejunky wrote:

    > When i try to install virtualbox 5.1.30 on a laptop running openSUSE
    > 42.3 with Kernel 4.13.10-2.g951f578-default Yast always gives the error
    > message


    Where are you obtaining VirtualBox from?

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  3. #3
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    915

    Default AW: Re: Cannot install virtualbox - nothing provides=?us-ascii?Q?libcrypto=2Eso=2E1=2E0=2E0=28OPENSS

    Quote Originally Posted by hendersj View Post
    On Tue, 31 Oct 2017 11:36:01 +0000, susejunky wrote:

    > When i try to install virtualbox 5.1.30 on a laptop running openSUSE
    > 42.3 with Kernel 4.13.10-2.g951f578-default Yast always gives the error
    > message


    Where are you obtaining VirtualBox from?

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

    I try to install the package virtualbox 5.1.30 from this repository: http://download.opensuse.org/reposit.../KMP/standard/

  4. #4
    Join Date
    Sep 2012
    Posts
    7,106

    Default Re: AW: Re: Cannot install virtualbox - nothing provides=?us-ascii?Q?libcrypto=2Eso=2E1=2E0=2E0=28OP

    Quote Originally Posted by susejunky View Post
    I try to install the package virtualbox 5.1.30 from this repository: http://download.opensuse.org/reposit.../KMP/standard/
    This repository is built against Tumbleweed, not against Leap.

  5. #5
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: Cannot install virtualbox - nothing provides=?us-ascii?Q?libcrypto=2Eso=2E1=2E0=2E0=28OPENSSL=5F1=2E0=2E0=29=2864bi?==?us-ascii?Q?t=29?=

    On Tue, 31 Oct 2017 16:26:02 +0000, susejunky wrote:

    > hendersj;2843544 Wrote:
    >> On Tue, 31 Oct 2017 11:36:01 +0000, susejunky wrote:
    >>
    >> > When i try to install virtualbox 5.1.30 on a laptop running openSUSE
    >> > 42.3 with Kernel 4.13.10-2.g951f578-default Yast always gives the

    >> error
    >> > message

    >>
    >> Where are you obtaining VirtualBox from?
    >>
    >> --
    >> Jim Henderson openSUSE Forums Administrator Forum Use Terms &
    >> Conditions at http://tinyurl.com/openSUSE-T-C

    >
    >
    > I try to install the package virtualbox 5.1.30 from this repository:
    > http://tinyurl.com/gv9lk39


    Try using the one in the Virtualization repository instead. I've been
    using that one for years (though not on 42.3 - still running 42.2 here)
    and never had a problem with it.

    Jim



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: Cannot install virtualbox - nothing provides=?us-ascii?Q?libcrypto=2Eso=2E1=2E0=2E0=28OPENSSL=5F1=2E0=2E0=29=2864bi?==?us-ascii?Q?t=29?=

    On Tue, 31 Oct 2017 18:46:02 +0000, arvidjaar wrote:

    > susejunky;2843549 Wrote:
    >> I try to install the package virtualbox 5.1.30 from this repository:
    >> http://tinyurl.com/gv9lk39

    > This repository is built against Tumbleweed, not against Leap.


    Ah, yes, that also would do it.



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  7. #7
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    915

    Default AW: Re: AW: Re: Cannot install virtualbox - nothing provides=?us-ascii?Q?libcrypto=2Eso=2E1=2E0=2E0=

    Quote Originally Posted by arvidjaar View Post
    This repository is built against Tumbleweed, not against Leap.
    Thank you very much for your response. Nevertheless i'm still not quite sure how to solve my problem:

    Which repository provides a version of virtualbox (for openSUSE 42.3) that runs with the latest kernel from http://download.opensuse.org/reposit...able/standard/ ?

    I run an installation of openSUSE 42.2 on the same machine. There i use the repositories


    without any problem. So what changed in openSUSE 42.3?

    Regards

    susejunky

  8. #8
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    915

    Default AW: Re: Cannot install virtualbox - nothing provides=?us-ascii?Q?libcrypto=2Eso=2E1=2E0=2E0=28OPENSS

    Quote Originally Posted by hendersj View Post
    ... Try using the one in the Virtualization repository instead.
    Thank you very much for your reply.

    Is "http://download.opensuse.org/repositories/Virtualization/Kernel_stable_standard/" the correct repository? It only provides an slightly older version of virtualbox (5.1.6 vs 5.1.30) but that - i guess - is not a problem.

    Nevertheless when i replace "http://download.opensuse.org/repositories/Kernel:/stable:/KMP/standard/" with "http://download.opensuse.org/repositories/Virtualization/Kernel_stable_standard/" and try to install virtualbox 5.1.6 YaST gives me the error message

    nothing provides libvpx.so.4()(64bit) needed by virtualbox-5.1.6-236.1.x86_64

    So where do i get libvpx.so.4()(64bit) from?

    Regards

    susejunky

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,732

    Default AW: Cannot install virtualbox - nothing provides libcrypto.so.1.0.0(OPENSSL_1.0.0)(64bit)

    Get the src.rpm and buuild it by your own:

    f.e.:
    Code:
    wget https://download.opensuse.org/repositories/Kernel:/stable:/KMP/standard/src/virtualbox-5.1.30-3.2.src.rpm
    Code:
    rpmbuild --rebuild virtualbox-5.1.30-3.2.src.rpm
    And depending on your build Environment, you have all build Packages in /usr/src/packages/RPMS/.... noarch or x86_64

  10. #10
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    915

    Default AW: Cannot install virtualbox - nothing provides libcrypto.so.1.0.0(OPENSSL_1.0.0)(64bit)

    Quote Originally Posted by Sauerland View Post
    Get the src.rpm and buuild it by your own: ...
    Thank you very much for your reply.

    I will try to build the package. But even if i succeed there still remains the question why YaST does not recognize a package which is installed.

    Regards

    susejunky

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •