Results 1 to 2 of 2

Thread: secure-boot not working on asrock X99 taichi

  1. #1

    Default secure-boot not working on asrock X99 taichi

    Hi,
    I was not able to boot the installer media (USB) with secure boot enabled in my uefi firmware. With secure boot disabled all is working fine.
    I saw that opensuse use shim as secure boot loader, which is signed (also) with the microsft key so to be recognized by uefi bios. I'm sure my uefi bios is working becouse i was able to boot a microsoft genuine usb installation media with secure boot enabled, but with opensuse shim i can't boot in anyway.

    The motherboard is an ASRock X99 taichi. Someone else has had any similar experience?

    My hypothesis is to be in the case described here https://en.opensuse.org/openSUSE:UEFI in the section "Booting the Machine that supports only one signature with vendor provided Keys"

    Thank you all.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,741
    Blog Entries
    3

    Default Re: secure-boot not working on asrock X99 taichi

    Quote Originally Posted by jjletho View Post
    My hypothesis is to be in the case described here https://en.opensuse.org/openSUSE:UEFI in the section "Booting the Machine that supports only one signature with vendor provided Keys"
    Yes, very likely.

    You can test that hypothesis by following the directions in that linked documentation.

    I had that problem in a Lenovo ThinkServer. And the suggested work around worked fine. However, I found it more convenient to leave secure-boot disabled. A later BIOS update fixed the issue on that computer. So now I usually have secure-boot enabled -- except when testing a distro that does not support secure-boot.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •