Results 1 to 10 of 10

Thread: Epson ES-200 Document Scanner SUSE 42.3

  1. #1

    Default Epson ES-200 Document Scanner SUSE 42.3

    Greetings All,

    I recently purchased an EPSON ES-200 document scanner.
    The unit was advertised as 'Linux' compatible.
    However, I cannot seem to get drivers installed that will allow this machine to work with Suse 42.3.

    From the Epson download page, I downloaded the 'ImageScan' bundle,
    which appears to be the ONLY Linux download for this device.
    However,the install script fails to load due to 'unsigned packages'.
    I've tried to install the RPMs that were included in the package,
    but there are a number of prerequisites that are needed.

    The bundle is ONLY available for Suse level 42.2.
    I don't know if this is the cause of the failure, or if something else needs to be done.

    Does anyone know how to get this unit working for Suse, or where to obtain a driver?

    Thanx in advance.

    Richard Rosa

  2. #2

    Default Re: Epson ES-200 Document Scanner SUSE 42.3

    Well, I managed to find the driver source (on the Epson site).
    The source file compiled and installed.
    However, the driver does not work well with XSane.
    The scanner is recognized, and I can start scanning,
    but the program will pop-up a message "Operation Was Canceled" before anything has completed.

    I'm beginning to think that Epson lied about this being Linux compatible..

    Does anyone have any suggestions as to how I can get this working?


    Richard Rosa

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Epson ES-200 Document Scanner SUSE 42.3

    Have you confirmed which driver is in use? I'm just wondering if the epson or epson2 driver might be impacting here? Make sure only the driver (epkowa?) you installed is the only one uncommented in /etc/sane.d/dll.conf.

    What does the following return (when your scanner is plugged in)?
    Code:
    scanimage -L
    You could try testing the backend with
    Code:
    scanimage -T
    Report back with the output.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Epson ES-200 Document Scanner SUSE 42.3

    BTW, the Epson Linux Support page may also be useful to read as well....
    http://download.ebz.epson.net/faq/linux/scanner.html

    In particular...
    http://download.ebz.epson.net/faq/li..._ls_00017.html

  5. #5

    Default Re: Epson ES-200 Document Scanner SUSE 42.3

    Quote Originally Posted by deano_ferrari View Post
    Have you confirmed which driver is in use? I'm just wondering if the epson or epson2 driver might be impacting here? Make sure only the driver (epkowa?) you installed is the only one uncommented in /etc/sane.d/dll.conf.

    What does the following return (when your scanner is plugged in)?
    Code:
    scanimage -L
    You could try testing the backend with
    Code:
    scanimage -T
    Report back with the output.
    Here is the output of the commands:

    Code:
    scanimage -L
    device `utsushi:esci:usb:/sys/devices/pci0000:00/0000:00:15.2/0000:0b:00.0/usb6/6-1/6-1.1/6-1.1:1.0' is a EPSON ES-200 
    
    scanimage -T
    scanimage: sane_start: Operation was cancelled
    There's that 'Operation was cancelled' message again....

    Richard Rosa

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Epson ES-200 Document Scanner SUSE 42.3

    Ok, so you're using the Epson 'utsushi' driver. I now recall this old openSUSE thread discussing the same driver. In the end, the OP in that thread received the required support from the developer (refer post #16).

    After examining the utsushi README I note that the 'ES-200' model doesn't seem to be explicitly listed.

    FWIW, same model and issue reported here...
    https://github.com/utsushi/utsushi/issues/33

  7. #7

    Default Re: Epson ES-200 Document Scanner SUSE 42.3

    Quote Originally Posted by deano_ferrari View Post
    Ok, so you're using the Epson 'utsushi' driver. I now recall this old openSUSE thread discussing the same driver. In the end, the OP in that thread received the required support from the developer (refer post #16).

    After examining the utsushi README I note that the 'ES-200' model doesn't seem to be explicitly listed.
    I've come to the conclusion that even though the Epson site said this was the driver source, that it is NOT.

    It would appear that the ONLY application that can utilize this scanner is Epson's ImageScan.

    With a LOT of work, I managed to get the 'bundle' installed. In case anyone else attempts this, here is what was done:

    1) rpm -qpR .imagescan-3.32.0-1epson4opensuse42.2.x86_64.rpm
    2) Make note of ALL prereqs listed
    3) From YAST or zypper make sure that all the prereqs are installed (there are a LOT of them).
    4) rpm -ihv imagescan-3.32.0-1epson4opensuse42.2.x86_64.rpm

    Unfortunately, the Epson software lacks a LOT of the features of XSane, but this is what I am stuck with.


    Thanx to all for your help and suggestions.

    Richard Rosa

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Epson ES-200 Document Scanner SUSE 42.3

    Good to read of your success with this. BTW, if you install the rpm package with a package manager (YaST or zypper) it will take care of those dependencies for you.

  9. #9
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,033

    Default Re: Epson ES-200 Document Scanner SUSE 42.3

    Yes, good to read of your success.

    I've learnt from past experience that manufacturers claims of Linux compatibility don't always "tell the truth and whole truth"

    Prior to purchasing either printer or scanner I now always first check on:

    http://www.openprinting.org/printers and http://www.sane-project.org/sane-supported-devices.html

    to see what OSS drivers are available.

    Not of help to you in this particular case, but worth perhaps bearing in mind in the future.
    Regards, Paul

  10. #10
    Join Date
    Aug 2008
    Location
    Confoederatio helvetica
    Posts
    22

    Default Re: Epson ES-200 Document Scanner SUSE 42.3

    Quote Originally Posted by richardrosa View Post
    I've come to the conclusion that even though the Epson site said this was the driver source, that it is NOT.
    It would appear that the ONLY application that can utilize this scanner is Epson's ImageScan.
    Unfortunately, the Epson software lacks a LOT of the features of XSane, but this is what I am stuck with.
    Thanx to all for your help and suggestions.
    Richard Rosa
    Hello,

    I just installed with a lot of pain (the printer drivers) my new Epson ET-3750 under LEAP42.3.
    Because xsane is working (with some crashes due to sane) why do you say that Xsane is not working ?
    In my knowledge, Xsane is just a gui for sane, and imagescan does install everything for it (i think, before i had another from samsung)..
    Anyway i had to edit first the config file (EPSON:ET-3750__Series.drc) in ~/.sane/xsane/ and change the "resolution-bind" to 0

    Hope it will help

    Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •