Results 1 to 3 of 3

Thread: TuxGuitar. Cannot load 32-bit SWT libraries on 64-bit JVM

  1. #1

    Default TuxGuitar. Cannot load 32-bit SWT libraries on 64-bit JVM

    Hello
    I installed tuxguitar 1.4-106.1 x86_64 but when I trying to run this program I got an error:

    Code:
    > tuxguitar  
    java.lang.UnsatisfiedLinkError: Cannot load 32-bit SWT libraries on 64-bit JVM
            at org.eclipse.swt.internal.Library.loadLibrary(Library.java:263)
            at org.eclipse.swt.internal.Library.loadLibrary(Library.java:240)
            at org.eclipse.swt.internal.C.<clinit>(C.java:21)
            at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
            at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
            at org.eclipse.swt.widgets.Display.<clinit>(Display.java:133)
            at org.herac.tuxguitar.ui.swt.SWTApplication.<init>(SWTApplication.java:15)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
            at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
            at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
            at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
            at java.lang.Class.newInstance(Class.java:442)
            at org.herac.tuxguitar.util.TGServiceReader$IteratorImpl.next(TGServiceReader.java:91)
            at org.herac.tuxguitar.app.ui.TGApplication.lookupApplication(TGApplication.java:32)
            at org.herac.tuxguitar.app.ui.TGApplication.<init>(TGApplication.java:24)
            at org.herac.tuxguitar.app.ui.TGApplication$1.createInstance(TGApplication.java:56)
            at org.herac.tuxguitar.app.ui.TGApplication$1.createInstance(TGApplication.java:54)
            at org.herac.tuxguitar.util.singleton.TGSingletonUtil.getInstance(TGSingletonUtil.java:12)
            at org.herac.tuxguitar.app.ui.TGApplication.getInstance(TGApplication.java:54)
            at org.herac.tuxguitar.app.synchronizer.TGSynchronizerControllerImpl.<init>(TGSynchronizerControllerImpl.java:17)
            at org.herac.tuxguitar.app.TuxGuitar.createUIContext(TuxGuitar.java:113)
            at org.herac.tuxguitar.app.TuxGuitar.createApplication(TuxGuitar.java:100)
            at org.herac.tuxguitar.app.TGMain.main(TGMain.java:13)
    Exception in thread "main" java.util.NoSuchElementException
            at org.herac.tuxguitar.util.TGServiceReader$IteratorImpl.next(TGServiceReader.java:98)
            at org.herac.tuxguitar.app.ui.TGApplication.lookupApplication(TGApplication.java:32)
            at org.herac.tuxguitar.app.ui.TGApplication.<init>(TGApplication.java:24)
            at org.herac.tuxguitar.app.ui.TGApplication$1.createInstance(TGApplication.java:56)
            at org.herac.tuxguitar.app.ui.TGApplication$1.createInstance(TGApplication.java:54)
            at org.herac.tuxguitar.util.singleton.TGSingletonUtil.getInstance(TGSingletonUtil.java:12)
            at org.herac.tuxguitar.app.ui.TGApplication.getInstance(TGApplication.java:54)
            at org.herac.tuxguitar.app.synchronizer.TGSynchronizerControllerImpl.<init>(TGSynchronizerControllerImpl.java:17)                                                                                                                                                       
            at org.herac.tuxguitar.app.TuxGuitar.createUIContext(TuxGuitar.java:113)                                                                                                                                                                                                
            at org.herac.tuxguitar.app.TuxGuitar.createApplication(TuxGuitar.java:100)                                                                                                                                                                                             
            at org.herac.tuxguitar.app.TGMain.main(TGMain.java:13)  
    This is my java version:

    Code:
    > java -version
    openjdk version "1.8.0_144"
    OpenJDK Runtime Environment (IcedTea 3.5.1) (suse-10.15.2-x86_64)
    OpenJDK 64-Bit Server VM (build 25.144-b01, mixed mode)
    
    How can I solve this problem?

  2. #2

    Default Re: TuxGuitar. Cannot load 32-bit SWT libraries on 64-bit JVM


  3. #3

    Default Re: TuxGuitar. Cannot load 32-bit SWT libraries on 64-bit JVM

    I'd like to add that this was a bug in the eclipse-swt package in Factory (and Tumbleweed).
    The version in Leap 42.2 (and 42.3)'s standard repos never was affected it seems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •