Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Kaffein - DAB-S video only via VNC (no joke)

  1. #1

    Question Kaffein - DAB-S video only via VNC (no joke)

    Hy!

    Have here a TW 64 (all updates done, Kaffeine 2.0.13, repositories: packman priority 80, rest standard, priority 99).

    OK, Kaffeine worked fine from setup in February, some days ago I wanted to watch TV (DVB-S), audio was OK, but Kaffeine window stayed black, no matter what I do.

    Had to work with the machine via VNC and just for fun I started Kaffeine and ...believe it or not... via VNC the video signal is there (no way to watch TV this way, but anyhow...)

    Does anybody have the slightes idea where to look for this weired stuff?
    Kind regards

    raspu

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 9
    Posts
    14,589

    Default Re: Kaffein - DAB-S video only via VNC (no joke)

    What video/driver?

  3. #3

    Default Re: Kaffein - DAB-S video only via VNC (no joke)

    ..it's an older NVIDIA card (Quadro NVS 290) in a Dell Precision 690 Tower. No NVIDIA stuff installed, so this opensuse eehm.. forgot the name... standard driver for NVIDIA...
    Kind regards

    raspu

  4. #4
    Join Date
    May 2012
    Location
    Finland
    Posts
    1,950

    Default Re: Kaffein - DAB-S video only via VNC (no joke)

    Forum didn't want me to post yesterday, but it sounds like the xine output module needs to be changed. (opengl/overlay/vdpau etc)

    I can't remember if Kaffeine had this option in the settings or if you needed to change it using the xine configuration file.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  5. #5

    Default Re: Kaffein - DAB-S video only via VNC (no joke)

    Hi and many thanks for reply!

    I could not find any hint to xine re kaffeine

    https://www.linuxtv.org/wiki/index.php/Kaffeine

    ...and thought it's based on VLC-player?!?

    Anyway the options via menus are VERY sparse in Kaffeine, so any hint to the correct config file highly appreciated.

    Have here another DVB-S machine with Kaffeine, but after some problems I followed Wolfi's advice to switch to Kaffeine 1 from some other repo. But would have to have a closer look and the machine is currently remote.
    Kind regards

    raspu

  6. #6
    Join Date
    May 2012
    Location
    Finland
    Posts
    1,950

    Default Re: Kaffein - DAB-S video only via VNC (no joke)

    I'll install Kaffeine later on and give it a peek unless someone else has an idea - it's been *many* years since I last used it for DVB but I recall having to tweak the video output module for some GPUs and their drivers.

    So what I'm saying might be outdated - I need to install and see.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  7. #7
    Join Date
    May 2012
    Location
    Finland
    Posts
    1,950

    Default Re: Kaffein - DAB-S video only via VNC (no joke)

    To, I was sort of right and sort of wrong;
    Kaffeine and Kaffeine4 are XINE based but Kaffeine5 is VLC based (Kaffeine 2.0+ in TW)

    You might try launching kaffeine from the terminal using the following parameter;
    -V xcb_glx
    or
    -V
    vout_sdl

    These should define the video output module for Kaffeine as it uses the same as VLC. ( vlc -l )

    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  8. #8

    Default Re: Kaffein - DAB-S video only via VNC (no joke)

    Thank you, will try!

    Do you have any simple alternative to Kaffeine for DVB-S, just watching a little TV, sometimes starting some videorecording?
    Kind regards

    raspu

  9. #9
    Join Date
    May 2012
    Location
    Finland
    Posts
    1,950

    Default Re: Kaffein - DAB-S video only via VNC (no joke)

    VLC, MPlayer but optimally we should get your Kaffeine working since you're used to it.

    I'm almost 100% sure it's just a case of finding the right video output module.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  10. #10

    Default Re: Kaffein - DAB-S video only via VNC (no joke)

    Sorry, I could NOT debug the original system I opend this thread for, but I have a comparable problem on another Kaffein on TW 64bit KDE. No video, window is black, but audio is OK.

    Code:
    kaffeine -v
    Qt: 4.8.7
    KDE Development Platform: 4.14.37
    Kaffeine: 1.2.2
    starting in console gives:

    Code:
    kaffeine
    asdfghjk@linux1234:~> vo_vdpau: this hardware doesn't support h264.
    vo_vdpau: this hardware doesn't support vc1.
    vo_vdpau: this hardware doesn't support mpeg1/2.
    vo_vdpau: this hardware doesn't support mpeg4-part2.
    net_buf_ctrl: dvbspeed mode
    net_buf_ctrl: prebuffering...
    [h264 @ 0x7f61c4002f20] SPS unavailable in decode_picture_timing
    [h264 @ 0x7f61c4002f20] non-existing PPS 0 referenced
    [h264 @ 0x7f61c4002f20] decode_slice_header error
    [h264 @ 0x7f61c4002f20] no frame!
    [h264 @ 0x7f61c4002f20] SPS unavailable in decode_picture_timing
    [h264 @ 0x7f61c4002f20] non-existing PPS 0 referenced
    [h264 @ 0x7f61c4002f20] decode_slice_header error
    [h264 @ 0x7f61c4002f20] no frame!
    [h264 @ 0x7f61c4002f20] SPS unavailable in decode_picture_timing
    [h264 @ 0x7f61c4002f20] non-existing PPS 0 referenced
    [h264 @ 0x7f61c4002f20] decode_slice_header error
    [h264 @ 0x7f61c4002f20] no frame!
    [h264 @ 0x7f61c4002f20] SPS unavailable in decode_picture_timing
    [h264 @ 0x7f61c4002f20] non-existing PPS 0 referenced
    [h264 @ 0x7f61c4002f20] decode_slice_header error
    [h264 @ 0x7f61c4002f20] no frame!
    [h264 @ 0x7f61c4002f20] SPS unavailable in decode_picture_timing
    [h264 @ 0x7f61c4002f20] non-existing PPS 0 referenced
    [h264 @ 0x7f61c4002f20] decode_slice_header error
    [h264 @ 0x7f61c4002f20] no frame!
    [h264 @ 0x7f61c4002f20] SPS unavailable in decode_picture_timing
    [h264 @ 0x7f61c4002f20] non-existing PPS 0 referenced
    [h264 @ 0x7f61c4002f20] decode_slice_header error
    [h264 @ 0x7f61c4002f20] no frame!
    net_buf_ctrl: dvbspeed 100% @ video 2820 ms 471 buffers
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode                                                    
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode                                                    
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode                                                    
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode                                                    
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode                                                    
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode                                                    
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode                                                    
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode                                                    
    [h264 @ 0x7f61c4002f20] Got unexpected packet size after a partial decode
    .........
    Graphics is Nouveau with NVIDIA Quadro FX1800.

    I tried

    Code:
    kaffeine --graphicssystem opengl
    which fails with an error message as well as

    Code:
    kaffeine --graphicssystem raster
    which fails with the same error messages as starting without any options.
    Kind regards

    raspu

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •