Results 1 to 7 of 7

Thread: Opensuse 42.3 Installation Screen freezes after "Loading initial ramdisk... "

  1. #1

    Unhappy Opensuse 42.3 Installation Screen freezes after "Loading initial ramdisk... "

    Hello,

    I an trying to install Suse 42.3 on my new Lenovo Miix 320-10ICR. But each time the installation screen freezes after "Loading initial ramdisk... ". I had the same problem with Linux Mint.

    On a Lenovo Forum I was advised Ubuntu 17.4 for atom processors http://linuxiumcomau.blogspot.com which installed without problems. However I just cannot put up with Ubuntu (some functions like sound and battery monitor also don't work).

    I tried Boot Commands like "nomodeset" and "Textmode=1", no success.

    The EFI/boot of Ubuntu 17.4 contains a file with the name of "bootia32.efi" which 42.3 doesn't. Is that the difference?

    Thanks in advance

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    2,238

    Default Re: Opensuse 42.3 Installation Screen freezes after "Loading initial ramdisk... "

    Quote Originally Posted by noehlmann View Post
    Hello,

    I an trying to install Suse 42.3 on my new Lenovo Miix 320-10ICR. But each time the installation screen freezes after "Loading initial ramdisk... ". I had the same problem with Linux Mint.

    On a Lenovo Forum I was advised Ubuntu 17.4 for atom processors http://linuxiumcomau.blogspot.com which installed without problems. However I just cannot put up with Ubuntu (some functions like sound and battery monitor also don't work).

    I tried Boot Commands like "nomodeset" and "Textmode=1", no success.

    The EFI/boot of Ubuntu 17.4 contains a file with the name of "bootia32.efi" which 42.3 doesn't. Is that the difference?

    Thanks in advance
    Not very sure, maybe a better expert should confirm this, but AFAIK many (all?) Atom processors need a 32 bit EFI launcher that openSUSE doesn't provide; so apparently the missing bootia32.efi is indeed your problem.
    Tumbleweed Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.3

  3. #3
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    2,238

    Default Re: Opensuse 42.3 Installation Screen freezes after "Loading initial ramdisk... "

    OOOps! There are some newer Atoms that support the 64 bit instruction set, like the Atom-x5-Z8350 that might be inside your Lenovo Miix 320-10ICR. https://ark.intel.com/en/products/93...up-to-1_92-GHz
    So maybe your problem might be different...
    Tumbleweed Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.3

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Opensuse 42.3 Installation Screen freezes after "Loading initial ramdisk... "

    Some more grub2 commands you can try

    https://forums.linuxmint.com/viewtopic.php?t=236460

    Apparently you may also need to verify Bitlocker is not enabled.

    On second thought, your error might be happening before grub2 is even loaded.
    You may need to first see if you can boot off a USB stick (ie a LiveCD) to verify your hardware BIOS has no problems with an openSUSE in general...

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,576

    Question Re: Opensuse 42.3 Installation Screen freezes after "Loading initial ramdisk... "

    Was it running 32-bit or 64-bit Windows?

    It may be that, there's a UEFI/BIOS setting for 32-bit or 64-bit Windows . . .

  6. #6

    Default Re: Opensuse 42.3 Installation Screen freezes after "Loading initial ramdisk... "

    Sorry, overlooked those answers. Believe it or not, I am still not one step further with the issue.
    Could install Ubuntu on the machine, but this is not what I want.

    What is Bitlocker?

    How do I find out, whether the hardware BIOS has a problem with openSuse in General?

    Best Regards

    noelmann

    Quote Originally Posted by tsu2 View Post
    Some more grub2 commands you can try

    https://forums.linuxmint.com/viewtopic.php?t=236460

    Apparently you may also need to verify Bitlocker is not enabled.

    On second thought, your error might be happening before grub2 is even loaded.
    You may need to first see if you can boot off a USB stick (ie a LiveCD) to verify your hardware BIOS has no problems with an openSUSE in general...

    TSU

  7. #7

    Default Re: Opensuse 42.3 Installation Screen freezes after "Loading initial ramdisk... "

    Hello,

    How do I get a 32 bit EFI launcher for a 64 bit machine?

    Quote Originally Posted by OrsoBruno View Post
    Not very sure, maybe a better expert should confirm this, but AFAIK many (all?) Atom processors need a 32 bit EFI launcher that openSUSE doesn't provide; so apparently the missing bootia32.efi is indeed your problem.
    Best Regards

    Noehlmann

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •