Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: The anaconda issue again (Could not start d-bus, can you call qdbus-qt5)

  1. #1

    Default The anaconda issue again (Could not start d-bus, can you call qdbus-qt5)

    Hello Forum,

    I am experiencing an identical issue to one posted here previously; after installing Anaconda, the error dialog box "Could not start d-bus, can you call qdbus-qt5" is seen at login.

    https://forums.opensuse.org/showthre...call-qdbus-qt5

    After looking through many threads, I see there is a simple but inconvenient fix which is to edit ~/.bashrc and comment out the line below

    Code:
    # export PATH="/home/nick/anaconda3/bin:$PATH
    This does work and when the line is commented out, KDE starts correctly.
    However, I would really like to be able to keep the line in .bashrc as I otherwise need to state the full path to every function I call from ~/anaconda3/bin

    I have read through the information in the above thread and have attempted the solutions recommended by wolfi323 in post #4

    Of the three options suggested by wolfi323, I have already confirmed that option 1 works but is a little inconvenient.
    The other two options were
    - copy or symlink qdbus-qt5 in /home/username/anaconda3/bin
    - modify /usr/bin/startkde and add the explicit path to the call to qtpaths, i.e. replace qtpaths with /usr/bin/qtpaths

    I have attempted the symlink option without any success, but this could be a mistake on my part as I still very much a novice!

    This is how I attempted it.

    I have an up to date installation of OpenSuse Leap 42.3

    When "PATH =" line is commented out of ~/.bashrc

    Code:
    > qtpaths --binaries-dir
    /usr/lib64/qt5/bin
    
    > which qtpaths
    /usr/bin/qtpaths
    When "PATH =" line is NOT commented out of ~/.bashrc

    Code:
    >qtpaths --binaries-dir
    /home/nick/anconda3/bin
    
    >which qtpaths
    /home/nick/anaconda3/bin/qtpaths
    If I understand correctly, I need to backup and remove the copy of qtpaths from /home/nick/anaconda3/bin and place a symlink to either /usr/lib64/qt5/bin/qtpaths or /usr/bin/qtpaths.

    This is what I tried.

    Code:
    mv ~/anaconda3/bin/qtpaths ~/qtpaths.bak
    ln -s /usr/lib64/qt5/bin/qtpaths ~/anaconda3/bin/qtpaths
    Did not work so I then tried
    Code:
    rm ~/anaconda3/bin/qtpaths
    ln -s /usr/bin/qtpaths ~/anaconda3/bin/qtpaths
    Am I doing this correctly. If not,please could someone explain where I am going wrong.

    Many thanks,

    Nick

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,601

    Default Re: The anaconda issue again (Could not start d-bus, can you call qdbus-qt5)

    I have not read all of your post and thus I may be completely wrong, but did you try to put your personal directory at the end of PATH?
    Code:
    export PATH="$PATH:/home/nick/anaconda3/bin"
    (And what you posted can not be correct, there is a " missing there )
    Henk van Velden

  3. #3

    Default Re: The anaconda issue again (Could not start d-bus, can you call qdbus-qt5)

    Hello Henk,

    Thank you for your reply. You are correct, the path in my original post was incomplete.

    The full path should have read

    Code:
    export PATH="/home/nick/anaconda3/bin:$PATH"
    I will update my original post.

    Best wishes,

    Nick

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,601

    Default Re: The anaconda issue again (Could not start d-bus, can you call qdbus-qt5)

    Quote Originally Posted by BeakersHelper View Post
    Hello Henk,, or something else.

    Thank you for your reply. You are correct, the path in my original post was incomplete.

    The full path should have read

    Code:
    export PATH="/home/nick/anaconda3/bin:$PATH"
    I will update my original post.

    Best wishes,

    Nick
    You can not update your original post. You will have to do with the correction you posted here.

    But the important thing is if you tested my suggestion or rejected it out of hand. or did something different with it.
    Henk van Velden

  5. #5

    Default Re: The anaconda issue again (Could not start d-bus, can you call qdbus-qt5)

    Quote Originally Posted by hcvv View Post
    You can not update your original post. You will have to do with the correction you posted here.

    But the important thing is if you tested my suggestion or rejected it out of hand. or did something different with it.
    Hello Henk,

    I would certainly not reject any suggestions out of hand. The only use of the PATH line I have tried so far is to comment it out or include it.

    If it is commented out, KDE starts correctly but I need to include the full path to applications in the directory. E.g.
    ~/anaconda3/bin/conda

    If the line is not commented out, KDE does not start correctly and I get the "Could not start d-bus, can you call qdbus-qt5" message.

    Please could you explain in more detail what you suggested I should try.

    Many thanks.

    Nick

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,601

    Default Re: The anaconda issue again (Could not start d-bus, can you call qdbus-qt5)

    I suggested an alternative in my post #2 above!
    Didn't you see that?
    You only answered my side remark that was put between ( ), but the post starts with what is important (that is, what I though that it might be important for you.

    I will repeat it:
    Code:
    export PATH="$PATH:/home/nick/anaconda3/bin"
    Henk van Velden

  7. #7

    Default Re: The anaconda issue again (Could not start d-bus, can you call qdbus-qt5)

    Quote Originally Posted by hcvv View Post
    I will repeat it:
    Code:
    export PATH="$PATH:/home/nick/anaconda3/bin"
    Hello Henk,

    Thank you for the suggestion. First time around, I did not notice that your suggestion was not the same as what I had already tried. In your suggestion, the $PATH is at the start of the string, not at the end.

    I have just tried it and I am pleased to report that it appears to work! :-)

    With the line you suggested in the ~/.bashrc, KDE still starts successfully and I can access the anaconda applications directly from the terminal without prefixing the full path.

    Please could you explain why this variation works as there is only one other line in .bashrc

    Code:
    test -s ~/.alias && . ~/.alias || true
    
    # added by Anaconda3 installer
    # export PATH="/home/nick/anaconda3/bin:$PATH"
    export PATH="$PATH:/home/nick/anaconda3/bin"
    Thank you again for your help!

    Best wishes,

    Nick

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,601

    Default Re: The anaconda issue again (Could not start d-bus, can you call qdbus-qt5)

    Quote Originally Posted by BeakersHelper View Post
    Hello Henk,

    Thank you for the suggestion. First time around, I did not notice that your suggestion was not the same as what I had already tried. In your suggestion, the $PATH is at the start of the string, not at the end.
    Always read and re-read and try to understand helper posts .
    Quote Originally Posted by BeakersHelper View Post
    Please could you explain why this variation works as there is only one other line in .bashrc
    From
    Code:
    man bash
    PATH
    The search path for commands. It is a colon-separated list of directories in which the shell looks for commands (see COMMAND EXECUTION below). A zero-length (null) directory name in the value of PATH indicates the current directory. A null directory name may appear as two adjacent colons, or as an initial or trailing colon. The default path is system-dependent, and is set by the administrator who installs bash. A common value is ``/usr/gnu/bin:/usr/local/bin:/usr/ucb:/bin:/usr/bin''.
    As the directories are tried from left to right, there will be a difference between what the shell (and in your case, also KDE and Anaconda) will find if two or more files with the same name are found in different directories mentioned there. It will use the first one found. In my suggestion, the system directories are searched first and your addition as last. In your original, your addition is searched first. Imagine when programs with the names of common tools like ls are found there! They will be executed instead of the real ls.

    So an incorrect PATH can lead to the wrong program being executed. Specially for root this can be fatal. That is why you should always use
    Code:
    su -
    instead of plain
    Code:
    su
    With the first root will always have it's own PATH (which is different from what others get) instead of a crafted one from the original user that executes the su.

    BTW, I wonder why the Anaconda designers think that starting with it is the better setting.
    Henk van Velden

  9. #9

    Default Re: The anaconda issue again (Could not start d-bus, can you call qdbus-qt5)

    Hello Henk,

    Thank you for the explanation, I now understand why your solution works. It is elegant and logical once someone has explained it to me!

    I appreciate your help.

    Best wishes,

    Nick

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,601

    Default Re: The anaconda issue again (Could not start d-bus, can you call qdbus-qt5)

    You are welcome.

    With Linux, every day is learning day
    Henk van Velden

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •