Results 1 to 4 of 4

Thread: Application update problem

  1. #1

    Default Application update problem

    Hello. I try to install Add-on to Anki und run into problem:

    Code:
    Download failed: Traceback (most recent call last):
    
       File "/usr/share/anki/aqt/downloader.py", line 67, in run
         aqt.appShared + "download/%d" % self.code)
       File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1650, in request
         (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
       File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1443, in _request
         redirections=redirections - 1)
       File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1650, in request
         (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
       File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1390, in _request
         (response, content) = self._conn_request(conn, request_uri, method, body, headers)
       File "/usr/share/anki/aqt/sync.py", line 467, in _conn_request
         conn.connect()
       File "/usr/lib/python2.7/site-packages/httplib2/__init__.py", line 1083, in connect
    
         raise SSLHandshakeError(e)
     SSLHandshakeError: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:661)
    I've disable ssl certificate validation in /usr/lib/python2.7/site-packages/httplib2/__init__.py but it didn't help

    Code:
    more /usr/lib/python2.7/site-packages/httplib2/__init__.py | grep disable_ssl
                     ca_certs=None, disable_ssl_certificate_validation=True,
            self.disable_ssl_certificate_validation = \
                    disable_ssl_certificate_validation
                        self.disable_ssl_certificate_validation, self.ca_certs,
                    if not self.disable_ssl_certificate_validation:
        disable_ssl_certificate_validation, and ssl_version are all dropped on
                     disable_ssl_certificate_validation=True,
        The parameters proxy_info, ca_certs, disable_ssl_certificate_validation,
                     disable_ssl_certificate_validation=True,
                    not disable_ssl_certificate_validation)
                     ca_certs=None, disable_ssl_certificate_validation=True,
            If disable_ssl_certificate_validation is true, SSL cert validation will
            self.disable_ssl_certificate_validation = \
                    disable_ssl_certificate_validation
                                    disable_ssl_certificate_validation=
                                            self.disable_ssl_certificate_validation,
                                    disable_ssl_certificate_validation=
                                            self.disable_ssl_certificate_validation,

    Please, help me

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,887
    Blog Entries
    15

    Default Re: Application update problem

    Hi and welcome to the Forum
    Unfortunately it looks like the linux version is broken and not fixed yet by the developers (they did a release for Win and osX);
    See 2.0.48: https://apps.ankiweb.net/docs/changes.html
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Application update problem

    Malcolm, thank you very much

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,887
    Blog Entries
    15

    Default Re: Application update problem

    Quote Originally Posted by nortlov View Post
    Malcolm, thank you very much
    Hi
    Your welcome I suggest perhaps ask the developers when a fix maybe likely? If so post a link back here, or update the thread if you see a fix available and can look at updating the Education repo package (Assuming this is where you got it from?).
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •