Results 1 to 8 of 8

Thread: Can't load nvidia-drm.ko after update

  1. #1

    Default Can't load nvidia-drm.ko after update

    After update to 4.4.90 (if I recall correctly) I can't installing full nvidia driver (downloaded from nvidia site) - during install just after building I get "can't load nvidia-drm.ko" message. After reverting to previous kernel version (and previous kernel-devel) it installs correctly.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    2,996

    Default AW: Can't load nvidia-drm.ko after update

    Maybe you should post the whole log.

    But do you try the latest Driver?
    Its under the Beta Tab at nvidia homepage:
    Code:
    nvidia-settings -v
    
    nvidia-settings:  version 387.12  (buildmeister@swio-display-x86-rhel47-04)  Thu Sep 28 20:48:19 PDT
    2017
      The NVIDIA X Server Settings tool.
    
      This program is used to configure the NVIDIA Linux graphics driver.
      For more detail, please see the nvidia-settings(1) man page.
    drm-kmp-default is also deinstalled?

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    17,842
    Blog Entries
    13

    Default Re: Can't load nvidia-drm.ko after update

    Quote Originally Posted by Pshemas View Post
    After update to 4.4.90 (if I recall correctly) I can't installing full nvidia driver (downloaded from nvidia site) - during install just after building I get "can't load nvidia-drm.ko" message. After reverting to previous kernel version (and previous kernel-devel) it installs correctly.
    This is about Leap. why don't you use the NVIDIA repo ? When using the NVIDIA blob you;ll need to rebuild the driver. Where using the repo you'd be having the updated kernel module
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: Can't load nvidia-drm.ko after update

    @Sauderland: ahhh... I see it now - one of the updates pulled back drm-kmp-default. As soon as I removed it (again) all went as it should .

    Quote Originally Posted by Knurpht View Post
    This is about Leap. why don't you use the NVIDIA repo ? When using the NVIDIA blob you;ll need to rebuild the driver. Where using the repo you'd be having the updated kernel module
    @Knurpht: I'd love to. The reason I didn't is simple - the instructions from https://en.opensuse.org/SDB:NVIDIA_drivers didn't work for me. After adding the repo, when I typed (as instructed):
    Code:
    zypper install-new-recommends
    it didn't pull a single thing. Thus I reverted to the distro-agnostic (I'm new to OpenSUSE) way I know .

  5. #5
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    858

    Default Re: Can't load nvidia-drm.ko after update

    Quote Originally Posted by Pshemas View Post
    Code:
    zypper install-new-recommends
    it didn't pull a single thing. Thus I reverted to the distro-agnostic (I'm new to OpenSUSE) way I know .
    Use
    Code:
    zypper install nvidia-glG04 x11-video-nvidiaG04 nvidia-gfxG04-kmp-default nvidia-computeG04
    Change the G04 as necessary, depending on the version you wish to install.
    Regards, Paul

    Tumbleweed (Snapshot: 20180629) KDE Plasma 5
    Leap 42.3 KDE Plasma 5
    [Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected just for fun]


  6. #6

    Default Re: Can't load nvidia-drm.ko after update

    Quote Originally Posted by tannington View Post
    Use
    Code:
    zypper install nvidia-glG04 x11-video-nvidiaG04 nvidia-gfxG04-kmp-default nvidia-computeG04
    Change the G04 as necessary, depending on the version you wish to install.
    Thank you Tannington - how can I check what options (G04? - how would I know that) are available?
    Also is there a way to edit the wiki as at this moment the Nvidia part is not really helpfull for new users if it does not cover this part. If there's a way I'd be happy to add those.

  7. #7
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    858

    Default Re: Can't load nvidia-drm.ko after update

    Which driver you install is dependant upon the video card you have.

    I've just checked the nvidia leap 42.3 repo and it currently has:

    *G02 - V304.*
    *G03 - V340.*
    *G04 - V384.*

    If you take a look at this nvidia page:
    https://devtalk.nvidia.com/default/t...iver-releases/
    you can see which video cards those drivers support.

    The wiki page you linked to has a "login" link at the top right. It's the same login credentials as the forum. I'm sorry, but I don't know if there are any restrictions on who is able to edit the pages.
    Regards, Paul

    Tumbleweed (Snapshot: 20180629) KDE Plasma 5
    Leap 42.3 KDE Plasma 5
    [Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected just for fun]


  8. #8
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,773

    Default Re: Can't load nvidia-drm.ko after update

    Quote Originally Posted by Pshemas View Post
    how can I check what options (G04? - how would I know that) are available?
    Yast > Software Manager. In the search box type nvidia. Press enter.

    Seriously, Yast software manager (as well as it's other modules) is great. You can easily see what's installed, what versions are available from which repos (just click the versions tab), what repos are enabled in configurations menu > repos - that will temporarily switch you to Yast's repositories module and back, etc.

    Now, I like the command line as much as any other end user (i.e., if I must), but yast is special, it pays to learn how to use it.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •