Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: suddenly akregator crashes

  1. #1
    Join Date
    Jun 2008
    Location
    Europe
    Posts
    405

    Default suddenly akregator crashes

    Now, i've been using akregator for ages, and it suddenly crashes without any explanations except the little lady bug that tells me to report a bug.
    Anyone has the same behavior ?

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,001

    Default Re: suddenly akregator crashes

    Fire it up from konsole and reveal the secrets it outputs there.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3
    Join Date
    Jun 2008
    Location
    Europe
    Posts
    405

    Default Re: suddenly akregator crashes

    Thank you.
    I had already tried that but could not guess anything from the displayed lines.
    I hope you can tell more than me with this :

    Code:
     void AdblockManager::reloadConfig() false    AdBlock::AdblockManager(0x2bd7120)
    "Tag 'a' is not defined in message {<__kuit_internal_top__>Pour plus d'informations sur l'utilisation d'Akregator, v...}."
    "Tag 'a' is not defined in message {<__kuit_internal_top__>Pour plus d'informations sur l'utilisation d'Akregator, v...}."
    "http://www.kde.org/kde-look-content.rdf"
    "http://www.kde.org/dot/kde-apps-content.rdf"
    "https://www.linux.com/rss/feeds.php"
    "http://pim.planetkde.org/rss20.xml"
    "https://store.kde.org/content.rdf"
    "https://fr.planetkde.org/rss20.xml"
    "http://zdnet.fr/feeds/rss/actualites/informatique/open_source/"
    "http://kernel.org/kdist/rss.xml"
    "http://www.clubic.com/xml/news.xml"
    "http://www.generation-nt.com/export/rss.xml"
    "http://www.matbe.com/export/rss.xml"
    "http://www.aldebaran-robotics.com/forum/rss.php"
    "http://www.nvnews.net/vbulletin/external.php?type=RSS2&forumids=13"
    "http://www.nvnews.net/vbulletin/external.php?type=RSS2&forumids=27"
    "http://www.lemonde.fr/rss/sequence/0,2-3244,1-0,0.xml"
    "http://www.lemonde.fr/rss/sequence/0,2-651865,1-0,0.xml"
    "http://www.lemonde.fr/rss/sequence/0,2-3208,1-0,0.xml"
    "http://rss.lefigaro.fr/lefigaro/laune"
    "http://www.lefigaro.fr/rss/figaro_flash-actu.xml"
    "http://feeds.lefigaro.fr/c/32266/f/438191/index.rss"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=664"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=665"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=668"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=669"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=809"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=672"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=675"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=678"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=679"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=680"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=685"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=689"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=690"
    "http://news.opensuse.org/feed/"
    "http://zonker.opensuse.org/feed/"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=811"
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=813"                                                                                                                                                                              
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=831"                                                                                                                                                                              
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=821"                                                                                                                                                                              
    "http://forums.opensuse.org/external.php?type=RSS2&forumids=827"                                                                                                                                                                              
    "http://www.alionet.org/external.php?do=rss&type=newcontent&sectionid=1&days=120&count=10"                                                                                                                                                    
    "http://www.alionet.org/external.php?type=RSS2&forumids=46"                                                                                                                                                                                   
    "http://www.alionet.org/external.php?type=RSS2&forumids=21"                                                                                                                                                                                   
    "http://www.alionet.org/external.php?type=RSS2&forumids=16"                                                                                                                                                                                   
    "http://www.alionet.org/external.php?type=RSS2&forumids=47"                                                                                                                                                                                   
    "http://www.alionet.org/external.php?type=RSS2&forumids=17"                                                                                                                                                                                   
    "http://www.alionet.org/external.php?type=RSS2&forumids=19"                                                                                                                                                                                   
    "http://www.alionet.org/external.php?type=RSS2&forumids=45"                                                                                                                                                                                   
    "http://www.alionet.org/external.php?type=RSS2&forumids=22"                                                                                                                                                                                   
    "http://www.alionet.org/external.php?type=RSS2&forumids=12"                                                                                                                                                                                   
    "http://www.auto-hybride.com/feed/"                                                                                                                                                                                                           
    "http://www.voiture-electrique-populaire.fr/feed"                                                                                                                                                                                             
    "http://www.hybridcar.com/index.php?option=com_rss&feed=RSS2.0&no_html=1"                                                                                                                                                                     
    "http://www.hybridcars.com/feed.xml"                                                                                                                                                                                                          
    "http://www.cartech.fr/rss/"                                                                                                                                                                                                                  
    "http://www.rappelsproduits.fr/rss-rappels-produits.xml"                                                                                                                                                                                      
    KCrash: Application 'akregator' crashing...                                                                                                                                                                                                   
    KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit                                                                                                                                                                           
    sock_file=/run/user/501/kdeinit5__0                                                                                                                                                                                                           
                                                                                                                                                                                                                                                  
    [1]+  Stoppé                 akregator

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,058
    Blog Entries
    3

    Default Re: suddenly akregator crashes

    Quote Originally Posted by Christophe_deR View Post
    Now, i've been using akregator for ages, and it suddenly crashes without any explanations except the little lady bug that tells me to report a bug.
    Anyone has the same behavior ?
    If I remember correctly, then 42.2 came with two versions of "akregator".

    If you upgraded from 42.1, you got the "akregator" from KDE4.

    If you did a clean install of 42.2, you got the "akregator" from Plasma 5. I think the package name was "akregator5" for that one.

    If you have the "akregator" from KDE4, then I'm not surprised that it crashes. It has not had much recent support. But you can try firing up "konqueror" and switching it between using "KHTML" and "WebKit". Switching "konqueror" has a side effect of switching the older version of "akregator". And then start or restart "akregator" to see if that helped.

    I've been using the "akregator" from Plasma 5, and it has been pretty reliable. I think it may have crashed once.
    openSUSE Leap 15.1; KDE Plasma 5;

  5. #5
    Join Date
    Jun 2008
    Location
    Europe
    Posts
    405

    Default Re: suddenly akregator crashes

    it's a clean install
    i have akregator5
    it's been working flawlessly for more than 6 months
    And suddenly, it crashes without any reasons.

  6. #6
    Join Date
    Jun 2008
    Location
    Europe
    Posts
    405

    Default Re: suddenly akregator crashes

    i've the khtml/webkit trick in konqueror but it did not work

  7. #7
    Join Date
    Jun 2008
    Location
    Europe
    Posts
    405

    Default Re: suddenly akregator crashes

    May i mention that some of my .mk4 files ( in /.local/share/akregator/Archive/ directory ) are very heavy ?
    Many MB for most of them .
    90.1 MB for the heaviest .
    Is this something that akregator cannot handle ?

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,058
    Blog Entries
    3

    Default Re: suddenly akregator crashes

    Quote Originally Posted by Christophe_deR View Post
    i've the khtml/webkit trick in konqueror but it did not work
    That only works with the older "akregator" from KDE4.

    May i mention that some of my .mk4 files ( in /.local/share/akregator/Archive/ directory ) are very heavy ?
    Many MB for most of them .
    90.1 MB for the heaviest .
    The biggest that I am seeing, is 29M.
    openSUSE Leap 15.1; KDE Plasma 5;

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,358

    Exclamation Re: suddenly akregator crashes

    Quote Originally Posted by Christophe_deR View Post
    it suddenly crashes without any explanations except the little lady bug that tells me to report a bug.
    You'll need to create a KDE Bug Report account at <https://bugs.kde.org/> and, probably install some Plasma5 debug packages (DrKonqui will do this semi-automatically for you during the process of submitting the Bug Report -- there's a button labelled something like "load additional debug packages).
    It would be really great if, you do that.

    As a "quick and dirty" solution, you could try moving the contents of ~/.local/share/akregator/ to a temporary "home" directory and then restarting Akregator.

    If that works OK, then move a few of the '.mk4' files back to ~/.local/share/akregator/ and see if Akregator crashes again.
    Repeat until the "culprit" is found.

  10. #10
    Join Date
    Jun 2008
    Location
    Europe
    Posts
    405

    Default Re: suddenly akregator crashes

    Thank you everyone for your iput.
    I took away every mk4 file from .local/share/akregator/Archive/ directory and took them back one by one until i found the guilty file.
    I decided to give up this file although i lost many years of articles selection.
    I am sad and i think it is a bug in the mk4 format or its treatment by akregator.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •