Results 1 to 10 of 10

Thread: Not able to mount samba shares?

  1. #1

    Default Not able to mount samba shares?

    Hi,

    I have a samba disc share on my modem. I can mount this share from 42.2 & 42.3 but NOT Tumbleweed?
    Code:
    ~# mount -t cifs //192.168.0.1/sda1 /smb
    Password for root@//192.168.0.1/sda1:
    ~#
    Works for 42.2 & 42.3.
    However, this is what I get in Tumbleweed:
    Code:
    ~# mount -t cifs //192.168.0.1/sda1 /smb
    Password for root@//192.168.0.1/sda1:  
    mount error(112): Host is down
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    ~ #
    Any suggestion? Insistently, the 42.x workstations are VMs on the Tumbleweed host.

    Regards, Martin
    openSUSE Leap 15.3, KDE Plasma Version: 5.18.6

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,339
    Blog Entries
    15

    Default Re: Not able to mount samba shares?

    Hi
    I would try connecting via smbclient and add some debug. I'm guessing samba/ssl changes perhaps?

    Code:
    smbclient -d3 -L //192.168.0.1/
    smbclient -d3 //192.168.0.1/<share listed from above>
    Repeat on a working system and compare... on the Leap systems have you added any tweaks in /etc/samba/smb.conf?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Not able to mount samba shares?

    Thanks for the suggestions, Malcolm. Results follow?

    First, SuSE Leap 42.2 (mount -t cifs <etc> will work)
    Code:
    linux-qhyi:~ # smbclient -d3 -L //192.168.0.1/
    lp_load_ex: refreshing parameters
    Initialising global parameters
    rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
    Processing section "[global]"
    Can't find include file /etc/samba/dhcp.conf
    added interface eth0 ip=192.168.0.107 bcast=192.168.0.255 netmask=255.255.255.0
    Client started (version 4.4.2-7.2-3709-SUSE-SLE_12-x86_64).
    Enter root's password: 
    Connecting to 192.168.0.1 at port 445
    Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.33]
    
            Sharename       Type      Comment
            ---------       ----      -------
    GENSEC backend 'gssapi_spnego' registered
    GENSEC backend 'gssapi_krb5' registered
    GENSEC backend 'gssapi_krb5_sasl' registered
    GENSEC backend 'spnego' registered
    GENSEC backend 'schannel' registered
    GENSEC backend 'naclrpc_as_system' registered
    GENSEC backend 'sasl-EXTERNAL' registered
    GENSEC backend 'ntlmssp' registered
    GENSEC backend 'ntlmssp_resume_ccache' registered
    GENSEC backend 'http_basic' registered
    GENSEC backend 'http_ntlm' registered
            sda1            Disk      Disk Name's sda1
            IPC$            IPC       IPC Service (NFS)
    Connecting to 192.168.0.1 at port 139
    Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.33]
    
            Server               Comment
            ---------            -------
            NFS                  NFS
    
            Workgroup            Master
            ---------            -------
            WORKGROUP            NFS
    linux-qhyi:~ #
    Now, Tumbleweed:
    Code:
    gzunder:~ # smbclient -d3 -L //192.168.0.1/ 
    lp_load_ex: refreshing parameters
    Initialising global parameters
    rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
    Processing section "[global]"
    Can't find include file /etc/samba/dhcp.conf
    added interface enp3s0 ip=192.168.0.235 bcast=192.168.0.255 netmask=255.255.255.0
    Client started (version 4.6.7-git.49.562d44faa9dSUSE-oS13.3-x86_64).
    Connecting to 192.168.0.1 at port 445
    Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.33]
    Enter WORKGROUP\root's password: 
    
            Sharename       Type      Comment
            ---------       ----      -------
    GENSEC backend 'gssapi_spnego' registered
    GENSEC backend 'gssapi_krb5' registered
    GENSEC backend 'gssapi_krb5_sasl' registered
    GENSEC backend 'spnego' registered
    GENSEC backend 'schannel' registered
    GENSEC backend 'naclrpc_as_system' registered
    GENSEC backend 'sasl-EXTERNAL' registered
    GENSEC backend 'ntlmssp' registered
    GENSEC backend 'ntlmssp_resume_ccache' registered
    GENSEC backend 'http_basic' registered
    GENSEC backend 'http_ntlm' registered
            sda1            Disk      Disk Name's sda1
            IPC$            IPC       IPC Service (NFS)
    Connecting to 192.168.0.1 at port 139
    Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.33]
    
            Server               Comment
            ---------            -------
            NFS                  NFS
    
            Workgroup            Master
            ---------            -------
            WORKGROUP            NFS
    gzunder:~ #
    Conclusions: Identical results (I think?)

    Now try a connection.
    As I understand it, the smbclient provides an FTP type context rather than a drive mapping service(?)

    SuSE Leap 42.2:
    Code:
    linux-qhyi:~ # smbclient -d3 //192.168.0.1/sda1                                         
    lp_load_ex: refreshing parameters                                                       
    Initialising global parameters                                                          
    rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
    Processing section "[global]"
    Can't find include file /etc/samba/dhcp.conf
    added interface eth0 ip=192.168.0.107 bcast=192.168.0.255 netmask=255.255.255.0
    Client started (version 4.4.2-7.2-3709-SUSE-SLE_12-x86_64).
    Enter root's password: 
    Connecting to 192.168.0.1 at port 445
    Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.33]
    smb: \> ls
      .                                   D        0  Tue Oct 17 09:00:26 2017
      ..                                  D        0  Sat Oct 14 15:23:40 2017
      TV Shows                            D        0  Tue Sep 26 18:32:44 2017
      myMusic                             D        0  Thu Oct  5 08:16:32 2017
      ourVideos                           D        0  Wed Oct 11 20:21:08 2017
    
                    117190688 blocks of size 1024. 71850944 blocks available
    Total bytes listed: 0
    smb: \> exit
    linux-qhyi:~ #
    Tumbleweed:
    Code:
    gzunder:~ # smbclient -d3 //192.168.0.1/sda1
    lp_load_ex: refreshing parameters
    Initialising global parameters
    rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
    Processing section "[global]"
    Can't find include file /etc/samba/dhcp.conf
    added interface enp3s0 ip=192.168.0.235 bcast=192.168.0.255 netmask=255.255.255.0
    Client started (version 4.6.7-git.49.562d44faa9dSUSE-oS13.3-x86_64).
    Connecting to 192.168.0.1 at port 445
    Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.33]
    Enter WORKGROUP\root's password: 
    smb: \> ls
      .                                   D        0  Tue Oct 17 09:00:26 2017
      ..                                  D        0  Sat Oct 14 15:23:40 2017
      TV Shows                            D        0  Tue Sep 26 18:32:44 2017
      myMusic                             D        0  Thu Oct  5 08:16:32 2017
      ourVideos                           D        0  Wed Oct 11 20:21:08 2017
    
                    117190688 blocks of size 1024. 71850944 blocks available
    Total bytes listed: 0
    smb: \> exit
    gzunder:~ #
    Once again, using smbclient, I get similar results on Leap & Tumbleweed.

    Does this offer any insights for you Malcolm, as to why mount -t cifs is not playing-ball on Tumbleweed?
    One more small bit of evidence - Dolphin can see and map the smb share fine. But in the light of the above, I don't think that this is all that surprising.

    Regards, Martin
    openSUSE Leap 15.3, KDE Plasma Version: 5.18.6

  4. #4
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,188

    Default Re: Not able to mount samba shares?

    Quote Originally Posted by martinprowe View Post
    Does this offer any insights for you Malcolm, as to why mount -t cifs is not playing-ball on Tumbleweed?
    Code:
    mount -t cifs -o vers=2.1 /blah /blah
    Try dropping to 2.0 or 1.0 if it fails.
    .: miuku @ #opensuse @ irc.libera.chat

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,706
    Blog Entries
    1

    Default Re: Not able to mount samba shares?

    Yes, as Miuku mentioned try specifying the samba protocol explicitly.

    From 'man mount.cifs'...
    Code:
    vers=
    SMB protocol version. Allowed values are: 
    
    • 1.0 - The classic CIFS/SMBv1 protocol. This is the default.
    
    
    • 2.0 - The SMBv2.002 protocol. This was initially introduced in Windows Vista Service Pack 1, and Windows Server 2008. Note that the initial release version of Windows Vista spoke a slightly different dialect (2.000) that is not supported.
    
    
    • 2.1 - The SMBv2.1 protocol that was introduced in Microsoft Windows 7 and Windows Server 2008R2.
    
    
    • 3.0 - The SMBv3.0 protocol that was introduced in Microsoft Windows 8 and Windows Server 2012.
    
    
    Note too that while this option governs the protocol version used, not all features of each version are available.

  6. #6

    Default Re: Not able to mount samba shares?

    WooHooo......

    Thank you all VERY much. Yes, Vers=1.0 did the trick.

    Ironically, I had tried that line already. I tried 3.0, 2.1 etc, BUT as 1.0 was the default I did not explicitly state it. Silly me!
    So, In LEAP 42.x you can leave it off but in Tumbleweed I needed this in my /etc/fstab

    //192.168.0.1/sda1 /smb cifs username=guest,password="",vers=1.0

    Once again you have all come to my rescue.

    Regards, Martin
    openSUSE Leap 15.3, KDE Plasma Version: 5.18.6

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,706
    Blog Entries
    1

    Default Re: Not able to mount samba shares?

    Quote Originally Posted by martinprowe View Post
    WooHooo......

    Thank you all VERY much. Yes, Vers=1.0 did the trick.
    Good to read of your success with this!

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,706
    Blog Entries
    1

    Default Re: Not able to mount samba shares?

    Quote Originally Posted by martinprowe View Post
    ...BUT as 1.0 was the default I did not explicitly state it. Silly me!
    So, In LEAP 42.x you can leave it off but in Tumbleweed I needed this in my /etc/fstab
    Yes, it's no longer the default since a few months back and now disabled (unless specified specifically). I assume this is now reflected in the mount,cifs man page for the TW version?

  9. #9

    Default Re: Not able to mount samba shares?

    Thank you very much deano_ferrari !!!

    It works for me with :

    //my.local.ip/share /myshare cifs _netdev,guest,vers=1.0 0 0

    Encore merci mon ami

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,706
    Blog Entries
    1

    Default Re: Not able to mount samba shares?

    Nice to read of your success with this!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •