Results 1 to 10 of 10

Thread: Video-Problem: H.264 und MSE & H.264: Chrome kann, Firefox nicht

  1. #1

    Default Video-Problem: H.264 und MSE & H.264: Chrome kann, Firefox nicht

    Hallo und einen sonniges Sonntag allerseits,

    wer weiß, was ich tun sollte um mit Firefox auch viele Videos sehen zu können, die ich mit Chrome ohne Probleme sehen kann? Der Grund ist vermutlich die fehlende Unterstützung von H.264 und MSE & H.264 im Firefox (lt. https://www.youtube.com/html5). Merkwürdigerweise ist das H.264-Plugin im Firefox zu sehen.


    Beste Grüße

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,672
    Blog Entries
    15

    Default Re: Video-Problem: H.264 und MSE & H.264: Chrome kann, Firefox nicht

    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default AW: Video-Problem: H.264 und MSE & H.264: Chrome kann, Firefox nicht

    Code:
    sudo zypper install libdvdcss2 ffmpeg lame gstreamer-plugins-libav gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon vlc vlc-codecs flash-player flash-player-ppapi libxine2 libxine2-codecs
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    'flash-player-ppapi' ist bereits installiert.
    Es gibt einen Aktualisierungskandidaten für 'flash-player-ppapi', aber er ist von einem anderen Anbieter. Verwenden Sie 'zypper install flash-player-ppapi-27.0.0.170-release.x86_64' um diesen Kandidaten zu installieren.
    'gstreamer-plugins-bad' ist bereits installiert.
    Es gibt einen Aktualisierungskandidaten für 'gstreamer-plugins-bad', aber er ist von einem anderen Anbieter. Verwenden Sie 'zypper install gstreamer-plugins-bad-1.8.3-8.6.x86_64' um diesen Kandidaten zu installieren.
    'gstreamer-plugins-ugly' ist bereits installiert.
    Kein Aktualisierungskandidat für 'gstreamer-plugins-ugly-1.8.3-10.1.x86_64'. Die neueste Version ist bereits installiert.
    Paketabhängigkeiten werden aufgelöst...
    2 Probleme:
    Problem: freshplayerplugin-0.3.6-4.1.x86_64 steht in Konflikt mit flash-player, das von flash-player-27.0.0.130-1.1.x86_64 zur Verfügung gestellt wurde
    Problem: ffmpeg-3.3.4-9.1.x86_64 benötigt libavcodec57 = 3.3.4-9.1, kann jedoch nicht zur Verfügung gestellt werden
    
    Problem: freshplayerplugin-0.3.6-4.1.x86_64 steht in Konflikt mit flash-player, das von flash-player-27.0.0.130-1.1.x86_64 zur Verfügung gestellt wurde
     Lösung 1: Deinstallation von freshplayerplugin-0.3.6-4.1.x86_64
     Lösung 2: flash-player-27.0.0.130-1.1.x86_64 nicht installieren
    
    Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder brechen (a)b [1/2/u/w/a] (a):
    Was empfiehlst du?

    PS:
    Du musst erst einige Beiträge anderer Benutzer bewertet haben, bevor du malcolmlewis erneut bewerten kannst.
    Iss klar. Das lese ich immer, falls das jemand versteht. Und was heißt überhaupt "erneut"?

  4. #4

    Default AW: Video-Problem: H.264 und MSE & H.264: Chrome kann, Firefox nicht

    So, ich kann nun alles mit Firefox sehen, was ich auch mit Chrome sehen kann, und bei https://www.youtube.com/html5 wird nun auch alles als unterstützt angezeigt.

    Die Vorgehensweise, basierend auf dem Link (https://forums.opensuse.org/entry.ph...ltimedia-Guide) von malcomlewis (die Seite ist übrigens nur erreichbar, wenn man angemeldet ist):

    Ich habe libdvdcss via YaST eingebunden - packman war schon eingebunden - und dann in der Konsole das Kommando
    Code:
    zypper install libdvdcss2 ffmpeg lame gstreamer-plugins-libav gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon vlc vlc-codecs flash-player flash-player-ppapi libxine2 libxine2-codecs
    ausgeführt.
    Bei der ersten Auswahl (s. vorherige Antwwort) habe ich Option 2 gewählt und bei der zweiten Auswahl die erste Option (lib irgendwas mit 57 ... opensuse>packman) von ca. 10 weiteren Optionen.

    Keine Ahnung, was mit
    When done. Close the terminal. And open Yast > Software Management and Apply the Package Switcher on Packman Repo

    KDE: http://paste.opensuse.org/92222495

    Gnome: http://paste.opensuse.org/71856337

    If you encounter dependency errors: You need to accept changes that allow vendor switch to Packman If you can't work it out. Ask in the forum.
    gemeint war. Ich habe es nicht gemacht, aber es läuft soweit alles.

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,952

    Default AW: Video-Problem: H.264 und MSE & H.264: Chrome kann, Firefox nicht

    Keine Ahnung, was mit
    When done. Close the terminal. And open Yast > Software Management and Apply the Package Switcher on Packman Repo

    KDE: http://paste.opensuse.org/92222495

    Gnome: http://paste.opensuse.org/71856337

    If you encounter dependency errors: You need to accept changes that allow vendor switch to Packman If you can't work it out. Ask in the forum.
    gemeint war. Ich habe es nicht gemacht, aber es läuft soweit alles.
    Alle installierten Pakete auf Packman umstellen, falls in Packman vorhanden.
    Funktioniert per Yast-----Software installieren (siehe die beiden Bilder) oder per Konsole als root:
    Code:
    zypper dup --from Packman
    Wobei Packman ersetzt werden muss mit dem Namen, der URL oder der Nummer des Packman Repos, dabei hilft die Ausgabe von
    Code:
    zypper lr -d

  6. #6

    Default AW: Video-Problem: H.264 und MSE & H.264: Chrome kann, Firefox nicht

    Danke für die Erklärung.

    Ich bin gerade in YaST und sehe, dass Packman zweimal bei mir im System ist:
    Code:
    http://packman.inode.at/suse/openSUSE_Leap_42.3/ 
    http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/openSUSE_Leap_42.3
    Kann ich eine Version löschen?

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,003

    Default Re: Video-Problem: H.264 und MSE & H.264: Chrome kann, Firefox nicht

    Da du nicht wirklich zeigst was mit diese repos los ist
    Code:
    zypper lr -d
    können wir nur so raten. Normalerweise reicht einer natürlich.
    Es könnte aber sein das du ganz vorsichtich bist und ein zweiter (aber dann natürlich abgeschaltet) dabei hast um, wenn einer ausfallt, schnell umsteigen zu können.
    Henk van Velden

  8. #8

    Default AW: Video-Problem: H.264 und MSE & H.264: Chrome kann, Firefox nicht

    Hilft das?
    Code:
     sudo zypper lr -d                                                                                                                                                                                              
    Die Repository-Prioritäten sind ohne Effekt. Alle aktivierten Repositorys teilen sich die gleiche Priorität.                                                                                                                  
                                                                                                                                                                                                                                  
    #  | Alias                             | Name                                    | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ    | URI                                                                      | Dienst
    ---+-----------------------------------+-----------------------------------------+-----------+-----------------+----------------+-----------+--------+--------------------------------------------------------------------------+-------
     1 | adobe                             | adobe                                   | Ja        | ( p) Ja         | Ja             |   99      | rpm-md | http://linuxdownload.adobe.com/linux/x86_64/                             |       
     2 | google-chrome                     | google-chrome                           | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                      |       
     3 | http-ftp.uni-erlangen.de-96477d06 | Packman Repository                      | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/openSUSE_Leap_42.3   |       
     4 | openSUSE-Leap-42.3-0              | openSUSE-Leap-42.3-0                    | Ja        | (r ) Ja         | Ja             |   99      | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/            |       
     5 | opensuse-guide.org-repo           | Libdvdcss Repository                    | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.3/                       |       
     6 | packman.inode.at-suse             | Packman Repository                      | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.3/                         |       
     7 | repo-debug                        | openSUSE-Leap-42.3-Debug                | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/oss/      |       
     8 | repo-debug-non-oss                | openSUSE-Leap-42.3-Debug-Non-Oss        | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/non-oss/  |       
     9 | repo-debug-update                 | openSUSE-Leap-42.3-Update-Debug         | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/update/leap/42.3/oss/                 |       
    10 | repo-debug-update-non-oss         | openSUSE-Leap-42.3-Update-Debug-Non-Oss | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/update/leap/42.3/non-oss/             |       
    11 | repo-non-oss                      | openSUSE-Leap-42.3-Non-Oss              | Ja        | (r ) Ja         | Ja             |   99      | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/        |       
    12 | repo-source                       | openSUSE-Leap-42.3-Source               | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/     |       
    13 | repo-source-non-oss               | openSUSE-Leap-42.3-Source-Non-Oss       | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/non-oss/ |       
    14 | repo-update                       | openSUSE-Leap-42.3-Update               | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/leap/42.3/oss/                       |       
    15 | repo-update-non-oss               | openSUSE-Leap-42.3-Update-Non-Oss       | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/leap/42.3/non-oss/                   |

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,952

    Default AW: Video-Problem: H.264 und MSE & H.264: Chrome kann, Firefox nicht

    Du kannst ein Packman Repo löschen und solltest die Priorität des verbleibenden Packman Repos auf 20 stellen. Welcher ist in dem Falle egal.


    Zum Thema Priorität
    Kleinere Zahl = höhere Priorität
    Dann wird dies Repo bei Installationen eines Paketes bevorzugt, falls das Paket noch in einem anderen Repo vorhanden ist.

  10. #10

    Default AW: Video-Problem: H.264 und MSE & H.264: Chrome kann, Firefox nicht

    * * *

    (10 Zeichen)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •