Results 1 to 3 of 3

Thread: Unable to install plugins per instructions in the TW Multimedia Guide

  1. #1

    Default Unable to install plugins per instructions in the TW Multimedia Guide

    I was able to add the repos with no problem when following the guide here: https://forums.opensuse.org/showthre...USE-Tumbleweed

    However, when I tried to install the plugins for KDE, zypper reported it was unable to find a lot of them.

    Code:
    linux-q5o0:~ # zypper install libxine2-codecs ffmpeg lame gstreamer-0_10-plugins-good gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-ugly gstreamer-0_10-plugins-bad-orig-addon gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly-orig-addon gstreamer-0_10-plugins-ffmpeg libdvdcss2 dvdauthor07 gstreamer-plugins-base gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-good gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon gstreamer-plugins-good-extra gstreamer-0_10-plugins-fluendo_mpegdemux gstreamer-0_10-plugins-fluendo_mpegmux k3b-codecs vlc-beta h264enc x264 gstreamer-plugins-libav vlc-beta-codecs
    Loading repository data...
    Reading installed packages...
    Package 'k3b-codecs' not found.
    'gstreamer-plugins-bad' is already installed.
    There is an update candidate for 'gstreamer-plugins-bad', but it is from a different vendor. Use 'zypper install gstreamer-plugins-bad-1.12.3-5.14.x86_64' to install this candidate.
    'gstreamer-plugins-ugly' is already installed.
    There is an update candidate for 'gstreamer-plugins-ugly', but it is from a different vendor. Use 'zypper install gstreamer-plugins-ugly-1.12.3-4.6.x86_64' to install this candidate.
    'lame' is already installed.
    No update candidate for 'lame-3.99.5-1.1.x86_64'. The highest available version is already installed.
    'gstreamer-plugins-base' is already installed.
    No update candidate for 'gstreamer-plugins-base-1.12.3-1.1.x86_64'. The highest available version is already installed.
    'vlc-beta-codecs' not found in package names. Trying capabilities.
    'gstreamer-plugins-good' is already installed.
    No update candidate for 'gstreamer-plugins-good-1.12.3-1.1.x86_64'. The highest available version is already installed.
    'dvdauthor07' not found in package names. Trying capabilities.
    'gstreamer-0_10-plugins-bad' not found in package names. Trying capabilities.
    No provider of 'gstreamer-0_10-plugins-bad' found.
    'gstreamer-0_10-plugins-bad-orig-addon' not found in package names. Trying capabilities.
    No provider of 'gstreamer-0_10-plugins-bad-orig-addon' found.
    'gstreamer-0_10-plugins-ffmpeg' not found in package names. Trying capabilities.
    No provider of 'gstreamer-0_10-plugins-ffmpeg' found.
    'gstreamer-0_10-plugins-fluendo_mpegdemux' not found in package names. Trying capabilities.
    No provider of 'gstreamer-0_10-plugins-fluendo_mpegdemux' found.
    'gstreamer-0_10-plugins-fluendo_mpegmux' not found in package names. Trying capabilities.
    No provider of 'gstreamer-0_10-plugins-fluendo_mpegmux' found.
    'gstreamer-0_10-plugins-good' not found in package names. Trying capabilities.
    No provider of 'gstreamer-0_10-plugins-good' found.
    'gstreamer-0_10-plugins-good-extra' not found in package names. Trying capabilities.
    No provider of 'gstreamer-0_10-plugins-good-extra' found.
    'gstreamer-0_10-plugins-ugly' not found in package names. Trying capabilities.
    No provider of 'gstreamer-0_10-plugins-ugly' found.
    'gstreamer-0_10-plugins-ugly-orig-addon' not found in package names. Trying capabilities.
    No provider of 'gstreamer-0_10-plugins-ugly-orig-addon' found.
    Resolving package dependencies...
    
    Problem: ffmpeg-3.3.4-3.6.x86_64 requires libavcodec57 = 3.3.4-3.6, but this requirement cannot be provided
      uninstallable providers: libavcodec57-3.3.4-3.6.i586[packman]
                       libavcodec57-3.3.4-3.6.x86_64[packman]
     Solution 1: install libavcodec57-3.3.4-3.6.x86_64 (with vendor change)
      openSUSE  -->  http://packman.links2linux.de
     Solution 2: do not install ffmpeg-3.3.4-3.6.x86_64
     Solution 3: break ffmpeg-3.3.4-3.6.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/c] (c): c 
    linux-q5o0:~ #
    Is it that the versions of the plugins I am trying to install are old and no longer available? I just need the new version names?
    Tumbleweed on a Dell Inspiron 15 - 5578

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,695
    Blog Entries
    1

    Default Re: Unable to install plugins per instructions in the TW Multimedia Guide

    Quote Originally Posted by Silverclipper View Post
    I was able to add the repos with no problem when following the guide here: https://forums.opensuse.org/showthre...USE-Tumbleweed

    However, when I tried to install the plugins for KDE, zypper reported it was unable to find a lot of them.
    That's because some no longer exist. Anyway, try this (as per the Leap 42.3 guide)....

    Code:
    zypper install libdvdcss2 ffmpeg lame gstreamer-plugins-libav gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon vlc vlc-codecs flash-player flash-player-ppapi libxine2 libxine2-codecs

  3. #3

    Default Re: Unable to install plugins per instructions in the TW Multimedia Guide

    Quote Originally Posted by deano_ferrari View Post
    That's because some no longer exist. Anyway, try this (as per the Leap 42.3 guide)....

    Code:
    zypper install libdvdcss2 ffmpeg lame gstreamer-plugins-libav gstreamer-plugins-bad gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon vlc vlc-codecs flash-player flash-player-ppapi libxine2 libxine2-codecs
    Thanks very much. It worked perfectly this time with your revised instructions.
    Tumbleweed on a Dell Inspiron 15 - 5578

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •