Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Keyb/Vid/Mouse unavailable after hiber/suspend resume

  1. #1
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    36

    Default Keyb/Vid/Mouse unavailable after hiber/suspend resume

    Since upgrading (zypper dup) from 42.2 to 42.3 I am unable to resume properly from either suspend or hibernation. I return to a black screen with mouse cursor only. Keyboard is unresponsive, as is mouse. The only recourse I have found is reboot via front panel reset button of desktop.

    Graphics card info:

    fuscop@office:~> /usr/sbin/hwinfo --gfxcard
    08: PCI 02.0: 0300 VGA compatible controller (VGA)
    [Created at pci.378]
    Unique ID: _Znp.fOXSkkk0ZeF
    SysFS ID: /devices/pci0000:00/0000:00:02.0
    SysFS BusID: 0000:00:02.0
    Hardware Class: graphics card
    Device Name: "Onboard IGD"
    Model: "Intel 4th Generation Core Processor Family Integrated Graphics Controller"
    Vendor: pci 0x8086 "Intel Corporation"
    Device: pci 0x041e "4th Generation Core Processor Family Integrated Graphics Controller"
    SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
    SubDevice: pci 0x8534
    Revision: 0x06
    Driver: "i915"
    Driver Modules: "i915"
    Memory Range: 0xf7800000-0xf7bfffff (rw,non-prefetchable)
    Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
    I/O Ports: 0xf000-0xf03f (rw)
    IRQ: 31 (4164 events)
    I/O Ports: 0x3c0-0x3df (rw)
    Module Alias: "pci:v00008086d0000041Esv00001043sd00008534bc03sc00i00"
    Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
    Config Status: cfg=no, avail=yes, need=no, active=unknown


    Not sure if following is relevant, from SystemD Journal via YaST:

    Starting Load/Save Screen Backlight Brightness of backlight:acpi_video0...
    Failed to get backlight or LED device 'backlight:acpi_video0': No such device
    systemd-backlight@backlight:acpi_video0.service: Main process exited, code=exited, status=1/FAILURE
    Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0.
    systemd-backlight@backlight:acpi_video0.service: Unit entered failed state.
    systemd-backlight@backlight:acpi_video0.service: Failed with result 'exit-code'.
    [system] Activating service name='org.kde.powerdevil.backlighthelper' (using servicehelper)
    powerdevil: no kernel backlight interface found
    QDBusArgument: read from a write-only object
    QDBusArgument: read from a write-only object
    QDBusArgument: read from a write-only object
    [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,883
    Blog Entries
    1

    Default Re: Keyb/Vid/Mouse unavailable after hiber/suspend resume

    Laptop model? Lets check current boot parameters
    Code:
    cat /proc/cmdline
    Also report back with output from the following
    Code:
    ls -l /sys/class/backlight/

  3. #3
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    36

    Default Re: Keyb/Vid/Mouse unavailable after hiber/suspend resume

    Quote Originally Posted by deano_ferrari View Post
    Laptop model? Lets check current boot parameters
    Code:
    cat /proc/cmdline
    Also report back with output from the following
    Code:
    ls -l /sys/class/backlight/
    It's not a laptop, but a desktop build (no specific manufacturer). It has been upgraded several times since initial build, which was 13.1 version (/var/log/zypp/history).

    fuscop@office:~> cat /proc/cmdline
    BOOT_IMAGE=/boot/vmlinuz-4.4.87-25-default root=UUID=7fa1ebf7-c005-437c-bdb5-2404ea8ddf05 resume=/dev/disk/by-id/ata-Hitachi_HDS721050CLA362_JP1521HN06KX3A-part1 nosplash verbose showopts

    fuscop@office:~> ls -l /sys/class/backlight
    total 0

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,883
    Blog Entries
    1

    Default Re: Keyb/Vid/Mouse unavailable after hiber/suspend resume

    Quote Originally Posted by fuscop View Post
    It's not a laptop, but a desktop build (no specific manufacturer). It has been upgraded several times since initial build, which was 13.1 version (/var/log/zypp/history).
    Ok.

    Code:
    fuscop@office:~> ls -l /sys/class/backlight
    total 0
    No backlight interfaces evident. This boot parameter might be worth a shot.
    Code:
    acpi_backlight=vendor
    Let us know if you need help with grub2 boot configuration.

    Perhaps also take a look at
    Code:
    sudo dmidecode

  5. #5
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    36

    Default Re: Keyb/Vid/Mouse unavailable after hiber/suspend resume

    Quote Originally Posted by deano_ferrari View Post
    Ok.

    Code:
    fuscop@office:~> ls -l /sys/class/backlight
    total 0
    No backlight interfaces evident. This boot parameter might be worth a shot.
    Code:
    acpi_backlight=vendor
    Let us know if you need help with grub2 boot configuration.

    I inserted that information into grub2 boot configuration, no change on suspend issue. It does seem to have cleared up the errors in the SystemD Journal though.

    fuscop@office:~> cat /proc/cmdline
    BOOT_IMAGE=/boot/vmlinuz-4.4.87-25-default root=UUID=7fa1ebf7-c005-437c-bdb5-2404ea8ddf05 resume=/dev/disk/by-id/ata-Hitachi_HDS721050CLA362_JP1521HN06KX3A-part1 acpi_backlight=vendor nosplash verbose showopts

    Perhaps also take a look at
    Code:
    sudo dmidecode
    Output was too many characters to include in reply. Was there something in particular you wanted to see?

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,883
    Blog Entries
    1

    Default Re: Keyb/Vid/Mouse unavailable after hiber/suspend resume

    Quote Originally Posted by fuscop View Post
    Output was too many characters to include in reply.
    When dealing with lengthy output, it is generally suggested to upload it to https://paste.opensuse.org/ and post the URL it provides here.

    Was there something in particular you wanted to see?
    ACPI BIOS info really. But in general, sometimes it provides clues to others who may be able to help.

  7. #7
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    36

    Default Re: Keyb/Vid/Mouse unavailable after hiber/suspend resume

    Quote Originally Posted by deano_ferrari View Post
    When dealing with lengthy output, it is generally suggested to upload it to https://paste.opensuse.org/ and post the URL it provides here.


    ACPI BIOS info really. But in general, sometimes it provides clues to others who may be able to help.

    URL: https://paste.opensuse.org/37064028

    Thanks very much for all your help with this. I'm going to sign off for the night and will check back tomorrow. Take whatever time you (and anyone else) need, this isn't a major obstacle to my use of the system.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    19,883
    Blog Entries
    1

    Default Re: Keyb/Vid/Mouse unavailable after hiber/suspend resume

    I don't have a definitive answer here, but since you report that the same hardware is working with Leap 42.2 it could well be due to a kernel regression. Now you could try installing a stable kernel via the stable kernel repo, but you might be wise just to test a live distro (using a later kernel) first perhaps eg http://geckolinux.github.io/#download-rolling
    Last edited by deano_ferrari; 14-Oct-2017 at 00:02.

  9. #9

    Default Re: Keyb/Vid/Mouse unavailable after hiber/suspend resume

    I can confirm the issue with the same circumstances.
    Same zypper dup upgrade from 42.2 -> 42.3. Acer Aspire V3-572/V3-532 series. Stock repositories, KDE, no Nvidia blobs.

  10. #10
    Join Date
    Oct 2008
    Location
    Texas
    Posts
    36

    Default Re: Keyb/Vid/Mouse unavailable after hiber/suspend resume

    Quote Originally Posted by deano_ferrari View Post
    I don't have a definitive answer here, but since you report that the same hardware is working with Leap 42.2 it could well be due to a kernel regression. Now you could try installing a stable kernel via the stable kernel repo, but you might be wise just to test a live distro (using a later kernel) first perhaps eg http://geckolinux.github.io/#download-rolling
    I upgraded tonight to kernel 4.4.90-28-default but experienced the same issue when resuming from suspend. I then rebooted and chose Advanced Options at the grub boot GUI. I tried the available kernels previous to 4.4.87-25-default which is the kernel version I opened this issue for.

    4.4.79-18.29-default worked fine.
    4.4.79-18.26-default worked fine.
    4.4.79-18.23-default worked fine.

    Since 4.4.79-18.29 is the latest to work okay I went with it for now. Since this is a home machine that I normally suspend that works fine until a newer kernel that addresses/fixes the issue is released. It does seem you are correct on kernel regression.

    fuscop@office:~> cat /proc/cmdline
    BOOT_IMAGE=/boot/vmlinuz-4.4.87-18.29-default root=UUID=7fa1ebf7-c005-437c-bdb5-2404ea8ddf05 resume=/dev/disk/by-id/ata-Hitachi_HDS721050CLA362_JP1521HN06KX3A-part1 acpi_backlight=vendor nosplash verbose showopts

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •