Results 1 to 5 of 5

Thread: repository .xml files not found

  1. #1

    Default repository .xml files not found

    I'm getting a repomod.xml file not found for the oss/ and non-oss/ repositories. All the other ones seems to be working fine. Is there a current problem with these two repos?

    Code:
    File '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/'

  2. #2
    Join Date
    Sep 2012
    Posts
    5,279

    Default Re: repository .xml files not found

    Works here, could be a specific mirror problem.

  3. #3

    Default Re: repository .xml files not found

    Yep. Looks like just a mirror problem. Thanks.

  4. #4

    Default Re: repository .xml files not found

    Hello,
    i have same error on LEAP 42.3. Can you explain how to change mirror, with zypper parameter ?
    Thanks

  5. #5

    Default Re: repository .xml files not found

    Quote Originally Posted by finkjf View Post
    Hello,
    i have same error on LEAP 42.3. Can you explain how to change mirror, with zypper parameter ?
    Thanks
    Sure. Go to https://mirrors.opensuse.org/ and select a mirror close to you. Click on one of the mirror URLs and navigate to your needed repo.

    In the terminal, list your repos in zypper
    Code:
    zypper lr --uri
    To disable or remove the offending repos:
    Code:
    sudo zypper modifyrepo -d (Alias or repo #)
    or
    sudo zypper rr (Alias or repo #)
    Replace the stuff in parentheses with your info.

    Then add a new repo(s) from the mirror URL you found above. In my case it was:
    Code:
    sudo zypper ar http://mirrors.rit.edu/opensuse/distribution/leap/42.3/repo/oss/ openSUSE-Leap-42.3-Oss
    sudo zypper ar http://mirrors.rit.edu/opensuse/distribution/leap/42.3/repo/non-oss/ openSUSE-Leap-42.3-Non-Oss

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •