Results 1 to 7 of 7

Thread: Plasma workspace broken (no taskbar, plasmashell not responding)

  1. #1
    Join Date
    May 2017
    Posts
    12

    Default Plasma workspace broken (no taskbar, plasmashell not responding)

    Hello,
    on my LEAP 42.3 system, all users cannot start KDE Plasma Desktop properly.

    Symptoms:
    They just get the background image, mouse pointer, can use ALT-F2 to start commands like "konsole"
    or any others. But there is no taskbar, plasmashell does not respond to clicks (not on the little icon,
    no right click on the background).

    Code:
    kquitapp  plasmashell
    does not stop plasmashell. I can kill it and "kstart" it again, but that does not help.

    I've removed .config/plasma-org.kde.plasma.desktop-appletsrc and restarted: no change.
    I've used a fresh user: same problem.

    The system has been upgraded from OpenSuse 13.1 to LEAP 42.3 a while ago, which went fine.
    On 2017-10-08 when the problem started I've got some package updates,
    but they look unrelated (libvirt*, mozilla*, libsoftokn3, git* , yast2-bootloader, yast2-xml).

    The system is fully updated (some more updates today). Here is the used repo list:
    Code:
    zypper lr -Eup
    #  | Alias                           | Name                                                    | Enabled | GPG Check | Refresh | Priority | URI                                                              
    ---+---------------------------------+---------------------------------------------------------+---------+-----------+---------+----------+------------------------------------------------------------------
     1 | download.opensuse.org-non-oss   | Haupt-Repository (NON-OSS)                              | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/
     2 | download.opensuse.org-non-oss_1 | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/leap/42.3/non-oss/           
     3 | download.opensuse.org-oss       | Haupt-Repository (OSS)                                  | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/distribution/leap/42.3/repo/oss/  
     4 | download.opensuse.org-oss_1     | Hauptaktualisierungs-Repository                         | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/leap/42.3/oss            
     5 | dvd                             | dvd                                                     | Yes     | (r ) Yes  | Yes     |   99     | http://opensuse-guide.org/repo/openSUSE_Leap_42.3/               
     7 | packman                         | packman                                                 | Yes     | (r ) Yes  | Yes     |   99     | http://packman.inode.at/suse/openSUSE_Leap_42.3/
    There is nothing obvious in the .xsession-error log. And nothing obvious when kstarting plasmashell.

    The problem started to appear when I was trying to use yast to change my printer settings.
    cups sometimes seems to hang, so I may have ended some processes and restarted.

    Any hints how to further resolve or debug this?

    Thanks in advance,
    Bernhard

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,649
    Blog Entries
    14

    Default Re: Plasma workspace broken (no taskbar, plasmashell not responding)

    If it's no problem for you, you could reset the plasmadesktop to default, by invoking
    Code:
    rm ~/.config/plasma*
    then hit Ctrl+Alt+Backspace twice
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    May 2017
    Posts
    12

    Default Re: Plasma workspace broken (no taskbar, plasmashell not responding)

    Hi Knurpht,
    thanks for the suggestion! I've tried with one user, but it did not help.

    Later I got the right idea: I've straced plasmashell and saw that it was somehow hanging while asking cups.
    Disabling cups made plasmashell start again. I guess there is a defect somewhere, probably a missing timeout
    as a hanging cupsd should not render plasmashell broken.

    To document it, I did something like
    Code:
    # killing plasmashell first, then restarting it with strace
    strace -o trace1 plasmashell
    
    # in a second window
    vim trace1
    
    # scrolled back, found stuff before a number of polls like
    3374  connect(32, {sa_family=AF_LOCAL, sun_path="/run/cups/cups.sock"}, 22) = 0
    [..]
    3374 sendto(32, "POST / HTTP/1.1\r\nContent-Length:"..., 180, 0, NULL, 0) = 180
    
    # as root
    systemctl stop cups
    # plasmashell continued, now permanently disabling cups (printer daemon) until debugging is possible
    systemctl disable cups
    Best Regards and thanks for caring!
    Bernhard
    ps.: If someone wants to follow up on the defect later, relevant versions are plasma5-workspace-5.8.7-6.1.x86_64
    and cups-1.7.5-11.1.x86_64.
    Last edited by ber; 11-Oct-2017 at 13:19. Reason: added package versions

  4. #4

    Default Re: Plasma workspace broken (no taskbar, plasmashell not responding)

    Does uninstalling kde-print-manager help then?
    (or disabling the applet in the system tray settings)

  5. #5

    Default Re: Plasma workspace broken (no taskbar, plasmashell not responding)

    Just an FYI, this problem isn't unique. I've been using alt-tab to change windows and save my work. I have no idea if the print manager is the culprit, but I have removed it and will do a post regarding if that fixes the problem or not.

    I'm on a Dell E6400 ATG with Intel graphics.
    Linux linux-0u81 4.4.92-31-default #1 SMP Sun Oct 22 06:56:24 UTC 2017 (1d80e8a) x86_64 x86_64 x86_64 GNU/Linux

  6. #6

    Default Re: Plasma workspace broken (no taskbar, plasmashell not responding)

    Quote Originally Posted by wolfi323 View Post
    Does uninstalling kde-print-manager help then?
    (or disabling the applet in the system tray settings)
    I've deleted kde-print-manager and have put a few hours on the PC. I believe the problem is solved. I will leave it up to the gurus to determine if this requires a bug report.

    Thanks for the tip.

  7. #7
    Join Date
    May 2017
    Posts
    12

    Default Re: Plasma workspace broken (no taskbar, plasmashell not responding)

    Quote Originally Posted by wolfi323 View Post
    Does uninstalling kde-print-manager help then?
    (or disabling the applet in the system tray settings)
    After reinstalling and reconfiguring cups, cups did not hang anymore
    and I did not run into the issue again. So I did not do further tests.

    Maybe suspending the cupsd process could provoke the problem, but this is just a wild guess.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •