Results 1 to 7 of 7

Thread: Browsers won't start at all after updating/installing...

  1. #1
    Join Date
    Dec 2016
    Location
    Burlington - Canada
    Posts
    16

    Default Browsers won't start at all after updating/installing...

    Hello all,

    I am experiencing something weird. None of my brwosers that are installed on my system open/start after installing Vivaldi. The only thing that I think that I have done is to to Software Update and install Vivaldi.
    Chromium, Firefox and Opera do not open/start at all. Firefox reports a crash report everytime. I did restart my computer, uninstalled Vivaldi, restarted but to the same result.

    How can i find what is causing and fix it?!
    I am using Konqueror to post this.

    Thank you in advance.

    Regards.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Browsers won't start at all after updating/installing...

    Probably the first thing you should do is let us know what your repos are, just in case.
    You can tell us by reporting the result of

    Code:
    zypper lr -d
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Dec 2016
    Location
    Burlington - Canada
    Posts
    16

    Default Re: Browsers won't start at all after updating/installing...

    Sorry I did not know if the repos has an effect on the allready installed applications. The thing is that Opera was running and functional when I installed Vivaldi, but after restart of the computer, Opera did not open/start.

    Code:
    #  | Alias                               | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                            | Service
    ---+-------------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------------------------+--------
     1 | KDE                                 | KDE                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_42.3/                       |         
     2 | download.opensuse.org-non-oss       | Main Repository (NON-OSS)               | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/                              |         
     3 | download.opensuse.org-non-oss_1     | Update Repository (Non-Oss)             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/non-oss/                                         |         
     4 | download.opensuse.org-oss           | Main Repository (OSS)                   | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/                                  |         
     5 | download.opensuse.org-oss_1         | Main Update Repository                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/oss                                              |         
     6 | download.opensuse.org-oss_2         | Main Repository (Sources)               | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/                           |         
     7 | http-download.opensuse.org-e170ff8c | home:osmc                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/osmc/openSUSE_Leap_42.3/                       |         
     8 | http-download.opensuse.org-e4624812 | home:marcus_gama                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/marcus_gama/openSUSE_Leap_42.3/                |         
     9 | libdvdcss                           | libdvdcss                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.3/                                             |         
    10 | openSUSE-42.3-0                     | openSUSE-42.3-0                         | No      | ----      | ----    |   99     | yast2  | hd:///?device=/dev/disk/by-id/usb-Kingston_DataTraveler_3.0_08606E6D4077BEC0D7148EA5-0:0-part2 |         
    11 | openSUSE_Leap_42.3                  | Mozilla based projects                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_42.3/                          |         
    12 | packman.inode.at-suse               | Packman Repository                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.3/                                               |         
    13 | repo-debug                          | openSUSE-Leap-42.3-Debug                | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/oss/                            |         
    14 | repo-debug-non-oss                  | openSUSE-Leap-42.3-Debug-Non-Oss        | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/non-oss/                        |         
    15 | repo-debug-update                   | openSUSE-Leap-42.3-Update-Debug         | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.3/oss/                                       |         
    16 | repo-debug-update-non-oss           | openSUSE-Leap-42.3-Update-Debug-Non-Oss | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.3/non-oss/                                   |         
    17 | repo-source                         | openSUSE-Leap-42.3-Source               | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/                           |         
    18 | repo-source-non-oss                 | openSUSE-Leap-42.3-Source-Non-Oss       | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/non-oss/                       |         
    19 | repo-update                         | openSUSE-Leap-42.3-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.3/oss/                                             |        
    
    

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Browsers won't start at all after updating/installing...

    I'm guessing you have Firefox 56 from the Mozilla repo and mozilla-nss for Firefox LTS from the Update repo I'd say do a full vendor change to the mozilla repo or switch back to Firefox LTS from the update repo
    if you want the latest Firefox (or SeaMonkey) do
    Code:
    zypper dup --from 11
    if you'd prefer Firefox LTS do
    Code:
    zypper dup --from 12 --from 19
    the above needs packman too as not to break multimedia the Mozilla repo doesn't contain any multimedia packages so it didn't need #12

    ps. Firefox 56 has dropped java support and if you have java installed you'll get a dependency error the best way around it is to chose ignore dependency becase the other options are to remove java or Firefox and none of those are good choices

  5. #5
    Join Date
    Dec 2016
    Location
    Burlington - Canada
    Posts
    16

    Default Re: Browsers won't start at all after updating/installing...

    Thank you for your reply.

    I did the following:

    Code:
    simorgh@Simorgh:~> zypper dup --from 11
    Root privileges are required for performing a distribution upgrade.
    simorgh@Simorgh:~> sudo !!
    sudo zypper dup --from 11
    [sudo] password for root:  
    Retrieving repository 'Packman Repository' metadata ...........................................................................................................................................................................................................[done]
    Building repository 'Packman Repository' cache ................................................................................................................................................................................................................[done]
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    2 Problems:
    Problem: java-1_8_0-openjdk-headless-1.8.0.144-15.2.x86_64 requires mozilla-nss = 3.28.6, but this requirement cannot be provided
    Problem: MozillaFirefox-56.0.1-1.1.x86_64 requires mozilla-nss >= 3.33, but this requirement cannot be provided
    
    Problem: java-1_8_0-openjdk-headless-1.8.0.144-15.2.x86_64 requires mozilla-nss = 3.28.6, but this requirement cannot be provided
     Solution 1: deinstallation of java-1_8_0-openjdk-headless-1.8.0.144-15.2.x86_64
     Solution 2: keep obsolete mozilla-nss-3.28.6-44.1.x86_64
     Solution 3: break java-1_8_0-openjdk-headless-1.8.0.144-15.2.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c): 3
    
    Problem: MozillaFirefox-56.0.1-1.1.x86_64 requires mozilla-nss >= 3.33, but this requirement cannot be provided
      uninstallable providers: mozilla-nss-3.33-2.1.i586[openSUSE_Leap_42.3]
                       mozilla-nss-3.33-2.1.x86_64[openSUSE_Leap_42.3]
     Solution 1: deinstallation of MozillaFirefox-52.4.0-63.2.x86_64
     Solution 2: deinstallation of java-1_8_0-openjdk-1.8.0.144-15.2.x86_64
     Solution 3: keep obsolete MozillaFirefox-52.4.0-63.2.x86_64
     Solution 4: break MozillaFirefox-56.0.1-1.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c] (c): 3
    Resolving dependencies...
    Computing distribution upgrade...
    
    The following item is locked and will not be changed by any action:
     Installed:
      MozillaFirefox
    
    The following package is going to be upgraded:
      mozilla-nss
    
    The following 2 packages are going to be downgraded:
      libnsssharedhelper0 MozillaFirefox-branding-openSUSE                                                                                                                                                                                                                
                                                                                                                                                                                                                                                                          
    The following 3 packages are going to change vendor:
      libnsssharedhelper0               openSUSE -> obs://build.opensuse.org/mozilla
      MozillaFirefox-branding-openSUSE  openSUSE -> obs://build.opensuse.org/mozilla
      mozilla-nss                       openSUSE -> obs://build.opensuse.org/mozilla
    
    
    1 package to upgrade, 2 to downgrade, 3  to change vendor.
    Overall download size: 658.5 KiB. Already cached: 0 B. After the operation, additional 24.4 KiB will be used.
    Continue? [y/n/...? shows all options] (y): 
    Retrieving package MozillaFirefox-branding-openSUSE-45-3.1.x86_64                                                                                                                                                               (1/3),  11.0 KiB (  8.4 KiB unpacked)
    Retrieving: MozillaFirefox-branding-openSUSE-45-3.1.x86_64.rpm ................................................................................................................................................................................................[done]
    Retrieving package mozilla-nss-3.33-2.1.x86_64                                                                                                                                                                                  (2/3), 631.5 KiB (  1.8 MiB unpacked)
    Retrieving: mozilla-nss-3.33-2.1.x86_64.rpm .....................................................................................................................................................................................................[done (177.5 KiB/s)]
    Retrieving package libnsssharedhelper0-1.0.10-1.1.x86_64                                                                                                                                                                        (3/3),  16.0 KiB ( 36.1 KiB unpacked)
    Retrieving: libnsssharedhelper0-1.0.10-1.1.x86_64.rpm .........................................................................................................................................................................................................[done]
    Checking for file conflicts: ..................................................................................................................................................................................................................................[done]
    (1/3) Installing: MozillaFirefox-branding-openSUSE-45-3.1.x86_64 ..............................................................................................................................................................................................[done]
    (2/3) Installing: mozilla-nss-3.33-2.1.x86_64 .................................................................................................................................................................................................................[done]
    (3/3) Installing: libnsssharedhelper0-1.0.10-1.1.x86_64 .......................................................................................................................................................................................................[done]
    There are some running programs that might use files deleted by recent upgrade. You may wish to check and restart some of them. Run 'zypper ps -s' to list these programs.
    
    How did this happen. Did this get an update from Software Update and broke the dependencies?

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Browsers won't start at all after updating/installing...

    Quote Originally Posted by simorgh View Post
    Thank you for your reply.

    I did the following:

    Code:
    simorgh@Simorgh:~> zypper dup --from 11
    Root privileges are required for performing a distribution upgrade.
    simorgh@Simorgh:~> sudo !!
    sudo zypper dup --from 11
    [sudo] password for root:  
    Retrieving repository 'Packman Repository' metadata ...........................................................................................................................................................................................................[done]
    Building repository 'Packman Repository' cache ................................................................................................................................................................................................................[done]
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    2 Problems:
    Problem: java-1_8_0-openjdk-headless-1.8.0.144-15.2.x86_64 requires mozilla-nss = 3.28.6, but this requirement cannot be provided
    Problem: MozillaFirefox-56.0.1-1.1.x86_64 requires mozilla-nss >= 3.33, but this requirement cannot be provided
    
    Problem: java-1_8_0-openjdk-headless-1.8.0.144-15.2.x86_64 requires mozilla-nss = 3.28.6, but this requirement cannot be provided
     Solution 1: deinstallation of java-1_8_0-openjdk-headless-1.8.0.144-15.2.x86_64
     Solution 2: keep obsolete mozilla-nss-3.28.6-44.1.x86_64
     Solution 3: break java-1_8_0-openjdk-headless-1.8.0.144-15.2.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c): 3
    
    Problem: MozillaFirefox-56.0.1-1.1.x86_64 requires mozilla-nss >= 3.33, but this requirement cannot be provided
      uninstallable providers: mozilla-nss-3.33-2.1.i586[openSUSE_Leap_42.3]
                       mozilla-nss-3.33-2.1.x86_64[openSUSE_Leap_42.3]
     Solution 1: deinstallation of MozillaFirefox-52.4.0-63.2.x86_64
     Solution 2: deinstallation of java-1_8_0-openjdk-1.8.0.144-15.2.x86_64
     Solution 3: keep obsolete MozillaFirefox-52.4.0-63.2.x86_64
     Solution 4: break MozillaFirefox-56.0.1-1.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c] (c): 3
    Resolving dependencies...
    Computing distribution upgrade...
    
    The following item is locked and will not be changed by any action:
     Installed:
      MozillaFirefox
    
    The following package is going to be upgraded:
      mozilla-nss
    
    The following 2 packages are going to be downgraded:
      libnsssharedhelper0 MozillaFirefox-branding-openSUSE                                                                                                                                                                                                                
                                                                                                                                                                                                                                                                          
    The following 3 packages are going to change vendor:
      libnsssharedhelper0               openSUSE -> obs://build.opensuse.org/mozilla
      MozillaFirefox-branding-openSUSE  openSUSE -> obs://build.opensuse.org/mozilla
      mozilla-nss                       openSUSE -> obs://build.opensuse.org/mozilla
    
    
    1 package to upgrade, 2 to downgrade, 3  to change vendor.
    Overall download size: 658.5 KiB. Already cached: 0 B. After the operation, additional 24.4 KiB will be used.
    Continue? [y/n/...? shows all options] (y): 
    Retrieving package MozillaFirefox-branding-openSUSE-45-3.1.x86_64                                                                                                                                                               (1/3),  11.0 KiB (  8.4 KiB unpacked)
    Retrieving: MozillaFirefox-branding-openSUSE-45-3.1.x86_64.rpm ................................................................................................................................................................................................[done]
    Retrieving package mozilla-nss-3.33-2.1.x86_64                                                                                                                                                                                  (2/3), 631.5 KiB (  1.8 MiB unpacked)
    Retrieving: mozilla-nss-3.33-2.1.x86_64.rpm .....................................................................................................................................................................................................[done (177.5 KiB/s)]
    Retrieving package libnsssharedhelper0-1.0.10-1.1.x86_64                                                                                                                                                                        (3/3),  16.0 KiB ( 36.1 KiB unpacked)
    Retrieving: libnsssharedhelper0-1.0.10-1.1.x86_64.rpm .........................................................................................................................................................................................................[done]
    Checking for file conflicts: ..................................................................................................................................................................................................................................[done]
    (1/3) Installing: MozillaFirefox-branding-openSUSE-45-3.1.x86_64 ..............................................................................................................................................................................................[done]
    (2/3) Installing: mozilla-nss-3.33-2.1.x86_64 .................................................................................................................................................................................................................[done]
    (3/3) Installing: libnsssharedhelper0-1.0.10-1.1.x86_64 .......................................................................................................................................................................................................[done]
    There are some running programs that might use files deleted by recent upgrade. You may wish to check and restart some of them. Run 'zypper ps -s' to list these programs.
    
    How did this happen. Did this get an update from Software Update and broke the dependencies?
    this could not have come from software update you must have added the mozilla repo as it's not present by default
    regarding java I hope you chose Solution 3: break java-1_8_0-openjdk-headless-1.8.0.144-15.2.x86_64 by ignoring some of its dependencies

  7. #7
    Join Date
    Dec 2016
    Location
    Burlington - Canada
    Posts
    16

    Default Re: Browsers won't start at all after updating/installing...

    Quote Originally Posted by I_A View Post
    this could not have come from software update you must have added the mozilla repo as it's not present by default
    regarding java I hope you chose Solution 3: break java-1_8_0-openjdk-headless-1.8.0.144-15.2.x86_64 by ignoring some of its dependencies
    Thank you for your reply.
    I don't recall adding the Mozilla repo, to be honest. Is it safe to remove it and let the default setting/repo handle it?
    I did choose option 3 in both questions though.

    Regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •