Results 1 to 4 of 4

Thread: Autodesk Eagle 8.3.2 not running?

  1. #1

    Default Autodesk Eagle 8.3.2 not running?

    Hi,

    I have been running Eagle PCB design software on my SuSE workstation for years. Generally with no problems.
    However, the latest version 8.3.2 for Linux will not run on Leap 42.2 or 42.3? The previous Eagle version ran okay.
    But as always, this is not the whole story!
    If I make two clean VM's (VirtualBox) installations of 42.2 and 42.3 using the DVD iso's, and then install Eagle 8.3.2 WITHOUT upgrading Eagle 8.3.2 WILL run on 42.x.
    Unfortunately, if I then upgrade each VM, Eagle 8.3.2 will not run!

    The only error message I get is this:
    Code:
    ./eagle: symbol lookup error: /lib64/libssl.so.1.0.0: undefined symbol: OPENSSL_init_librar
    Can anyone suggest what it is in the 400-500 upgraded packages (between the iso install and an up-to-date installation) that is likely to be causing my problem?

    Regards, Martin
    openSUSE Leap 15.1; KDE Plasma 5.12.8;

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: Autodesk Eagle 8.3.2 not running?

    To be sure

    UPGRADED does not work but a completely fresh clean install works.

    Sounds like a possible configuration files problem

    Try with a different user or rename the configuration files or directory for the program

  3. #3

    Default Re: Autodesk Eagle 8.3.2 not running?

    Quote Originally Posted by gogalthorp View Post
    UPGRADED does not work but a completely fresh clean install works?
    Yes, that's correct.
    As I'm sure you will understand, it is useful in these sort of problems to tackle it from both directions. I am passing on some (In the past, I have been reprimanded for linking to other forums) of the latest information from the Eagle Forum: for any SuSE users with an interest in this thread.

    WooHooo.... It runs!

    So, to recap. If I create an environment variable called LD_LIBRARY_PATH and point it at the old (8.3.0) library files, 8.3.2 will run.
    What is this saying? That there is a problem with (all/some?) of the shared object files in the eagle-8.3.2/lib folder?

    What for the longer term?
    1. I will not be holding on to previous versions forever.
    2. Can I copy eagle-8.3.0/lib/*.* to eagle-8.3.2/lib/ to avoid the environment variable fix?
    3. Any suggestions on why 8.3.0 & 8.3.2 will run with openssl 1.0.2j-2.2 but only 8.2.0 (not 8.2.3) will run with openssl 1.0.2j-6.3.1?

    Lastly, Ken. In your testing, what was the sequence you used? I guess you created the clean VM install from the DVD iso and then went on to test Eagle? Which, as we know, will result in Eagle 8.3.2 running.
    Did you look at upgrading your SuSE VM either before or after, installing and testing Eagle 8.3.2? Because there is something different (400-500 patches) between the release iso and an up-to-date SuSE system. Resulting in a system where Eagle 8.3.2 will not run.

    Best regards, Martin
    I would still be interested in any views from the SuSE side, on the question raised in point 3.

    Regards, Martin
    openSUSE Leap 15.1; KDE Plasma 5.12.8;

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,769

    Default Re: Autodesk Eagle 8.3.2 not running?

    As said sounds like maybe a configuration problem old config files are somehow not compatible with new. Did you try my suggestions??

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •