Results 1 to 6 of 6

Thread: Very slow and laggy desktop animation in Gnome 3 (Tumbleweed)

  1. #1

    Default Very slow and laggy desktop animation in Gnome 3 (Tumbleweed)

    Hi,

    I just installed Tumbleweed with Gnome environment and experiencing very slow and unpleasant desktop animations.
    My laptop is fairly new with good spec and I had very good experience with Kubuntu (KDE environment).

    I tried to edit my VGA setting, but didn't find any setting for my Radeon GPU;

    Also the Output of lspci -nnk | grep -A3 VGA:
    Code:
    00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Carrizo [1002:9874] (rev c5)
        Subsystem: Dell Device [1028:06bd]
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu
    PS: I have a Dell inspiron 15 5555;
    GPU: AMD Radeon R6
    CPU : AMD A10 8700P / 1.8 GHz
    Ram : 12 GB
    SSD : Sandisk 1 TB

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,814
    Blog Entries
    15

    Default Re: Very slow and laggy desktop animation in Gnome 3 (Tumbleweed)

    Hi
    I have the same model with a A8-7410 2.20 Ghz CPU, 8GB RAM when i did have Tumbleweed on it, wasn't laggy... How do you mean animations? Switching to overview etc? You shouldn't have to tweak anything with respect to the amdgpu driver. The system is not running tracker and indexing things, any coredump (as root user coredumpctl list).
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Very slow and laggy desktop animation in Gnome 3 (Tumbleweed)

    Quote Originally Posted by malcolmlewis View Post
    Hi
    I have the same model with a A8-7410 2.20 Ghz CPU, 8GB RAM when i did have Tumbleweed on it, wasn't laggy... How do you mean animations? Switching to overview etc? You shouldn't have to tweak anything with respect to the amdgpu driver. The system is not running tracker and indexing things, any coredump (as root user coredumpctl list).
    Hi Malcomlewis and thanks for your reply,

    By animation i mean window transition, showing all applications, minimizing windows and ...
    in KDE we could change some settings like openGL versions and ..., so there's nothing to do in Gnome 3, right?

    THanks

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,814
    Blog Entries
    15

    Default Re: Very slow and laggy desktop animation in Gnome 3 (Tumbleweed)

    Quote Originally Posted by lightblue View Post
    Hi Malcomlewis and thanks for your reply,

    By animation i mean window transition, showing all applications, minimizing windows and ...
    in KDE we could change some settings like openGL versions and ..., so there's nothing to do in Gnome 3, right?

    THanks
    Hi
    Is this running the proprietary amdgpu-pro driver, or the oss one?

    By default your running Wayland (Check System Settings -> Details), so you could try switching back to Xorg and see if that improves your system.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Very slow and laggy desktop animation in Gnome 3 (Tumbleweed)

    Hi, I can confirm choppy animations in gnome. My machine is i7 with 8Gb ram so it should handle gnome quite easy. I've installed TW few days ago and did some tests. My conclusions are that when i plug power source, lag is gone, so it is probably TLP related? But some time ago i Had gnome 3.24 on ths machine (also TW) and everything was ok.

  6. #6

    Default Re: Very slow and laggy desktop animation in Gnome 3 (Tumbleweed)

    I've edited
    Code:
    /etc/default/tlp
    and changed the line:
    Code:
    CPU_HWP_ON_BAT=balance_power
    to:
    Code:
    CPU_HWP_ON_BAT=balance_performance
    becouse my animations were choppy only on battery, i thought it must be related to powersaving settings. Now everything is back to normal.


    I've rechecked power consumption by powertop and everything looks ok, so it should be safe.
    For me problem is gone.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •