Results 1 to 2 of 2

Thread: motion not working

  1. #1

    Default motion not working

    On openSUSE 42.2 motion does not work anymore. On openSUSE 42.1 i got it working, but i do not remember how. Cheese is working with this camera. The motion logfile says:
    Code:
    [36315680:motion] [NTC] [ALL] [Oct 08 21:50:12] motion_startup: Using log type (ALL) log level (NTC)
    [36315680:motion] [NTC] [ENC] [Oct 08 21:50:12] ffmpeg_init: ffmpeg libavcodec version 57.89.100 libavformat version 57.71.100
    [0:motion] [NTC] [ALL] [Oct 08 21:50:12] main: Camera 0 is from /etc/motion/motion.conf
    [0:motion] [NTC] [ALL] [Oct 08 21:50:12] main: Camera 0 is device: /dev/video0 input -1
    [0:motion] [NTC] [ALL] [Oct 08 21:50:12] main: Stream port 8081
    [0:motion] [NTC] [ALL] [Oct 08 21:50:12] main: Waiting for threads to finish, pid: 3854
    [1:ml1] [NTC] [ALL] [Oct 08 21:50:12] motion_init: Camera 0 started: motion detection Enabled
    [0:web_control] [NTC] [STR] [Oct 08 21:50:12] http_bindsock: listening on 127.0.0.1 port 8080
    [1:ml1] [NTC] [VID] [Oct 08 21:50:12] vid_v4lx_start: Using videodevice /dev/video0 and input -1
    [0:web_control] [NTC] [STR] [Oct 08 21:50:12] httpd_run: Started motion-httpd server on port 8080 (auth Disabled)
    [1:ml1] [NTC] [VID] [Oct 08 21:50:12] v4l2_get_capability: 
    ------------------------
    cap.driver: "ov519"
    cap.card: "USB Camera"
    cap.bus_info: "usb-0000:00:02.0-4"
    cap.capabilities=0x85200001
    ------------------------
    [1:ml1] [NTC] [VID] [Oct 08 21:50:12] v4l2_get_capability: - VIDEO_CAPTURE
    [1:ml1] [NTC] [VID] [Oct 08 21:50:12] v4l2_get_capability: - READWRITE
    [1:ml1] [NTC] [VID] [Oct 08 21:50:12] v4l2_get_capability: - STREAMING
    [1:ml1] [NTC] [VID] [Oct 08 21:50:12] v4l2_select_input: name = "ov519", type 0x00000002, status 00000000
    [1:ml1] [NTC] [VID] [Oct 08 21:50:12] v4l2_select_input: - CAMERA
    [1:ml1] [WRN] [VID] [Oct 08 21:50:12] v4l2_select_input: Device doesn't support VIDIOC_G_STD
    [1:ml1] [NTC] [VID] [Oct 08 21:50:12] v4l2_set_pix_format: Config palette index 17 (YU12) doesn't work.
    [1:ml1] [NTC] [VID] [Oct 08 21:50:12] v4l2_set_pix_format: Supported palettes:
    [1:ml1] [NTC] [VID] [Oct 08 21:50:12] v4l2_set_pix_format: (0) O518 (GSPCA OV518)
    [1:ml1] [NTC] [VID] [Oct 08 21:50:12] v4l2_set_pix_format: 0 - GSPCA OV518 (compressed : 1) (0x3831354f)
    [1:ml1] [ERR] [VID] [Oct 08 21:50:12] v4l2_set_pix_format: Unable to find a compatible palette format.
    [1:ml1] [NTC] [VID] [Oct 08 21:50:12] vid_v4lx_start: Using V4L1
    [1:ml1] [NTC] [ALL] [Oct 08 21:50:12] image_ring_resize: Resizing pre_capture buffer to 1 items
    [1:ml1] [ERR] [ALL] [Oct 08 21:50:22] motion_init: Error capturing first image
    [1:ml1] [NTC] [STR] [Oct 08 21:50:22] http_bindsock: listening on 127.0.0.1 port 8081
    [1:ml1] [NTC] [ALL] [Oct 08 21:50:22] motion_init: Started motion-stream server on port 8081 (auth Disabled)
    [1:ml1] [ERR] [ALL] [Oct 08 21:50:22] motion_loop: Video device fatal error - Closing video device
    [1:ml1] [NTC] [VID] [Oct 08 21:50:22] vid_close: Closing video device /dev/video0
    [1:ml1] [WRN] [ALL] [Oct 08 21:50:30] motion_loop: Retrying until successful connection with camera
    [1:ml1] [NTC] [VID] [Oct 08 21:50:30] vid_v4lx_start: Using videodevice /dev/video0 and input -1
    [1:ml1] [NTC] [VID] [Oct 08 21:50:30] v4l2_get_capability: 
    ------------------------
    cap.driver: "ov519"
    cap.card: "USB Camera"
    cap.bus_info: "usb-0000:00:02.0-4"
    cap.capabilities=0x85200001
    ------------------------
    [1:ml1] [NTC] [VID] [Oct 08 21:50:30] v4l2_get_capability: - VIDEO_CAPTURE
    [1:ml1] [NTC] [VID] [Oct 08 21:50:30] v4l2_get_capability: - READWRITE
    [1:ml1] [NTC] [VID] [Oct 08 21:50:30] v4l2_get_capability: - STREAMING
    [1:ml1] [NTC] [VID] [Oct 08 21:50:30] v4l2_select_input: name = "ov519", type 0x00000002, status 00000000
    [1:ml1] [NTC] [VID] [Oct 08 21:50:30] v4l2_select_input: - CAMERA
    [1:ml1] [WRN] [VID] [Oct 08 21:50:30] v4l2_select_input: Device doesn't support VIDIOC_G_STD
    [1:ml1] [NTC] [VID] [Oct 08 21:50:30] v4l2_set_pix_format: Config palette index 17 (YU12) doesn't work.
    [1:ml1] [NTC] [VID] [Oct 08 21:50:30] v4l2_set_pix_format: Supported palettes:
    [1:ml1] [NTC] [VID] [Oct 08 21:50:30] v4l2_set_pix_format: (0) O518 (GSPCA OV518)
    [1:ml1] [NTC] [VID] [Oct 08 21:50:30] v4l2_set_pix_format: 0 - GSPCA OV518 (compressed : 1) (0x3831354f)
    [1:ml1] [ERR] [VID] [Oct 08 21:50:30] v4l2_set_pix_format: Unable to find a compatible palette format.
    [1:ml1] [NTC] [VID] [Oct 08 21:50:30] vid_v4lx_start: Using V4L1
    [1:ml1] [ERR] [ALL] [Oct 08 21:50:30] motion_loop: Video device fatal error - Closing video device
    [1:ml1] [NTC] [VID] [Oct 08 21:50:30] vid_close: Closing video device /dev/video0
    [1:ml1] [WRN] [ALL] [Oct 08 21:50:40] motion_loop: Retrying until successful connection with camera
    [1:ml1] [NTC] [VID] [Oct 08 21:50:40] vid_v4lx_start: Using videodevice /dev/video0 and input -1
    [1:ml1] [NTC] [VID] [Oct 08 21:50:40] v4l2_get_capability: 
    ------------------------
    cap.driver: "ov519"
    cap.card: "USB Camera"
    cap.bus_info: "usb-0000:00:02.0-4"
    cap.capabilities=0x85200001
    ------------------------
    [1:ml1] [NTC] [VID] [Oct 08 21:50:40] v4l2_get_capability: - VIDEO_CAPTURE
    [1:ml1] [NTC] [VID] [Oct 08 21:50:40] v4l2_get_capability: - READWRITE
    [1:ml1] [NTC] [VID] [Oct 08 21:50:40] v4l2_get_capability: - STREAMING
    [1:ml1] [NTC] [VID] [Oct 08 21:50:40] v4l2_select_input: name = "ov519", type 0x00000002, status 00000000
    [1:ml1] [NTC] [VID] [Oct 08 21:50:40] v4l2_select_input: - CAMERA
    [1:ml1] [WRN] [VID] [Oct 08 21:50:40] v4l2_select_input: Device doesn't support VIDIOC_G_STD
    [1:ml1] [NTC] [VID] [Oct 08 21:50:40] v4l2_set_pix_format: Config palette index 17 (YU12) doesn't work.
    [1:ml1] [NTC] [VID] [Oct 08 21:50:40] v4l2_set_pix_format: Supported palettes:
    [1:ml1] [NTC] [VID] [Oct 08 21:50:40] v4l2_set_pix_format: (0) O518 (GSPCA OV518)
    [1:ml1] [NTC] [VID] [Oct 08 21:50:40] v4l2_set_pix_format: 0 - GSPCA OV518 (compressed : 1) (0x3831354f)
    [1:ml1] [ERR] [VID] [Oct 08 21:50:40] v4l2_set_pix_format: Unable to find a compatible palette format.
    [1:ml1] [NTC] [VID] [Oct 08 21:50:40] vid_v4lx_start: Using V4L1
    [1:ml1] [ERR] [ALL] [Oct 08 21:50:40] motion_loop: Video device fatal error - Closing video device
    [1:ml1] [NTC] [VID] [Oct 08 21:50:40] vid_close: Closing video device /dev/video0
    [1:ml1] [WRN] [ALL] [Oct 08 21:50:50] motion_loop: Retrying until successful connection with camera
    [1:ml1] [NTC] [VID] [Oct 08 21:50:50] vid_v4lx_start: Using videodevice /dev/video0 and input -1
    [1:ml1] [NTC] [VID] [Oct 08 21:50:50] v4l2_get_capability: 
    .
    .
    .
    .
    .
    .
    .
    .

  2. #2

    Default Re: motion not working

    I got it working with:
    Code:
    pc1:/home/amadrits # LD_PRELOAD=/usr/lib64/libv4l/v4l1compat.so motion

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •