Results 1 to 6 of 6

Thread: No video playback

  1. #1

    Default No video playback

    I've been trying to play videos in Leap 42.3 (with pacman repo enabled) and it is a major fail - neither Totem or Gnome MPV do the trick. When I launched totem via cli I found:

    ** Message: Missing plugin: gstreamer|1.0|totem|Dekoder H.264 (High Profile)|decoder-video/x-h264, level=(string)4, profile=(string)high, interlace-mode=(string)progressive (Dekoder H.264 (High Profile))

    When I'm trying to do as in the guide on the forums I get:


    File /usr/lib64/gstreamer-1.0/libgsta52dec.so
    from install of
    gstreamer-plugins-ugly-orig-addon-1.8.3-7.1.x86_64 (packman)
    conflicts with file from package
    gstreamer-plugins-ugly-1.12.3-92.3.x86_64 (@System)


    File /usr/lib64/gstreamer-1.0/libgstlame.so
    from install of
    gstreamer-plugins-ugly-orig-addon-1.8.3-7.1.x86_64 (packman)
    conflicts with file from package
    gstreamer-plugins-ugly-1.12.3-92.3.x86_64 (@System)


    File /usr/lib64/gstreamer-1.0/libgsttwolame.so
    from install of
    gstreamer-plugins-ugly-orig-addon-1.8.3-7.1.x86_64 (packman)
    conflicts with file from package
    gstreamer-plugins-ugly-1.12.3-92.3.x86_64 (@System)

    How should I proceed?

    Also is there a repo with fffmpeg that has nvenc enabled somewhere?
    Lastly how do you setup OBS-studio on Opensuse? When I try to record the video I get a message about encoders failing.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,728

    Default AW: No video playback

    gstreamer-plugins-ugly-orig-addon-1.8.3-7.1.x86_64 (packman)
    conflicts with file from package
    gstreamer-plugins-ugly-1.12.3-92.3.x86_64 (@System)
    Here are only Version 1.8 avaible, so where do you get you Version 1.12?
    Code:
    S  | Name                                              | Typ        | Version   | Arch   | Repository            
    ---+---------------------------------------------------+------------+-----------+--------+-----------------------
    i+ | gstreamer-plugins-ugly                            | Paket      | 1.8.3-7.1 | x86_64 | Packman Repository    
    v  | gstreamer-plugins-ugly                            | Paket      | 1.8.3-4.1 | x86_64 | openSUSE-Leap-42.3-Oss
    Code:
    Post: zypper lr -d
    Use Code-Tags.

    Edit:
    I think from here:
    https://download.opensuse.org/reposi...USE_Leap_42.3/

    And that is no good choice.
    Better is only Packman for multimedia packages.
    Or you know what you are doing......

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: No video playback

    gstreamer-plugins-ugly-orig-addon has been depreciated and all of the codecs it provided have been moved to gstreamer-plugins-ugly but that package only provides audio codecs and you are describing a video issue
    check to see if you have gstreamer-plugins-bad and gstreamer-plugins-libav
    Code:
    zypper se -si gstreamer-plugins-bad
    zypper se -si gstreamer-plugins-libav
    if you don't have them install them if they're from 42.2 do a system upgrade to 42.3
    another thing gstreamer-plugins-ugly-orig-addon never existed for 42.3 that's a 42.2 package I'm guessing your upgrade wasn't quite successful check to see if you have some old packages left behind (assuming you upgraded from 42.2)
    Code:
    rpm -qa --queryformat "%{Name}:%{Distribution}\n" | grep -F "42.2"
    about nvenc as it's a h264 based encoder I don't think it's in OBS and installing ffmpeg from OBS will break multimedia

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: No video playback

    one more thing you seam to be installing gstreamer packages from multimedia:libs repo
    all multimedia especially gstreamer should be installed from packman as Sauerland said tell us your repo list
    Code:
    zypper lr -d
    I already mentioned this but you seam to have old 42.2 packages how did you upgrade to 42.3 from an install disk or live with zypper dup?

  5. #5

    Default Re: No video playback

    THANK YOU! Yeah- I've messed it up. It seems at one point I've added multimedia repo. Removed it and did zypper dup. I also had to remove vaapi related packages as with them I got:

    Code:
    libva info: VA-API version 0.39.4
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib64/dri/nvidia_drv_video.so
    libva info: Found init function __vaDriverInit_0_39
    libva info: va_openDriver() returns 0
    
    
    (totem:9518): Gtk-WARNING **: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node slider owner GtkScale)
    
    
    (totem:9518): Cogl-WARNING **: driver/gl/cogl-buffer-gl.c:93: GL error (1280): Invalid enumeration value
    With those removed video now plays in Totem correctly.
    Also it seems that the ffmpeg version I got after the procedure has nvenc enabled. YAY!

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: No video playback

    vaapi is not needed on nvidia hardware as it's intel technology for hardware accelerated video decoding I think amd also uses it
    if that's an optimus laptop maybe you need bumblebee
    https://en.opensuse.org/SDB:NVIDIA_Bumblebee

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •