Results 1 to 9 of 9

Thread: How do you prevent Kontact from auto starting on login?

  1. #1

    Default How do you prevent Kontact from auto starting on login?

    Every time I log in, Kontact automatically starts up, as does the KOrganizer remider daemon. I've unchecked "Enable Reminders" and "Start Reminder Daemon at Login" in the taskbar, but very time I log in, it starts anyway. It's not in autostart in system settings either. What am I missing?

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,573

    Default Re: How do you prevent Kontact from auto starting on login?

    Quote Originally Posted by z2 View Post
    What am I missing?
    Possibly nothing. The same thing happens to me sometimes, both on this laptop Leap 42.3 system and on my desktop Leap 42.2 system.

    The only thing I've noticed is that, it seems to happen mostly when there's an event or 'to-do' reminder popping up at login.

    I haven't really noticed that "akonadictl fsck" and "akonadictl vacuum" (both executed with Kontact shut down) really change the frequency of Kontact popping up at login. I'll possibly, sometime next week, take another sweep through the '~/.cache/' and '~/.config/' directories to see if anything is lurking in one of files . . .

  3. #3

    Default Re: How do you prevent Kontact from auto starting on login?

    I'm not actually using Kontact though, or any of the parts of it (KMail, etc.). I just opened it to check it out and now I can't stop it from auto starting. There must be a setting somewhere. I deleted everything in .cache also, no effect.

  4. #4

    Default Re: How do you prevent Kontact from auto starting on login?

    I fixed this problem. It's probably over-kill, but I just disabled everything in the configuration settings.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,812
    Blog Entries
    3

    Default Re: How do you prevent Kontact from auto starting on login?

    Quote Originally Posted by z2 View Post
    I'm not actually using Kontact though, or any of the parts of it (KMail, etc.).
    I'm not using it either. But it does not automatically start here.

    I just opened it to check it out and now I can't stop it from auto starting.
    Reminder to self -- don't start Kontact or Kmail just to see what it does.

    Actually, I have a separate test-user account that I can login for testing things. And when done with the testing, I can reset it by deleting all configuration for that account (".config", ".local", ".cache", ".kde4" and similar).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,573

    Cool Re: How do you prevent Kontact from auto starting on login?

    Quote Originally Posted by z2 View Post
    I just disabled everything in the configuration settings.
    Please check that, Akonadi is also stopped and not running:
    1. "akonadictl stop".
    2. Check that nothing related with Kontact -- the "PIM Events Plugin" -- is enabled in the Plasma Clock widget.
    3. Log out.
    4. From a TTY console, 'cd' to "~/.local/share/" -- remove everything looking like 'akonadi' (there's a socket link in the "akonadi" directory to "/tmp/akonadi-<User Name>-<random number>/"); 'akregator'; 'emailidentities'; 'contacts'; 'kaddressbook'; 'kmail2'; 'kontact'; 'korganizer'; 'local-mail'; 'messageviewer'.
    5. From a TTY console, 'cd' to "/tmp/" -- remove the "akonadi-<User Name>-<random number>" directory.
    6. From a TTY console, 'cd' to "~/.config/" -- remove everything with 'akonadi' in the name; 'akregatorrc'; 'calendar_printing.rc'; 'emaildefaults'; 'emailidentities'; 'eventviewsrc'; 'kaddressbookrc'; 'kmail2rc'; 'kmailsearchindexingrc'; 'kontactrc'; 'kontact_summaryrc'; 'korgacrc'; 'korganizerrc'; 'kpimcompletionorder'; 'mailtransports'; 'specialmailcollectionsrc'.

    I think that the above list is fairly complete, but there may be something that I missed …

    After the Akonadi and related KDE PIM local data and configuration has been deleted, you can login agin to KDE without having any Akonadi or PIM components being started at login -- check with KSysguard that there're no akonadi processes running from your user -- check that, the user's Akonadi directory in "/tmp/" hasn't been recreated …

  7. #7

    Default Re: How do you prevent Kontact from auto starting on login?

    Quote Originally Posted by dcurtisfra View Post
    Please check that, Akonadi is also stopped and not running....
    I had disabled akonadi also and it seemed to do the trick, but I went ahead and deleted the files/directories you suggested as well. Akonadi is no longer starting up at login. Thanks for the advice.

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,004
    Blog Entries
    14

    Default Re: How do you prevent Kontact from auto starting on login?

    Quote Originally Posted by z2 View Post
    I had disabled akonadi also and it seemed to do the trick, but I went ahead and deleted the files/directories you suggested as well. Akonadi is no longer starting up at login. Thanks for the advice.
    AFAICS what happens is that you have "Restore previous session" switched on. Kontact shouldn't autostart, unless this item is switched on. Set it to start with a clean session. You can stop akonadi from autostarting in ~/.config/akonadi/akonadiserverrc
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,573

    Cool Re: How do you prevent Kontact from auto starting on login?

    Quote Originally Posted by Knurpht View Post
    You can stop akonadi from autostarting in ~/.config/akonadi/akonadiserverrc
    Used to be the case; the current KDE view seems to be this one: <https://userbase.kde.org/Akonadi#Dis...nadi_subsystem>.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •