Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: Another zypper dup puzzle; 3 Problems: yast2-apparmor-4.0.0-1.2.noarch, perl-5.24.1-1.7.x86_64, perl

  1. #1
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Another zypper dup puzzle; 3 Problems: yast2-apparmor-4.0.0-1.2.noarch, perl-5.24.1-1.7.x86_64, perl

    Hi. What should i do pls? My TW is 20170928, & i assume the new one will be 20171003.
    Code:
    gooeygirl@linux-Tower:~> sudo zypper -vvv dup
    
    
    [sudo] password for root: 
    Verbosity: 3
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Initialising Target
    Checking whether to refresh metadata for My_openSUSE_Repo
    Checking whether to refresh metadata for Vivaldi
    Retrieving: http://repo.vivaldi.com/snapshot/rpm/x86_64/repodata/repomd.xml ........................................[done]
    Checking whether to refresh metadata for Main Repository (NON-OSS)
    Retrieving: http://download.opensuse.org/tumbleweed/repo/non-oss/content ...........................................[done]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/non-oss/media.1/media .....................................[done]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/non-oss/media.1/media ............................[done (26 B/s)]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/non-oss/content.asc .......................................[done]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/non-oss/content.key .......................................[done]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/non-oss/content ................................[done (1003 B/s)]
      Repository:       Main Repository (NON-OSS)                           
      Key Name:         openSUSE Project Signing Key <opensuse@opensuse.org>
      Key Fingerprint:  22C07BA5 34178CD0 2EFE22AA B88B2FD4 3DBDC284        
      Key Created:      Mon 05 May 2014 18:37:40 AEST                       
      Key Expires:      Thu 02 May 2024 18:37:40 AEST                       
      Rpm Name:         gpg-pubkey-3dbdc284-53674dd4                        
    Retrieving: http://download.opensuse.org/tumbleweed/repo/non-oss/suse/setup/descr/packages.DU.gz ...................[done]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/non-oss/suse/setup/descr/packages.en.gz .........[done (972 B/s)]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/non-oss/suse/setup/descr/packages.gz ......................[done]
    Retrieving repository 'Main Repository (NON-OSS)' metadata .........................................................[done]
    Building repository 'Main Repository (NON-OSS)' cache ..............................................................[done]
    Checking whether to refresh metadata for Main Repository (OSS)
    Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/content ..................................[done (13.5 KiB/s)]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/media.1/media .........................................[done]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/media.1/media ................................[done (26 B/s)]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/content.asc ...........................................[done]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/content.key ...........................................[done]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/content ....................................[done (1001 B/s)]
      Repository:       Main Repository (OSS)                               
      Key Name:         openSUSE Project Signing Key <opensuse@opensuse.org>
      Key Fingerprint:  22C07BA5 34178CD0 2EFE22AA B88B2FD4 3DBDC284        
      Key Created:      Mon 05 May 2014 18:37:40 AEST                       
      Key Expires:      Thu 02 May 2024 18:37:40 AEST                       
      Rpm Name:         gpg-pubkey-3dbdc284-53674dd4                        
    Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/suse/setup/descr/appdata-icons.tar.gz ...[done (281.8 KiB/s)]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/suse/setup/descr/appdata-ignore.xml.gz ..[done (150.0 KiB/s)]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/suse/setup/descr/appdata-screenshots.tar ..............[done]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/suse/setup/descr/appdata.xml.gz .........[done (331.8 KiB/s)]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/suse/setup/descr/packages.DU.gz .........[done (263.6 KiB/s)]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/suse/setup/descr/packages.en.gz .........[done (293.8 KiB/s)]
    Retrieving: http://download.opensuse.org/tumbleweed/repo/oss/suse/setup/descr/packages.gz ............[done (324.0 KiB/s)]
    Retrieving repository 'Main Repository (OSS)' metadata .............................................................[done]
    Building repository 'Main Repository (OSS)' cache ..................................................................[done]
    Checking whether to refresh metadata for Main Update Repository
    Retrieving: http://download.opensuse.org/update/tumbleweed/repodata/repomd.xml .....................................[done]
    Checking whether to refresh metadata for Packman Repository
    Retrieving: http://packman.inode.at/suse/openSUSE_Tumbleweed/repodata/repomd.xml ...................................[done]
    Retrieving: http://packman.inode.at/suse/openSUSE_Tumbleweed/media.1/media ....................................[not found]
    Retrieving: http://packman.inode.at/suse/openSUSE_Tumbleweed/repodata/repomd.xml.asc ...............................[done]
    Retrieving: http://packman.inode.at/suse/openSUSE_Tumbleweed/repodata/repomd.xml.key ...............................[done]
    Retrieving: http://packman.inode.at/suse/openSUSE_Tumbleweed/repodata/repomd.xml .......................[done (1.0 KiB/s)]
      Repository:       Packman Repository                                    
      Key Name:         PackMan Project (signing key) <packman@links2linux.de>
      Key Fingerprint:  F8875B88 0D518B6B 8C530D13 45A1D067 1ABD1AFB          
      Key Created:      Tue 16 Sep 2014 08:18:00 AEST                         
      Key Expires:      Fri 13 Sep 2024 08:17:21 AEST                         
      Rpm Name:         gpg-pubkey-1abd1afb-54176598                          
    Retrieving: http://packman.inode.at/suse/openSUSE_Tumbleweed/repodata/primary.xml.gz .................[done (264.3 KiB/s)]
    Retrieving repository 'Packman Repository' metadata ................................................................[done]
    Building repository 'Packman Repository' cache .....................................................................[done]
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    Force resolution: No
    Computing upgrade...
    3 Problems:
    Problem: yast2-apparmor-4.0.0-1.2.noarch requires perl(:MODULE_COMPAT_5.26.1), but this requirement cannot be provided
    Problem: perl-5.24.1-1.7.x86_64 requires perl-base = 5.24.1, but this requirement cannot be provided
    Problem: perl-Gtk2-Unique-0.05-1.7.x86_64 requires perl(:MODULE_COMPAT_5.24.1), but this requirement cannot be provided
    
    
    Problem: yast2-apparmor-4.0.0-1.2.noarch requires perl(:MODULE_COMPAT_5.26.1), but this requirement cannot be provided
      uninstallable providers: perl-5.26.1-1.2.i586[download.opensuse.org-oss]
                       perl-5.26.1-1.2.x86_64[download.opensuse.org-oss]
     Solution 1: Following actions will be done:
      keep obsolete yast2-apparmor-4.0.0-1.1.noarch
      keep obsolete perl-namespace-clean-0.27-1.3.noarch
      keep obsolete perl-namespace-autoclean-0.28-1.4.noarch
      keep obsolete perl-libwww-perl-6.27-1.1.noarch
      keep obsolete perl-YAML-1.23-1.2.noarch
      keep obsolete perl-XML-XPath-1.42-1.1.noarch
      keep obsolete perl-XML-Twig-3.52-1.2.noarch
      keep obsolete perl-XML-Simple-2.24-1.2.noarch
      keep obsolete perl-XML-SAX-Expat-0.51-3.5.noarch
      keep obsolete perl-XML-SAX-Base-1.09-1.2.noarch
      keep obsolete perl-XML-NamespaceSupport-1.12-1.2.noarch
      keep obsolete perl-WWW-RobotRules-6.02-9.5.noarch
      keep obsolete perl-WWW-Mechanize-1.75-2.4.noarch
      keep obsolete perl-URI-1.72-1.1.noarch
      keep obsolete perl-Types-Serialiser-1.0-3.5.noarch
      keep obsolete perl-Try-Tiny-0.28-1.2.noarch
      keep obsolete perl-TimeDate-1.20-26.5.noarch
      keep obsolete perl-Tie-Simple-1.04-1.4.noarch
      keep obsolete perl-Text-Glob-0.11-1.2.noarch
      keep obsolete perl-Test-Warn-0.32-1.2.noarch
      keep obsolete perl-Test-Pod-Coverage-1.10-3.5.noarch
      keep obsolete perl-Test-Pod-1.51-1.6.noarch
      keep obsolete perl-Test-Fatal-0.014-1.5.noarch
      keep obsolete perl-Task-Weaken-1.04-21.5.x86_64
      keep obsolete perl-Sub-Uplevel-0.240.0-13.5.noarch
      keep obsolete perl-Sub-Quote-2.004000-1.1.noarch
      keep obsolete perl-Sub-Install-0.928-1.6.noarch
      keep obsolete perl-Sub-Exporter-Progressive-0.001013-1.2.noarch
      keep obsolete perl-Specio-0.40-1.1.noarch
      keep obsolete perl-Sort-Naturally-1.03-5.6.noarch
      keep obsolete perl-Role-Tiny-2.000005-1.2.noarch
      keep obsolete perl-RPC-XML-0.79-1.3.noarch
      keep obsolete perl-Proc-Simple-1.32-1.5.noarch
      keep obsolete perl-Pod-Coverage-0.23-5.6.noarch
      keep obsolete perl-Perl-Tidy-20170521-1.1.noarch
      keep obsolete perl-Path-Class-0.37-1.2.noarch
      keep obsolete perl-Params-ValidationCompiler-0.24-1.1.noarch
      keep obsolete perl-Package-Stash-0.37-1.5.noarch
      keep obsolete perl-Package-DeprecationManager-0.17-1.2.noarch
      keep obsolete perl-PPI-1.236-1.1.noarch
      keep obsolete perl-Number-Compare-0.03-10.5.noarch
      keep obsolete perl-Net-HTTP-6.17-1.1.noarch
      keep obsolete perl-Net-DNS-1.12-1.1.noarch
      keep obsolete perl-Module-Runtime-0.015-1.1.noarch
      keep obsolete perl-Module-Implementation-0.09-1.5.noarch
      keep obsolete perl-MRO-Compat-0.13-1.2.noarch
      keep obsolete perl-Locale-Maketext-Lexicon-1.00-1.5.noarch
      keep obsolete perl-List-MoreUtils-0.425-1.1.noarch
      keep obsolete perl-Lingua-EN-Sentence-0.30-1.2.noarch
      keep obsolete perl-LWP-Protocol-https-6.06-1.5.noarch
      keep obsolete perl-LWP-MediaTypes-6.02-9.5.noarch
      keep obsolete perl-JSON-2.94-1.1.noarch
      keep obsolete perl-Image-ExifTool-10.55-1.1.noarch
      keep obsolete perl-IPC-System-Simple-1.25-3.5.noarch
      keep obsolete perl-IO-Socket-SSL-2.051-1.1.noarch
      keep obsolete perl-IO-HTML-1.001-1.5.noarch
      keep obsolete perl-HTTP-Server-Simple-0.52-1.2.noarch
      keep obsolete perl-HTTP-Negotiate-6.01-9.5.noarch
      keep obsolete perl-HTTP-Message-6.13-1.1.noarch
      keep obsolete perl-HTTP-Date-6.02-9.5.noarch
      keep obsolete perl-HTTP-Daemon-6.01-9.5.noarch
      keep obsolete perl-HTTP-Cookies-6.04-1.1.noarch
      keep obsolete perl-HTML-Tree-5.07-1.1.noarch
      keep obsolete perl-HTML-Tagset-3.20-73.5.noarch
      keep obsolete perl-HTML-Format-2.11-1.5.noarch
      keep obsolete perl-HTML-Form-6.03-5.6.noarch
      keep obsolete perl-File-Which-1.22-1.1.noarch
      keep obsolete perl-File-ShareDir-1.104-1.1.noarch
      keep obsolete perl-File-Listing-6.04-9.5.noarch
      keep obsolete perl-File-Find-Rule-0.34-1.4.noarch
      keep obsolete perl-File-Copy-Recursive-0.38-9.5.noarch
      keep obsolete perl-File-BaseDir-0.07-1.5.noarch
      keep obsolete perl-ExtUtils-PkgConfig-1.160000-1.2.noarch
      keep obsolete perl-ExtUtils-Depends-0.405-1.4.noarch
      keep obsolete perl-Exporter-Tiny-1.000000-1.1.noarch
      keep obsolete perl-Exception-Class-1.43-1.1.noarch
      keep obsolete perl-Eval-Closure-0.14-1.2.noarch
      keep obsolete perl-Encode-Locale-1.05-1.5.noarch
      keep obsolete perl-Dist-CheckConflicts-0.11-1.5.noarch
      keep obsolete perl-Digest-HMAC-1.03-20.6.noarch
      keep obsolete perl-Devel-Symdump-2.18-1.2.noarch
      keep obsolete perl-Devel-StackTrace-2.02-1.2.noarch
      keep obsolete perl-DateTime-TimeZone-2.13-1.1.noarch
      keep obsolete perl-DateTime-Locale-1.160000-1.1.noarch
      keep obsolete perl-DateTime-Format-Strptime-1.74-1.1.noarch
      keep obsolete perl-DateTime-Format-Builder-0.81-5.6.noarch
      keep obsolete perl-Config-Crontab-1.45-1.2.noarch
      keep obsolete perl-Class-Singleton-1.5-1.5.noarch
      keep obsolete perl-Class-Method-Modifiers-2.12-1.3.noarch
      keep obsolete perl-Class-Inspector-1.32-1.1.noarch
      keep obsolete perl-Class-Factory-Util-1.7-14.5.noarch
      keep obsolete perl-Class-Data-Inheritable-0.08-77.5.noarch
      keep obsolete perl-Capture-Tiny-0.46-1.2.noarch
      keep obsolete perl-CPAN-Changes-0.400002-2.1.noarch
      keep obsolete perl-CGI-4.36-1.2.noarch
      keep obsolete perl-B-Hooks-EndOfScope-0.21-1.3.noarch
      keep obsolete perl-Archive-Zip-1.59-1.2.noarch
      keep obsolete perl-AppConfig-1.71-1.5.noarch
      keep obsolete pciutils-ids-20170917-1.1.noarch
      keep obsolete apparmor-utils-2.11.0-7.1.noarch
      keep obsolete perl-5.24.1-1.7.x86_64
     Solution 2: deinstallation of perl-DateTime-Format-ISO8601-0.08-1.13.noarch
     Solution 3: break yast2-apparmor-4.0.0-1.2.noarch by ignoring some of its dependencies
    
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c):
    You can see there's 2 other problems as well, so i might need to also ask about them later, once i understand the least-worst thing i should do for the first problem.

    Thanks.

    PS - I know i am a hopelessly slow learner, but i still don't understand why TW keeps freaking me out with these impossible choices; why can't it work out the "correct" action itself?

  2. #2
    Join Date
    Sep 2012
    Posts
    4,132

    Default Re: Another zypper dup puzzle; 3 Problems: yast2-apparmor-4.0.0-1.2.noarch, perl-5.24.1-1.7.x86_64,

    Quote Originally Posted by GooeyGirl View Post
    Code:
     Solution 2: deinstallation of perl-DateTime-Format-ISO8601-0.08-1.13.noarch
    This package is not part of openSUSE, so it was not (yet) rebuilt with updated Perl. That is normal for third party repositories.

    I wish zypper gave more intelligible explanation what exactly is causing dependency problem.

  3. #3
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Another zypper dup puzzle; 3 Problems: yast2-apparmor-4.0.0-1.2.noarch, perl-5.24.1-1.7.x86_64,

    Thank you.

    Just to clarify, am i correct to assume that your quoting me Solution 2 for Problem 1, means that you are recommending that should be my action [ie, pick Sol.2]? If so, should i select the same option for those other two problems also pls?

    There's just no way i can ever know, without seeking help here, what i should do with these opaque problems.

  4. #4
    Join Date
    Sep 2012
    Posts
    4,132

    Default Re: Another zypper dup puzzle; 3 Problems: yast2-apparmor-4.0.0-1.2.noarch, perl-5.24.1-1.7.x86_64,

    Quote Originally Posted by GooeyGirl View Post
    you are recommending that should be my action
    No, I do not recommend anything - I explain where the problem comes from so you can make decision. I do not know what or who requires this package to make any recommendations.

    Other two problems are related to Perl update as well.

    Waiting couple of days until third party repo catches up and rebuilds dependent packages is just as viable option as any. If this does not happen in reasonable time, contact maintainer.

  5. #5
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Another zypper dup puzzle; 3 Problems: yast2-apparmor-4.0.0-1.2.noarch, perl-5.24.1-1.7.x86_64,

    Thanks. I'll wait a while then, & hope that something improves next time i try.

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 9
    Posts
    14,581

    Default Re: Another zypper dup puzzle; 3 Problems: yast2-apparmor-4.0.0-1.2.noarch, perl-5.24.1-1.7.x86_64,

    Note you can see dependencies in Yast -software Management on one of the tabs bottom right. Also you can search for requires or provides.

  7. #7
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Another zypper dup puzzle; 3 Problems: yast2-apparmor-4.0.0-1.2.noarch, perl-5.24.1-1.7.x86_64,

    Quote Originally Posted by gogalthorp View Post
    Note you can see dependencies in Yast -software Management on one of the tabs bottom right. Also you can search for requires or provides.
    Thanks. A day later, the Problems have reduced to two, not the original three [#1 is now gone]. Those remaining warnings pertain to Shutter. Having TW running properly, including still with all my desired pgms, is "critical" on my Tower, but only "important" on my Lappy. Hence i decided to use the latter as a guinea pig. For current Problem 1 [previously = Problem 2] i tried Solution 1 [ie, retain the myriad obsolete versions of all the dependencies]. That proved unviable, as it then lead to a cascading torrent of several dozen extra Problems. I aborted that dup, & tried again, this time choosing Solution 2... deinstall Shutter. That lead to Problem 2 [was #3] getting focus, for which i again chose Solution 2, remove Shutter. Thereafter the dup proceeded without incident, as did the Lappy reboot. Once back at my desktop, i attempted to install Shutter again, but as anticipated i now cannot, due to unmet dependencies.

    Code:
    gooeygirl@linux-Lappy:~> zypper if shutter
    Loading repository data...
    Reading installed packages...
    
    
    
    
    Information for package shutter:
    --------------------------------
    Repository     : Main Repository (OSS)     
    Name           : shutter                   
    Version        : 0.94-1.2                  
    Arch           : noarch                    
    Vendor         : openSUSE                  
    Installed Size : 13.5 MiB                  
    Installed      : No                        
    Status         : not installed             
    Source package : shutter-0.94-1.2.src      
    Summary        : Featureful screenshot tool
    Description    :                           
        Shutter is a GTK+ 2.0 screenshot application written in perl.
        Shutter covers all features of common command line tools like
        scrot or import and adds reasonable new features combined
        with a comfortable GUI using the GTK+ 2.0 framework
    
    
    gooeygirl@linux-Lappy:~> sudo zypper in shutter
    [sudo] password for root: 
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    
    Problem: nothing provides perl(Gtk2::Unique) needed by shutter-0.94-1.2.noarch
     Solution 1: do not install shutter-0.94-1.2.noarch
     Solution 2: break shutter-0.94-1.2.noarch by ignoring some of its dependencies
    
    
    Choose from above solutions by number or cancel [1/2/c] (c): 
    gooeygirl@linux-Lappy:~>
    For me, Shutter is a major-important utility pgm. Whilst i can get by without it on Lappy for a temporary period, i cannot on Tower. Hence sadly i feel i cannot upgrade Tower from its present 20170928 to Lappy's now 20171005.

    I imagine that squillions of other users equally regard Shutter as vital. Is is reasonable for me to assume, therefore, that it might only be days rather than weeks or months before Shutter is recompiled against the new dependencies & once again available?

  8. #8
    Join Date
    Sep 2012
    Posts
    4,132

    Default Re: Another zypper dup puzzle; 3 Problems: yast2-apparmor-4.0.0-1.2.noarch, perl-5.24.1-1.7.x86_64,

    Quote Originally Posted by GooeyGirl View Post
    Code:
    Problem: nothing provides perl(Gtk2::Unique) needed by shutter-0.94-1.2.noarch
    Open bug report. perl-Gtk2-Unique was deleted a month ago; either shutter has to be updated to not require it or package has to go back.
    Code:
    519980  State:accepted   By:dimstar_suse When:2017-09-05T13:12:57        delete:                                                             openSUSE:Factory/perl-Gtk2-Unique
            Review by Group      is accepted:  legal-auto(licensedigger)                         
            Review by Group      is accepted:  factory-auto(factory-auto)                        
            Review by Group      is accepted:  factory-staging(staging-bot)                      
            Review by Package    is accepted:  devel:languages:perl/perl-Gtk2-Unique(coolo)      
            Review by User       is accepted:  repo-checker(repo-checker)                        
            Review by Project    is accepted:  openSUSE:Factory:Staging:B(dimstar_suse)          
            Descr: osc whatdependson perl-Gtk2-Unique comes back empthy and so does
                   zypper se --requires --recommends perl-Gtk2-Unique  -- Remove
                   what seems to be an obsolete package that depends on libunique1
                   (old compat package)
            Comment: Accept to openSUSE:Factory

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    23,219
    Blog Entries
    15

    Default Re: Another zypper dup puzzle; 3 Problems: yast2-apparmor-4.0.0-1.2.noarch, perl-5.24.1-1.7.x86_64,

    Quote Originally Posted by GooeyGirl View Post
    Thanks. A day later, the Problems have reduced to two, not the original three [#1 is now gone]. Those remaining warnings pertain to Shutter. Having TW running properly, including still with all my desired pgms, is "critical" on my Tower, but only "important" on my Lappy. Hence i decided to use the latter as a guinea pig. For current Problem 1 [previously = Problem 2] i tried Solution 1 [ie, retain the myriad obsolete versions of all the dependencies]. That proved unviable, as it then lead to a cascading torrent of several dozen extra Problems. I aborted that dup, & tried again, this time choosing Solution 2... deinstall Shutter. That lead to Problem 2 [was #3] getting focus, for which i again chose Solution 2, remove Shutter. Thereafter the dup proceeded without incident, as did the Lappy reboot. Once back at my desktop, i attempted to install Shutter again, but as anticipated i now cannot, due to unmet dependencies.

    Code:
    gooeygirl@linux-Lappy:~> zypper if shutter
    Loading repository data...
    Reading installed packages...
    
    
    
    
    Information for package shutter:
    --------------------------------
    Repository     : Main Repository (OSS)     
    Name           : shutter                   
    Version        : 0.94-1.2                  
    Arch           : noarch                    
    Vendor         : openSUSE                  
    Installed Size : 13.5 MiB                  
    Installed      : No                        
    Status         : not installed             
    Source package : shutter-0.94-1.2.src      
    Summary        : Featureful screenshot tool
    Description    :                           
        Shutter is a GTK+ 2.0 screenshot application written in perl.
        Shutter covers all features of common command line tools like
        scrot or import and adds reasonable new features combined
        with a comfortable GUI using the GTK+ 2.0 framework
    
    
    gooeygirl@linux-Lappy:~> sudo zypper in shutter
    [sudo] password for root: 
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    
    Problem: nothing provides perl(Gtk2::Unique) needed by shutter-0.94-1.2.noarch
     Solution 1: do not install shutter-0.94-1.2.noarch
     Solution 2: break shutter-0.94-1.2.noarch by ignoring some of its dependencies
    
    
    Choose from above solutions by number or cancel [1/2/c] (c): 
    gooeygirl@linux-Lappy:~>
    For me, Shutter is a major-important utility pgm. Whilst i can get by without it on Lappy for a temporary period, i cannot on Tower. Hence sadly i feel i cannot upgrade Tower from its present 20170928 to Lappy's now 20171005.

    I imagine that squillions of other users equally regard Shutter as vital. Is is reasonable for me to assume, therefore, that it might only be days rather than weeks or months before Shutter is recompiled against the new dependencies & once again available?
    Hi
    Does it break if you choose option 2? If not, rock on...

    Use cpan to install direct, or install direct from the development repo;

    Code:
    zypper in https://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Tumbleweed/x86_64/perl-Gtk2-Unique-0.05-8.16.x86_64.rpm
    BTW, up to 20171006 now....

    I guess I'm not in the squillions then.... A bug report (but I guess that won't happen), or the Factory Mailing List, put a comment on the build project, ping the maintainer, jump on IRC Freenode #opensuse-factory or even branch the project and remove the requires and test/submit. Lots of ways to do thing since it's a Community distribution

    Development Project: https://build.opensuse.org/package/s...lities/shutter
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2 (x86_64) GNOME 3.20.2
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Another zypper dup puzzle; 3 Problems: yast2-apparmor-4.0.0-1.2.noarch, perl-5.24.1-1.7.x86_64,

    Quote Originally Posted by arvidjaar View Post
    Open bug report. perl-Gtk2-Unique was deleted a month ago; either shutter has to be updated to not require it or package has to go back.
    Code:
    519980  State:accepted   By:dimstar_suse When:2017-09-05T13:12:57        delete:                                                             openSUSE:Factory/perl-Gtk2-Unique
            Review by Group      is accepted:  legal-auto(licensedigger)                         
            Review by Group      is accepted:  factory-auto(factory-auto)                        
            Review by Group      is accepted:  factory-staging(staging-bot)                      
            Review by Package    is accepted:  devel:languages:perl/perl-Gtk2-Unique(coolo)      
            Review by User       is accepted:  repo-checker(repo-checker)                        
            Review by Project    is accepted:  openSUSE:Factory:Staging:B(dimstar_suse)          
            Descr: osc whatdependson perl-Gtk2-Unique comes back empthy and so does
                   zypper se --requires --recommends perl-Gtk2-Unique  -- Remove
                   what seems to be an obsolete package that depends on libunique1
                   (old compat package)
            Comment: Accept to openSUSE:Factory
    Thanks for the info. I would happily create a bug-report if it did not entail foregoing my privacy. Given it does, sadly i can't/won't. Frankly i'm astonished that the system was designed without apparent consideration or regard for privacy. Not everyone wants their name & email address on public display.

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •