Results 1 to 7 of 7

Thread: zypper dup tells me, my Desktop will be deleted!

  1. #1

    Default zypper dup tells me, my Desktop will be deleted!


    Hi,

    I did an update of tumbleweed after several months (I had been told in this forum not to use the automatic, graphical update thing in KDE and, well, now I only remember doing it now or then). According to the advice here I used:

    Code:
    zypper dup --no-allow-vendor-change
    As usual I was asked whether I agree to a vendor change anyway, as there seems to be some inconsistency between files from the packman repository and the openSUSE one. I de-installed kaffeine because kaffeine was mentioned in these inconsistencies but that didn't help. In the end I was forced to agree in order to do the update.

    The update ran fine for many hundred files but then I got one error:
    Code:
    Paket pim-sieve-editor-lang-17.08.1-1.1.noarch abrufen                      (4791/4806), 366,5 KiB (683,8 KiB entpackt)
    Abrufen: pim-sieve-editor-lang-17.08.1-1.1.noarch.rpm .........................................................[fertig]
    Paket gstreamer-plugins-bad-1.12.3-5.3.x86_64 abrufen                       (4792/4806),   1,4 MiB (  4,9 MiB entpackt)
    Abrufen: gstreamer-plugins-bad-1.12.3-5.3.x86_64.rpm ..........................................................[Fehler]
    Datei './Essentials/x86_64/gstreamer-plugins-bad-1.12.3-5.3.x86_64.rpm' auf Medium 'http://packman.inode.at/suse/openSUSE_Tumbleweed/' nicht gefunden
    
    Abbrechen, wiederholen, ignorieren? [a/w/i/? zeigt alle Optionen] (a): w
    Abrufen: gstreamer-plugins-bad-1.12.3-5.3.x86_64.rpm ..........................................................[Fehler]
    Datei './Essentials/x86_64/gstreamer-plugins-bad-1.12.3-5.3.x86_64.rpm' auf Medium 'http://packman.inode.at/suse/openSUSE_Tumbleweed/' nicht gefunden
    
    Abbrechen, wiederholen, ignorieren? [a/w/i/? zeigt alle Optionen] (a): i
    Warnung: Ihre Wahl, ein Problem mit dem Herunterladen oder der Installation eines Pakets zu ignorieren, führt möglicherweise zu beschädigten Abhängigkeiten anderer Pakete. Es wird empfohlen, nach Beenden des Vorgangs 'zypper verify' auszuführen.
    Paket libmlt6-modules-6.4.1-13.5.x86_64 abrufen                             (4793/4806),   1,7 MiB ( 33,6 MiB entpackt)
    Abrufen: libmlt6-modules-6.4.1-13.5.x86_64.rpm ................................................................[Fehler]
    Datei './Essentials/x86_64/libmlt6-modules-6.4.1-13.5.x86_64.rpm' auf Medium 'http://packman.inode.at/suse/openSUSE_Tumbleweed/' nicht gefunden
    
    Abbrechen, wiederholen, ignorieren? [a/w/i/? zeigt alle Optionen] (a): i
    Warnung: Ihre Wahl, ein Problem mit dem Herunterladen oder der Installation eines Pakets zu ignorieren, führt möglicherweise zu beschädigten Abhängigkeiten anderer Pakete. Es wird empfohlen, nach Beenden des Vorgangs 'zypper verify' auszuführen.
    Paket vlc-beta-noX-3.0.0.20170822.ceacd64e17-3.7.x86_64 abrufen             (4794/4806),   3,9 MiB ( 13,8 MiB entpackt)
    Abrufen: vlc-beta-noX-3.0.0.20170822.ceacd64e17-3.7.x86_64.rpm ................................................[Fehler]
    Datei './Essentials/x86_64/vlc-beta-noX-3.0.0.20170822.ceacd64e17-3.7.x86_64.rpm' auf Medium 'http://packman.inode.at/suse/openSUSE_Tumbleweed/' nicht gefunden
    
    Abbrechen, wiederholen, ignorieren? [a/w/i/? zeigt alle Optionen] (a): i
    Warnung: Ihre Wahl, ein Problem mit dem Herunterladen oder der Installation eines Pakets zu ignorieren, führt möglicherweise zu beschädigten Abhängigkeiten anderer Pakete. Es wird empfohlen, nach Beenden des Vorgangs 'zypper verify' auszuführen.
    Paket vlc-beta-qt-3.0.0.20170822.ceacd64e17-3.7.x86_64 abrufen              (4795/4806),   1,0 MiB (  2,9 MiB entpackt)
    Abrufen: vlc-beta-qt-3.0.0.20170822.ceacd64e17-3.7.x86_64.rpm .................................................[Fehler]
    Datei './Essentials/x86_64/vlc-beta-qt-3.0.0.20170822.ceacd64e17-3.7.x86_64.rpm' auf Medium 'http://packman.inode.at/suse/openSUSE_Tumbleweed/' nicht gefunden
    Abbrechen, wiederholen, ignorieren? [a/w/i/? zeigt alle Optionen] (a): i
    Warnung: Ihre Wahl, ein Problem mit dem Herunterladen oder der Installation eines Pakets zu ignorieren, führt möglicherweise zu beschädigten Abhängigkeiten anderer Pakete. Es wird empfohlen, nach Beenden des Vorgangs 'zypper verify' auszuführen.
    Paket vlc-beta-3.0.0.20170822.ceacd64e17-3.7.x86_64 abrufen                 (4796/4806), 201,5 KiB (353,2 KiB entpackt)
    Abrufen: vlc-beta-3.0.0.20170822.ceacd64e17-3.7.x86_64.rpm ....................................................[Fehler]
    Datei './Essentials/x86_64/vlc-beta-3.0.0.20170822.ceacd64e17-3.7.x86_64.rpm' auf Medium 'http://packman.inode.at/suse/openSUSE_Tumbleweed/' nicht gefunden
    
    Abbrechen, wiederholen, ignorieren? [a/w/i/? zeigt alle Optionen] (a): i
    Warnung: Ihre Wahl, ein Problem mit dem Herunterladen oder der Installation eines Pakets zu ignorieren, führt möglicherweise zu beschädigten Abhängigkeiten anderer Pakete. Es wird empfohlen, nach Beenden des Vorgangs 'zypper verify' auszuführen.
    Paket libfarstream-0_2-5-0.2.8-1.6.x86_64 abrufen                           (4797/4806), 256,0 KiB (978,1 KiB entpackt)
    Abrufen: libfarstream-0_2-5-0.2.8-1.6.x86_64.rpm ..............................................................[fertig]
    Paket gstreamer-plugins-bad-lan
    I think these errors are related to the six files, where I was forced to agree to a vendor change, but I'm not completely sure.
    The rest of the update continued alright. According to the recommendation in the output "Es wird empfohlen, nach Beenden des Vorgangs 'zypper verify' auszuführen." (it is recommended to execute zypper verify) I entered this and got:
    Code:
    Paket libpurple-lang-2.12.0-5.3.noarch abrufen                              (4806/4806),   3,0 MiB ( 20,7 MiB entpackt)
    Abrufen: libpurple-lang-2.12.0-5.3.noarch.rpm .....................................................[fertig (3,7 MiB/s)]
    Die Installation wurde mit einem Fehler abgeschlossen.
    husky:~ # zypper verify
    Metadaten von Repository 'packman' abrufen ....................................................................[fertig]
    Cache für Repository 'packman' erzeugen .......................................................................[fertig]
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    
    Die folgenden 2 Anwendungen werden GELÖSCHT werden:
      Desktop "System Tray"
    
    Nach diesem Vorgang wird kein zusätzlicher Speicherplatz belegt oder freigegeben.
    Die Abhängigkeiten aller installierten Pakete sind berücksichtigt.
    "Die folgenden 2 Anwendungen werden GELÖSCHT werden:" (The following two applications will be DELETED)
    frightens me a lot, of course. I don't dare to reboot my system now, because I'm afraid to come up with no desktop as some other people did here in the forum lately, e.g.:
    HTML Code:
    https://forums.opensuse.org/showthread.php/527185-can-t-boot-after-update
    No system tray seems bad enough, but no desktop?! Sounds like a virus but seems an output of an official Linux command.

    Should I stop reboots until the next updates come up? But what about sleep-mode? Will the desktop be deleted, too?

  2. #2

    Default Re: zypper dup tells me, my Desktop will be deleted!

    Oh, just now, the system tray update thing tells me, I have 3700 updates waiting

  3. #3
    Join Date
    Sep 2012
    Posts
    7,096

    Default Re: zypper dup tells me, my Desktop will be deleted!

    Applications are not packages; they are abstraction used by GNOME Software Manager and are defined by description in special files. Sometimes these files are removed during package updates (intentionally or not). You can ignore anything related to "Applications" when running zypper.

    And please, when you run command line to post output in English language forums, set language to English, like "LC_ALL=C LANG=C zypper install".

  4. #4

    Default Re: zypper dup tells me, my Desktop will be deleted!

    OK. I did a restart and everything is still ok.
    I noted the command for changing the output language and will use it in the future, of course.

    Thank you for calming. So I consider this thread closed.

    Seeing similar questions from others here in the forum, I wonder how the zypper command made it through the reviews/approvals (by whom, by the way?) with this shocking message display. Was this at halloween perhaps?.....

  5. #5

    Default Re: zypper dup tells me, my Desktop will be deleted!

    Seems to me that TW from time to time (especially switching kernel) is having some kind of "bad-hair-day" (mostly "bad-hair-weeks", anyhow...). I simply don't upgrade/update for 1 week or so and wait for things getting fixed... ;-)
    Kind regards

    raspu

  6. #6
    Join Date
    Apr 2017
    Location
    Piemont
    Posts
    274

    Default Re: zypper dup tells me, my Desktop will be deleted!

    First you have to go to packman
    Code:
    zypper dup --from packman
    And then

    Code:
    zypper dup --no-allow-vendor-change
    But this last command is not a medicine for all evils

    And if I had to express an opinion it was much better when zypper respected the priorities.
    Now every now and then packman adds some rpm that is in OS and zypper being set "no-allow-vendor-change" .....then asks
    loyalty returns to those who practice it

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: zypper dup tells me, my Desktop will be deleted!

    Quote Originally Posted by V_idocq View Post
    First you have to go to packman
    Code:
    zypper dup --from packman
    And then

    Code:
    zypper dup --no-allow-vendor-change
    But this last command is not a medicine for all evils

    And if I had to express an opinion it was much better when zypper respected the priorities.
    Now every now and then packman adds some rpm that is in OS and zypper being set "no-allow-vendor-change" .....then asks
    Please note that not everybody's Packman repo is called "packman". If called "Packman" instead the command will not work
    The "--no-allow-vendor-change" addition doesn't do anything either, it already is the default .....
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •