Results 1 to 4 of 4

Thread: Leap 42.3 and GNU Radio and GNU radio companion and RTL2832?

  1. #1

    Default Leap 42.3 and GNU Radio and GNU radio companion and RTL2832?

    I have been trying this for some time with various versions of suse and still not there. I can get the packages to run and do flow charts etc but not connect to any real sources such as an RTL2832 device as I get an error saying can not load.

    But after I had an issue with my dual boot Win10 and leap 42.3 of loosing the option to boot both linux and windows I thought I must be on a roll and lets try it again.

    I loaded GNU radio not from the standard suse repository but from mnhauke:sdr. repository and it gave me a later version, also on the site are all the other requirements, so I installed

    gnuradio
    gr-osmosdr
    libhackrf and another few packages to give hackrf libs etc.

    But no matter what I do I can not get an RTL2832 device to work in suse linux, I have in Ubuntu but not suse

    This is the message I get when i try to run anything:
    Using device#0 Generic RTL2832U OEM
    usb_error -3
    Please fix the device permissions, e.g. by installing the udev rules file rtl-sdr.rules
    FATAL: Failed to open SDR device



    Now I have checked and I have rtl-sdr rules installed as it is part of the package rtl-sdr-udev

    I have tried adding to the blacklist in /etc/modprobe.d/50-blacklist.conf

    in fact I added the same as I needed in Ubuntu which was
    blacklist dvb_usb_rtl28xxu
    blacklist rtl2832
    blacklist rtl2838

    The above was found somewhere on the internet but worked for me in Ubuntu

    The last thing i have checked is by doing a lsusb -v command and found this:
    Bus 001 device 005: ID 0dba:2838 realtek semeconductor Corp. RTL2838 DVB-T
    Coudn't open device, some information will be missing


    it seems to be missing stuff like iManufacturer
    iProduct
    iSerial etc when compared to Ubuntu

    So wonder if there needs to be a revision of the modules?

    Please help if you can, I prefer Suse, and would love to get this all working on this laptop before I get my harkrf one.

    I am not a guru, and only barely understand what I am doing so guidance is much appreciated from anyone that has it working.

    Cheers

    Adrian

  2. #2
    Join Date
    Jul 2008
    Location
    Sweden
    Posts
    174

    Default Re: Leap 42.3 and GNU Radio and GNU radio companion and RTL2832?

    Hey, not a guru here either.

    Have you edited file
    Code:
    /usr/lib/udev/rules.d/rtl-sdr.rules
    Maybe look like something like this
    Code:
    SUBSYSTEM=="usb", ATTR{idVendor}=="0dba", ATTR{idProduct}=="2838", MODE="0666"
    Not a guru so this might not be correct. The goal is to give you permission to read and write of 2832.
    What is it in that file?
    What are the permission of the usb device?
    ASUS G46VW running openSUSE LEAP 42.1, Windows 8
    Samsung NP300V3A running openSUSE LEAP 42.1 Windows 7
    Some EEEPC running openSUSE LEAP 42.1, "Server" running sshfs, (mini)DLNA, NFS
    Raspberry Pi, Weezy, openSUSE 13.1 (two different SD-cards)

  3. #3

    Default Re: Leap 42.3 and GNU Radio and GNU radio companion and RTL2832?

    I have just delved into
    /usr/lib/udev/rules.d/rtl-sdr.rules

    and the first couple of lines are as follows:

    # original RTL2832U vid/pid (hama nano, for example)
    SUBSYSTEMS=="usb", ATTRS{idVendor}=="0bda", ATTRS{idProduct}=="2832", MODE:="0660", GROUP="rtlsdr"

    # RTL2832U OEM vid/pid, e.g. ezcap EzTV668 (E4000), Newsky TV28T (E4000/R820T) etc.
    SUBSYSTEMS=="usb", ATTRS{idVendor}=="0bda", ATTRS{idProduct}=="2838", MODE:="0660", GROUP="rtlsdr"

    So not quite the same but all the entries have MODE:="0660"

    I have gone via Yast to check the User and group settings, and added myself to the rtlsdr group.

    Up to now no difference, but will try a reboot just in case!

    OK just done a reboot and it works, so a case of the wrong permissions for me, or not automatically put into the correct groups on install????

    I know not how it all works, but quinness I thank you for putting me in the correct area.

    Adrian

    Adrian

    OK just done a re

  4. #4

    Default Re: Leap 42.3 and GNU Radio and GNU radio companion and RTL2832?

    Just thought I would add a last bit to my post about this.

    I have managed to install it all on a second computer taking the bits learned from above, but this time I did not blacklist the hardware devices rtl2832 etc.

    It looks as though once I have the user groups sorted, you do not need to blacklist anything.

    When running grc with a flow chart, I now get:

    Using device #0Realtek RTL2838UHIDIR etc
    Detached kernel driver

    So looks as though possibly with the rules it all takes care of it self.

    Hope my ignorance and a bit of learning helps others.

    Adrian

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •