Results 1 to 3 of 3

Thread: I'm unable to run AppImage applications

  1. #1

    Default I'm unable to run AppImage applications

    I'm unable to run AppImage applications in my system.

    They were running smoothly, then I had to reinstall the system, and now they don't work. The files are marked as executables of course.

    It happens with ALL AppImage files, not just for a single application (so I can rule out a problem with a particular package).

    I've tried to run them from CLI, but I get the following generic error:

    ~/Apps/FontBase> LANG=C bash FontBase.AppImage
    FontBase.AppImage: FontBase.AppImage: cannot execute binary file
    Even running them with sudo isn't helping.

  2. #2
    Join Date
    Jun 2008
    San Diego, Ca, USA
    Blog Entries

    Default Re: I'm unable to run AppImage applications

    When you're troubleshooting an app you start manually, it's useful to view the generated system log entries.

    1. Prepare to invoke your AppImage app, but don't actually invoke yet.
    2. Open a console, elevate to root and run the following command which will display your system log entries in real time
    journalctl -f
    3. Now, invoke your AppImage app and view your results in the console running journalctl, you will see only what is related to your fail.

    Beginner Wiki Quickstart -
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: I'm unable to run AppImage applications

    Thank you, I already managed to solve this by changing permissions to "usr/bin/fusermount", as described here:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts