Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Restricted Codecs etc

  1. #1

    Question Restricted Codecs etc

    Hallo zusammen.

    Ich habe heute LEAP 42.3 installiert:

    VLC ist es nicht möglich h264 Videos abzuspielen.

    Informationen:

    Code:
    VLC in der Shell gestartet:
    [00007fe3d8c598b8] gstdecode decoder error: no suitable decoder found
    [00007fe3d8c598b8] core decoder error: Codec `h264' (H264 - MPEG-4 AVC (part 10)) is not supported.
    Code:
     sudo zypper se H264
    [sudo] Passwort für root: 
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    
    S | Name    | Zusammenfassung                           | Typ       
    --+---------+-------------------------------------------+-----------
      | h264enc | An advanced CLI shell script for MEncoder | Paket     
      | h264enc | An advanced CLI shell script for MEncoder | Quellpaket
    Code:
    sudo zypper se libx264-148
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    
    S | Name                        | Zusammenfassung                           | Typ  
    --+-----------------------------+-------------------------------------------+------
    i | libx264-148                 | A free h264/avc encoder - encoder binary  | Paket
      | libx264-148-32bit           | A free h264/avc encoder - encoder binary  | Paket
      | libx264-148-debuginfo       | Debug information for package libx264-148 | Paket
      | libx264-148-debuginfo-32bit | Debug information for package libx264-148 | Paket

    Code:
    #  | Alias                     | Name                                    | Aktiviert | GPG-Überprüfung | Aktualisierung
    ---+---------------------------+-----------------------------------------+-----------+-----------------+---------------
     1 | Google-Chrome             | Google-Chrome                           | Ja        | ( p) Ja         | Nein          
     2 | Packman-Repo              | Packman-Repo                            | Ja        | (r ) Ja         | Ja            
     3 | google-chrome             | google-chrome                           | Ja        | (r ) Ja         | Ja            
     4 | openSUSE-Leap-42.3-0      | openSUSE-Leap-42.3-0                    | Ja        | (r ) Ja         | Nein          
     5 | repo-debug                | openSUSE-Leap-42.3-Debug                | Nein      | ----            | ----          
     6 | repo-debug-non-oss        | openSUSE-Leap-42.3-Debug-Non-Oss        | Nein      | ----            | ----          
     7 | repo-debug-update         | openSUSE-Leap-42.3-Update-Debug         | Nein      | ----            | ----          
     8 | repo-debug-update-non-oss | openSUSE-Leap-42.3-Update-Debug-Non-Oss | Nein      | ----            | ----          
     9 | repo-non-oss              | openSUSE-Leap-42.3-Non-Oss              | Ja        | (r ) Ja         | Ja            
    10 | repo-oss                  | openSUSE-Leap-42.3-Oss                  | Ja        | (r ) Ja         | Ja            
    11 | repo-source               | openSUSE-Leap-42.3-Source               | Nein      | ----            | ----          
    12 | repo-source-non-oss       | openSUSE-Leap-42.3-Source-Non-Oss       | Nein      | ----            | ----          
    13 | repo-update               | openSUSE-Leap-42.3-Update               | Ja        | (r ) Ja         | Ja            
    14 | repo-update-non-oss       | openSUSE-Leap-42.3-Update-Non-Oss       | Ja        | (r ) Ja         | Ja

    Eine Idee?

    Grüße und Danke!

  2. #2
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    409

    Default AW: Restricted Codecs etc

    Eventuell dürfte ein
    Code:
    zypper dup --from Packman-Repo
    schon ausreichen. Ansonsten führe noch die Ausgaben von
    Code:
    zypper lr -d
    und
    Code:
    zypper se -si vlc gst
    vor.

  3. #3

    Default Re: Restricted Codecs etc

    Hallo tomm_fa,

    huaahhh. Nach

    Code:
    zypper dup --from Packman-Repo
    tauchen 26 Abhängigkeitsprobleme auf.
    26 Pakete werden benötigt, die aber nirgends zu Verfügung stehen. Da muss etwas falsch gelaufen sein.
    Ich habe nach Anleitung das pacman Reposi installiert und priorisiert (20). Hmmmh..

    Infos:
    Code:
    zypper lr -d
    Repository-Prioritäten treten in Kraft:                                                                  (Siehe 'zypper lr -P' für Details)
          20 (erhöhte Priorität)  :  1 Repository                                                                                              
          70 (erhöhte Priorität)  :  1 Repository                                                                                              
          99 (Standard-Priorität) :  6 Repositorys                                                                                             
                                                                                                                                               
    #  | Alias                     | Name                                    | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ    | URI                                                                        | Dienst                                                    
    ---+---------------------------+-----------------------------------------+-----------+-----------------+----------------+-----------+--------+----------------------------------------------------------------------------+-------                                                    
     1 | Google-Chrome             | Google-Chrome                           | Ja        | ( p) Ja         | Nein           |   99      | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                        |                                                           
     2 | Packman-Repo              | Packman-Repo                            | Ja        | (r ) Ja         | Ja             |   20      | rpm-md | http://packman.inode.at/suse/openSUSE_11.4/                                |                                                           
     3 | google-chrome             | google-chrome                           | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                        |                                                           
     4 | openSUSE-Leap-42.3-0      | openSUSE-Leap-42.3-0                    | Ja        | (r ) Ja         | Nein           |   99      | yast2  | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_SH-224DB_R93E6YCD407E94 |                                                           
     5 | repo-debug                | openSUSE-Leap-42.3-Debug                | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/oss/        |                                                           
     6 | repo-debug-non-oss        | openSUSE-Leap-42.3-Debug-Non-Oss        | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/distribution/leap/42.3/repo/non-oss/    |                                                           
     7 | repo-debug-update         | openSUSE-Leap-42.3-Update-Debug         | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/update/leap/42.3/oss/                   |                                                           
     8 | repo-debug-update-non-oss | openSUSE-Leap-42.3-Update-Debug-Non-Oss | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/update/leap/42.3/non-oss/               |       
     9 | repo-non-oss              | openSUSE-Leap-42.3-Non-Oss              | Ja        | (r ) Ja         | Ja             |   99      | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/          |       
    10 | repo-oss                  | openSUSE-Leap-42.3-Oss                  | Ja        | (r ) Ja         | Ja             |   99      | yast2  | http://download.opensuse.org/distribution/leap/42.3/repo/oss/              |       
    11 | repo-source               | openSUSE-Leap-42.3-Source               | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/oss/       |       
    12 | repo-source-non-oss       | openSUSE-Leap-42.3-Source-Non-Oss       | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/42.3/repo/non-oss/   |       
    13 | repo-update               | openSUSE-Leap-42.3-Update               | Ja        | (r ) Ja         | Ja             |   70      | rpm-md | http://download.opensuse.org/update/leap/42.3/oss/                         |       
    14 | repo-update-non-oss       | openSUSE-Leap-42.3-Update-Non-Oss       | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/leap/42.3/non-oss/                     |
    Code:
    zypper se -si vlc gst
    : https://pastebin.com/ZY3w3qcv

    Vielen Dank!

  4. #4
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    409

    Default AW: Re: Restricted Codecs etc

    Quote Originally Posted by D1967er View Post
    Nach

    Code:
    zypper dup --from Packman-Repo
    tauchen 26 Abhängigkeitsprobleme auf.
    26 Pakete werden benötigt, die aber nirgends zu Verfügung stehen. Da muss etwas falsch gelaufen sein.
    Dann zeige doch mal die komplette Ein- und Ausgabe, kannst ja wieder abbrechen. Diesmal aber aussagekräftiger mittels
    Code:
    zypper -vv dup --from Packman-Repo
    Jedenfalls sind vlc und vlc-cocs-gstreamer noch nicht auf die Versionen von PackMan umgestellt, auch für einige GStreamer-Pakete trifft dieses zu.

  5. #5

    Default Re: Restricted Codecs etc

    Okay, ich dachte, dass das mit der Priorisierung erledigt wäre.

    Code:
    sudo zypper -vv dup --from Packman-Repo
    [sudo] Passwort für root: 
    Ausführlichkeitsgrad: 2
    Ziel wird initialisiert
    Es wird überprüft, ob die Metadaten für Packman-Repo aktualisiert werden müssen
    Abrufen: http://packman.inode.at/suse/openSUSE_11.4/repodata/repomd.xml ...........................................................[fertig]
    Es wird überprüft, ob die Metadaten für google-chrome aktualisiert werden müssen
    Abrufen: http://dl.google.com/linux/chrome/rpm/stable/x86_64/repodata/repomd.xml ..................................................[fertig]
    Es wird überprüft, ob die Metadaten für openSUSE-Leap-42.3-Non-Oss aktualisiert werden müssen
    Abrufen: http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/content .....................................[fertig (1,2 KiB/s)]
    Abrufen: http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/media.1/media ...........................................[fertig]
    Es wird überprüft, ob die Metadaten für openSUSE-Leap-42.3-Oss aktualisiert werden müssen
    Abrufen: http://download.opensuse.org/distribution/leap/42.3/repo/oss/content .....................................................[fertig]
    Abrufen: http://download.opensuse.org/distribution/leap/42.3/repo/oss/media.1/media ...............................................[fertig]
    Es wird überprüft, ob die Metadaten für openSUSE-Leap-42.3-Update aktualisiert werden müssen
    Abrufen: http://download.opensuse.org/update/leap/42.3/oss/repodata/repomd.xml ....................................................[fertig]
    Abrufen: http://download.opensuse.org/update/leap/42.3/oss/media.1/media .......................................................[not found]
    Abrufen: http://download.opensuse.org/update/leap/42.3/oss/repodata/repomd.xml.asc ................................................[fertig]
    Abrufen: http://download.opensuse.org/update/leap/42.3/oss/repodata/repomd.xml.key ................................................[fertig]
    Abrufen: http://download.opensuse.org/update/leap/42.3/oss/repodata/repomd.xml ....................................................[fertig]
      Repository:               openSUSE-Leap-42.3-Update                           
      Name des Schlüssels:      openSUSE Project Signing Key <opensuse@opensuse.org>
      Schlüssel-Fingerabdruck:  22C07BA5 34178CD0 2EFE22AA B88B2FD4 3DBDC284        
      Schlüssel erstellt:       Mo 05 Mai 2014 10:37:40 CEST                        
      Ablauf des Schlüssels:    Do 02 Mai 2024 10:37:40 CEST                        
      RPM-Name:                 gpg-pubkey-3dbdc284-53674dd4                        
    Abrufen: http://download.opensuse.org/update/leap/42.3/oss/repodata/74f17df6c8a2085dc206686ff5a1eed046330ead11b96be636ff94dd37d0b07[fertig]
    Abrufen: http://download.opensuse.org/update/leap/42.3/oss/repodata/a7efd1f840b39bc9474548ba911776238b5513cf687bb92528a7bf54e4a7872[fertig]
    Abrufen: http://download.opensuse.org/update/leap/42.3/oss/repodata/8fa3ebeafad0c1b21243b9acf3b41a66d47cc1c2072e4bfd45c[fertig (1,5 MiB/s)]
    Abrufen: http://download.opensuse.org/update/leap/42.3/oss/repodata/277da18723412903b982f707ccb2e98cb59a067f139da80aa8aa57a2fbf3858[fertig]
    Metadaten von Repository 'openSUSE-Leap-42.3-Update' abrufen ......................................................................[fertig]
    Cache für Repository 'openSUSE-Leap-42.3-Update' erzeugen .........................................................................[fertig]
    Es wird überprüft, ob die Metadaten für openSUSE-Leap-42.3-Update-Non-Oss aktualisiert werden müssen
    Abrufen: http://download.opensuse.org/update/leap/42.3/non-oss/repodata/repomd.xml ................................................[fertig]
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    Distributions-Aktualisierungen werden verarbeitet...
    Auflösung erzwingen: Nein                                                                                                                  
    26 Probleme:                                                                                                                               
    Problem: libgcrypt.so.11 benötigt von libmtp9-1.1.11-98.1.i586 wird nirgends zur Verfügung gestellt                                        
    Problem: libudev.so.0 benötigt von libva1-1.0.15-19.4.i586 wird nirgends zur Verfügung gestellt                                            
    Problem: libicuuc.so.44 benötigt von libraptor2-0-2.0.15-7.1.i586 wird nirgends zur Verfügung gestellt
    Problem: libgcrypt.so.11 benötigt von vlc-2.2.2-3.2.i586 wird nirgends zur Verfügung gestellt
    Problem: libpng14.so.14 benötigt von vlc-noX-2.2.2-3.2.i586 wird nirgends zur Verfügung gestellt
    Problem: libpng14.so.14 benötigt von gstreamer-0_10-plugins-good-0.10.31-89.3.i586 wird nirgends zur Verfügung gestellt
    Problem: libpng14.so.14 benötigt von libquicktime0-1.2.4cvs20150223-71.2.i586 wird nirgends zur Verfügung gestellt
    Problem: libpcre.so.0 benötigt von librasqal3-0.9.33-2.1.i586 wird nirgends zur Verfügung gestellt
    Problem: libpng14.so.14 benötigt von mjpegtools-2.0.0-64.1.i586 wird nirgends zur Verfügung gestellt
    Problem: libgcrypt.so.11 benötigt von libavformat56-2.8.20160302.f9f9f31-1.2.i586 wird nirgends zur Verfügung gestellt
    Problem: libpng14.so.14 benötigt von libsox3-14.4.2-39.1.i586 wird nirgends zur Verfügung gestellt
    Problem: libGLEW.so.1.5 benötigt von libprojectM2-2.1.0-29.1.i586 wird nirgends zur Verfügung gestellt
    Problem: libgnutls.so.26 benötigt von libavformat57-3.0.1-64.1.i586 wird nirgends zur Verfügung gestellt
    Problem: perl = 5.12.3 benötigt von perl-Module-Runtime-0.014-19.2.noarch wird nirgends zur Verfügung gestellt
    Problem: libpng14.so.14 benötigt von dvdauthor-0.6.18-3.7.i586 wird nirgends zur Verfügung gestellt
    Problem: libpng14.so.14()(64bit) benötigt von vlc-noX-2.2.2-3.2.x86_64 wird nirgends zur Verfügung gestellt
    Problem: pulseaudio-9.0-5.1.x86_64 benötigt liborc-0_4-0 = 0.4.24, kann jedoch nicht zur Verfügung gestellt werden
    Problem: amarok-2.8.0-19.1.x86_64 benötigt libtag1 >= 1.11, kann jedoch nicht zur Verfügung gestellt werden
    Problem: libgcrypt.so.11()(64bit) benötigt von libmtp9-1.1.11-98.1.x86_64 wird nirgends zur Verfügung gestellt
    Problem: libgnutls.so.26()(64bit) benötigt von libavformat57-3.0.1-64.1.x86_64 wird nirgends zur Verfügung gestellt
    Problem: vlc-noX-2.2.6-3.1.x86_64 benötigt libvlccore8 = 2.2.6-3.1, kann jedoch nicht zur Verfügung gestellt werden
    Problem: vlc-noX-2.2.6-3.1.x86_64 benötigt libvlc5 = 2.2.6-3.1, kann jedoch nicht zur Verfügung gestellt werden
    Problem: libgnutls.so.26()(64bit) benötigt von libavformat57-3.0.1-64.1.x86_64 wird nirgends zur Verfügung gestellt
    Problem: libgcrypt.so.11()(64bit) benötigt von libavformat56-2.8.20160302.f9f9f31-1.2.x86_64 wird nirgends zur Verfügung gestellt
    Problem: libgnutls.so.26()(64bit) benötigt von libavformat57-3.0.1-64.1.x86_64 wird nirgends zur Verfügung gestellt
    Problem: amarok-2.8.0-19.1.x86_64 benötigt libtag1 >= 1.11, kann jedoch nicht zur Verfügung gestellt werden
    
    Problem: libgcrypt.so.11 benötigt von libmtp9-1.1.11-98.1.i586 wird nirgends zur Verfügung gestellt
     Lösung 1: Folgende Aktionen werden ausgeführt:
      Deinstallation von libmtp9-1.1.13-3.1.x86_64
      Deinstallation von kio_mtp-0.75-8.1.x86_64
      Deinstallation von kio-extras5-17.04.2-2.1.x86_64
      Deinstallation von gvfs-backends-1.28.3-4.5.x86_64
      Deinstallation von kio-extras5-lang-17.04.2-2.1.noarch
      Deinstallation von plasma5-workspace-5.8.7-6.1.x86_64
      Deinstallation von gvfs-backend-samba-1.28.3-4.5.x86_64
      Deinstallation von plasma5-desktop-5.8.7.1-3.1.x86_64
      Deinstallation von patterns-openSUSE-kde_plasma-20170518-6.1.x86_64
      Deinstallation von plasma5-session-5.8.7-2.1.noarch
      Deinstallation von plasma5-workspace-branding-openSUSE-42.1.1-19.1.noarch
      Deinstallation von plasma5-workspace-lang-5.8.7-6.1.noarch
      Deinstallation von sddm-theme-openSUSE-42.1.1-19.1.noarch
      Deinstallation von patterns-openSUSE-kde_imaging-20170518-6.1.x86_64
      Deinstallation von patterns-openSUSE-kde-20170518-6.1.x86_64
      Deinstallation von sddm-branding-openSUSE-0.14.0-5.1.x86_64
      Deinstallation von plasma5-desktop-lang-5.8.7.1-3.1.noarch
     Lösung 2: veraltetes libmtp9-1.1.13-3.1.x86_64 beibehalten
     Lösung 3: libmtp9-1.1.11-98.1.i586 durch Ignorieren einiger Abhängigkeiten brechen
    Danke für Deine Hilfe!

  6. #6
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    409

    Default AW: Re: Restricted Codecs etc

    Quote Originally Posted by D1967er View Post
    Okay, ich dachte, dass das mit der Priorisierung erledigt wäre.
    Die Prioritäten sind nur von Interesse wenn ein Paket installiert wird und dieses von verschiedenen Repositorien zur Verfügung gestellt wird.

    Quote Originally Posted by D1967er View Post
    Code:
    sudo zypper -vv dup --from Packman-Repo
    [sudo] Passwort für root: 
    Ausführlichkeitsgrad: 2
    Ziel wird initialisiert
    […]
      Deinstallation von plasma5-desktop-lang-5.8.7.1-3.1.noarch
     Lösung 2: veraltetes libmtp9-1.1.13-3.1.x86_64 beibehalten
     Lösung 3: libmtp9-1.1.11-98.1.i586 durch Ignorieren einiger Abhängigkeiten brechen
    Wähle Lösung Zwei und führe es hier vor. Mir tauchen da einfach zuviele i586-Pakete auf.

  7. #7

    Default Re: Restricted Codecs etc

    Hallo,

    immer Lösung zwei oder nur das eine?

    Code:
    Deinstallation von plasma5-desktop-lang-5.8.7.1-3.1.noarch  Lösung 2: veraltetes libmtp9-1.1.13-3.1.x86_64 beibehalten
     Lösung 3: libmtp9-1.1.11-98.1.i586 durch Ignorieren einiger Abhängigkeiten brechen
    Also immer das veraltete behalten?

    Edit: Ja, dass mit den 586er Paketen ist mir jetzt auch aufgefallen, wo kommen die bloß her?

  8. #8
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    409

    Default AW: Re: Restricted Codecs etc

    Quote Originally Posted by D1967er View Post
    immer Lösung zwei oder nur das eine?
    Es dürfte nicht immer auf Lösung Zwei hinauslaufen, es kann sich ändern.

    Quote Originally Posted by D1967er View Post
    Code:
    Deinstallation von plasma5-desktop-lang-5.8.7.1-3.1.noarch  Lösung 2: veraltetes libmtp9-1.1.13-3.1.x86_64 beibehalten
     Lösung 3: libmtp9-1.1.11-98.1.i586 durch Ignorieren einiger Abhängigkeiten brechen
    Also immer das veraltete behalten?
    Diesmal wieder ja. Du könntest es bis dorthin durchziehen wo dann die Meldung mit Anbieterwechsel auf Packman erscheint. Möchtest du auf der sicheren Seite sein dann machst du es so wie bisher und meldest dich hier falls du unsicher bist.
    So nebenbei kannst du noch die Ausgabe von
    Code:
    zypper se -si libmtp9
    hier vorführen.

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,726

    Default AW: Restricted Codecs etc

    Da würde ich mal das passende Repo einbinden:
    2 | Packman-Repo | Packman-Repo | Ja | (r ) Ja | Ja | 20 | rpm-md | http://packman.inode.at/suse/openSUSE_11.4/
    Das wäre die richtige URL:
    http://packman.inode.at/suse/openSUSE_Leap_42.3/

  10. #10

    Default Re: Restricted Codecs etc

    Das hier wird kompliziert:

    Code:
    Problem: libgcrypt.so.11()(64bit) benötigt von libavformat56-2.8.20160302.f9f9f31-1.2.x86_64 wird nirgends zur Verfügung gestellt
     Lösung 1: Folgende Aktionen werden ausgeführt:
      veraltetes libavcodec56-2.8.13-32.1.x86_64 beibehalten
      veraltetes libavutil54-2.8.13-32.1.x86_64 beibehalten
      veraltetes libswresample1-2.8.13-32.1.x86_64 beibehalten
     Lösung 2: Folgende Aktionen werden ausgeführt:
      libffms2-3-2.19.2-4.1.i586 trotz der nachrangigen Architektur installieren
      libavformat56-32bit-2.8.13-32.1.x86_64 aus dem ausgeschlossenen Repository installieren
     Lösung 3: Deinstallation von libffms2-3-2.19.2-4.1.x86_64
     Lösung 4: libavformat56-2.8.20160302.f9f9f31-1.2.x86_64 durch Ignorieren einiger Abhängigkeiten brechen
    Wird es nicht einfacher sein, dass System neu aufzuspielen und eine aktuelle Anleitung zu nehmen, die codecs aufzuspielen?
    Irgendwo sind da ja 586 Repos reingeflutscht..

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •