Results 1 to 6 of 6

Thread: Switch Grub to proper target architecture after UEFI/BIOS install

  1. #1

    Default Switch Grub to proper target architecture after UEFI/BIOS install

    Hi everyone,

    sorry for the probable bad choice of topic name, but I don't know how else to express it.

    I have the following situation: Installed Tumbleweed on my x270 switched to Legacy Boot mode. I forced Grub2 EFI to be installed, however, it still tried to install the i386 version.
    So, now I have a system running in UEFI secure-boot mode after manually running grub2-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=opensuse from the rescue system.
    Whenever I perform a kernel update, it goes back to a non-working grub2 setup, so I either have to remember to manually run the command after the update, or take a trip to the rescue system.
    So, my question is, where is the config file, I need to fix to make the proper settings stick?

    Thanks for any help!

    Cheers

  2. #2
    Join Date
    Sep 2012
    Posts
    7,095

    Default Re: Switch Grub to proper target architecture after UEFI/BIOS install

    Go to YaST - bootloader module and change bootloader type to GRUB2-EFI.

  3. #3

    Default Re: Switch Grub to proper target architecture after UEFI/BIOS install

    Quote Originally Posted by arvidjaar View Post
    Go to YaST - bootloader module and change bootloader type to GRUB2-EFI.
    That is already set properly.

  4. #4
    Join Date
    Sep 2012
    Posts
    7,095

    Default Re: Switch Grub to proper target architecture after UEFI/BIOS install

    Quote Originally Posted by Adrixan View Post
    That is already set properly.
    OK, let's step back. If your computer is configured for EFI boot, even if you run grub2-install for i386-pc it does not really change anything - it will simply write boot block, but that will not affect EFI boot in any way. Conversely, if your computer is set to attempt legacy boot first, running your command after BIOS grub2 is already installed also will not change anything - BIOS grub2 remains where it was, it is not deleted.

    So please describe from the very beginning step by step - what happens when your computer boots and what you see.

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Switch Grub to proper target architecture after UEFI/BIOS install

    As arvidjaar describes, I can't think of any way the boot method or architecture has anything to do with the installed architecture.

    Are you sure the problem isn't the install source?
    Be sure you're installing using the TW x64 image, not the i386 image.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #6

    Default Re: Switch Grub to proper target architecture after UEFI/BIOS install

    Ok, I've checked it through.
    It seems just doing it once inside the rescue system was enough to get it working properly from that point on.
    I've had troubles with a past installation and so I just tried avoiding the situation too much.

    Anyhow, it is resolved and you are right.
    It suffices to choose grub-efi during installation, then fix it once in the rescue system and when new kernel updates, etc. arrive, it works properly.

    Thanks for your help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •