Results 1 to 6 of 6

Thread: Spectacle won't start when pressing PrintScreen button on keyboard

  1. #1

    Lightbulb Spectacle won't start when pressing PrintScreen button on keyboard

    Hi all,
    Not sure why but it just happen and Spectacle not starting when pressing [PrtScr] button on key board, but usually it was fine.. Now few last times it doesn't and even after rebooting the system.. I have checked settings in Global Shortcut - System Settings and Custom Shortcut - System Settings and all settings set as needed and by default, as you can see in pictures I have attached, but Spectacle not starting even after reapplying keypad settings. By the way, all other applications and other commands works just fine when I was testing adjacent shortcuts. Also I have Updated Unconditionally Spectacle in YaST Install/Remove Software, but with no luck..
    Any ideas why and how it can be fixed?



    Last edited by tasik; 03-Oct-2017 at 11:47. Reason: spell error corecting

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,869

    Default Re: Spectacle won't start when pressing PrintScreen button on keyboard

    I do not know what happened to your images, but what I get clicking on them is barely readable.

    Maybe better post them on http://paste.opensuse.org ?
    Henk van Velden

  3. #3
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,165

    Default Re: Spectacle won't start when pressing PrintScreen button on keyboard

    Did you happen to have a context menu open anywhere at the time you tried to invoke Spectacle?

    I'm unable to check on 42.3 at the moment, but on Tumbleweed there seems to be a bug (which, coincidentally, I reported just a few minutes before reading your post) that inhibits spectacle from opening when a context menu is being displayed.

    https://bugs.kde.org/show_bug.cgi?id=385357
    Regards, Paul

    Tumbleweed (Snapshot: 20190814) KDE Plasma 5 ~~~
    Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected
    Leap 15.0 KDE Plasma 5 ~~~ Leap 15.1 KDE Plasma 5 (Work in progress...)

  4. #4

    Default Re: Spectacle won't start when pressing PrintScreen button on keyboard

    I don't know if I can edit my first post after somebody already commented on it.
    Someone said that pictures I have added to first post is not readable so will add them again.



  5. #5

    Default Re: Spectacle won't start when pressing PrintScreen button on keyboard

    By the way.. For some reason, after another reboot it started working.. I think its just KDE glitch.

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,869

    Default Re: Spectacle won't start when pressing PrintScreen button on keyboard

    Nice it works again. But on the other hand, it is always a bit frustrating when one can not say: I know what it was, I repaired it and thus it will not return.

    BTW that other place you put the pictures on asks me to allow a lot of third party sites to run scripts. I am not sure everybody will allow that. Why not using the openSUSE site I advised?
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •